Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск значения по двум критериям - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: _Boroda_, Manyasha, SLAVICK, китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения по двум критериям (Формулы/Formulas)
Поиск значения по двум критериям
Fokus-pokuS Дата: Четверг, 18.03.2021, 05:09 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Доброе время суток, помогите до работать формулу пожалуйста.
К сообщению приложен файл: 2543943.xlsx(12.7 Kb)
 
Ответить
СообщениеДоброе время суток, помогите до работать формулу пожалуйста.

Автор - Fokus-pokuS
Дата добавления - 18.03.2021 в 05:09
Светлый Дата: Четверг, 18.03.2021, 06:23 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1569
Репутация: 409 ±
Замечаний: 0% ±

Excel 2010, 2013
Доброе!
Код
=ЕСЛИОШИБКА(--ПРАВБ(ЛЕВБ(B8;АГРЕГАТ(14;6;ПОИСК({"АВК";"АоРПИ"};B8);1)-5);10);"")


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДоброе!
Код
=ЕСЛИОШИБКА(--ПРАВБ(ЛЕВБ(B8;АГРЕГАТ(14;6;ПОИСК({"АВК";"АоРПИ"};B8);1)-5);10);"")

Автор - Светлый
Дата добавления - 18.03.2021 в 06:23
Fokus-pokuS Дата: Четверг, 18.03.2021, 10:13 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Светлый, Если Вашу формулу применить то другие функции формулы будут не работать, но все же спасибо что уделили время.
 
Ответить
СообщениеСветлый, Если Вашу формулу применить то другие функции формулы будут не работать, но все же спасибо что уделили время.

Автор - Fokus-pokuS
Дата добавления - 18.03.2021 в 10:13
Serge_007 Дата: Четверг, 18.03.2021, 10:34 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 13873
Репутация: 2315 ±
Замечаний: ±

Excel 2010
другие функции формулы будут не работать
Что означает эта Ваша загадочная фраза?

И почему не подходит просто
Код
=ВПР(H8;B$5:D$8;3;)*$A1
?


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
другие функции формулы будут не работать
Что означает эта Ваша загадочная фраза?

И почему не подходит просто
Код
=ВПР(H8;B$5:D$8;3;)*$A1
?

Автор - Serge_007
Дата добавления - 18.03.2021 в 10:34
Светлый Дата: Четверг, 18.03.2021, 10:43 | Сообщение № 5
Группа: Друзья
Ранг: Старожил
Сообщений: 1569
Репутация: 409 ±
Замечаний: 0% ±

Excel 2010, 2013
По Вашей формуле сделал:
Код
=ЕСЛИ($A$1;ЕСЛИ(СЧЁТ(ПОИСК({"АВК";"АоРПИ"};H8));ВПР(H8;B4:D8;3;);"");"")


Программировать проще, чем писать стихи.
 
Ответить
СообщениеПо Вашей формуле сделал:
Код
=ЕСЛИ($A$1;ЕСЛИ(СЧЁТ(ПОИСК({"АВК";"АоРПИ"};H8));ВПР(H8;B4:D8;3;);"");"")

Автор - Светлый
Дата добавления - 18.03.2021 в 10:43
Egyptian Дата: Четверг, 18.03.2021, 11:22 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 95
Репутация: 39 ±
Замечаний: 0% ±

Excel 2013/2016
Еще вариант:
Код
=LOOKUP(1;1/((MAX(IFERROR(SEARCH({"АВК"\"АоРПИ"};H5);0))*($A$5:$A$8=F5))*($A$1<>0));$D$5:$D$8)
К сообщению приложен файл: find.xlsx(12.2 Kb)
 
Ответить
СообщениеЕще вариант:
Код
=LOOKUP(1;1/((MAX(IFERROR(SEARCH({"АВК"\"АоРПИ"};H5);0))*($A$5:$A$8=F5))*($A$1<>0));$D$5:$D$8)

Автор - Egyptian
Дата добавления - 18.03.2021 в 11:22
Fokus-pokuS Дата: Четверг, 18.03.2021, 12:37 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Serge_007, Там ВПР не пойдет
 
Ответить
СообщениеSerge_007, Там ВПР не пойдет

Автор - Fokus-pokuS
Дата добавления - 18.03.2021 в 12:37
Fokus-pokuS Дата: Четверг, 18.03.2021, 12:38 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Светлый, спасибо огромное, работает как часики, то что нужно было)))
 
Ответить
СообщениеСветлый, спасибо огромное, работает как часики, то что нужно было)))

Автор - Fokus-pokuS
Дата добавления - 18.03.2021 в 12:38
Fokus-pokuS Дата: Четверг, 18.03.2021, 12:39 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Egyptian, и Вам спасибо большое, эта формула тоже работает четко, то что нужно)
 
Ответить
СообщениеEgyptian, и Вам спасибо большое, эта формула тоже работает четко, то что нужно)

Автор - Fokus-pokuS
Дата добавления - 18.03.2021 в 12:39
Serge_007 Дата: Четверг, 18.03.2021, 12:56 | Сообщение № 10
Группа: Админы
Ранг: Местный житель
Сообщений: 13873
Репутация: 2315 ±
Замечаний: ±

Excel 2010
Эти 3 формулы
Код
=ЕСНД(ПРОСМОТР(1;1/((МАКС(ЕСЛИОШИБКА(ПОИСК({"АВК";"АоРПИ"};H8);0))*($A$5:$A$8=F8))*($A$1<>0));$D$5:$D$8);"")
Код
=ЕСЛИ($A$1;ЕСЛИ(СЧЁТ(ПОИСК({"АВК";"АоРПИ"};H8));ВПР(H8;B4:D8;3;);"");"")
Код
=ВПР(H8;B$5:D$8;3;)*$A1

возвращают одинаковый результат

Но при этом
Egyptian, и Вам спасибо большое, эта формула тоже работает четко, то что нужно
Светлый, спасибо огромное, работает как часики, то что нужно было
Там ВПР не пойдет
Вот я и спрашиваю - Почему?


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЭти 3 формулы
Код
=ЕСНД(ПРОСМОТР(1;1/((МАКС(ЕСЛИОШИБКА(ПОИСК({"АВК";"АоРПИ"};H8);0))*($A$5:$A$8=F8))*($A$1<>0));$D$5:$D$8);"")
Код
=ЕСЛИ($A$1;ЕСЛИ(СЧЁТ(ПОИСК({"АВК";"АоРПИ"};H8));ВПР(H8;B4:D8;3;);"");"")
Код
=ВПР(H8;B$5:D$8;3;)*$A1

возвращают одинаковый результат

Но при этом
Egyptian, и Вам спасибо большое, эта формула тоже работает четко, то что нужно
Светлый, спасибо огромное, работает как часики, то что нужно было
Там ВПР не пойдет
Вот я и спрашиваю - Почему?

Автор - Serge_007
Дата добавления - 18.03.2021 в 12:56
Fokus-pokuS Дата: Пятница, 19.03.2021, 04:25 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 35
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Serge_007, Там есть строки где нет АВК и АоРПИ, если пропишу ВПР, то он будет со всех строк копировать даты, а нужны даты тока там где АВК и АоРПИ, где нет АВК и АоРПИ нужны пустые строки, что бы автоскрытие строк работало
 
Ответить
СообщениеSerge_007, Там есть строки где нет АВК и АоРПИ, если пропишу ВПР, то он будет со всех строк копировать даты, а нужны даты тока там где АВК и АоРПИ, где нет АВК и АоРПИ нужны пустые строки, что бы автоскрытие строк работало

Автор - Fokus-pokuS
Дата добавления - 19.03.2021 в 04:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения по двум критериям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!