Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подстановка значений при выборе значения из ячейки - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка значений при выборе значения из ячейки (Формулы/Formulas)
Подстановка значений при выборе значения из ячейки
Gopronotmore Дата: Понедельник, 29.03.2021, 09:50 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 167
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Добрый день, уважаемые форумчане!

Подскажите как решить данную задачку, с которой я столкнулся

Как сделать таким образом, чтобы при выборе Фамилии отображался список всех овощей которые присвоены Фамилии
К сообщению приложен файл: 6753299.xlsx(9.6 Kb)
 
Ответить
СообщениеДобрый день, уважаемые форумчане!

Подскажите как решить данную задачку, с которой я столкнулся

Как сделать таким образом, чтобы при выборе Фамилии отображался список всех овощей которые присвоены Фамилии

Автор - Gopronotmore
Дата добавления - 29.03.2021 в 09:50
Serge_007 Дата: Понедельник, 29.03.2021, 10:07 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14465
Репутация: 2384 ±
Замечаний: ±

Excel 2010
Здравствуйте

Формула массива:
Код
=ЕСЛИОШИБКА(ИНДЕКС(C$2:C$19;НАИМЕНЬШИЙ(ЕСЛИ(G$2=B$2:B$19;СТРОКА($1:$18));СТРОКА(A1)));"")
К сообщению приложен файл: 20210326_Gopron.xls(30.0 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Формула массива:
Код
=ЕСЛИОШИБКА(ИНДЕКС(C$2:C$19;НАИМЕНЬШИЙ(ЕСЛИ(G$2=B$2:B$19;СТРОКА($1:$18));СТРОКА(A1)));"")

Автор - Serge_007
Дата добавления - 29.03.2021 в 10:07
Gopronotmore Дата: Понедельник, 29.03.2021, 10:33 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 167
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Serge_007, спасибо большое! Именно то, что нужно, только один вопрос пытаюсь разобраться в логике формулы, почему строки от 1 до 18 берется когда значения
Код
СТРОКА($1:$18)
прописаны до 18???

Каков вообще принцип работы этой формулы ? Есть массив со значениями, в этом массиве мы выстраиваем от наименьшего, на этом все мо и познания по массивам закончились))))
 
Ответить
СообщениеSerge_007, спасибо большое! Именно то, что нужно, только один вопрос пытаюсь разобраться в логике формулы, почему строки от 1 до 18 берется когда значения
Код
СТРОКА($1:$18)
прописаны до 18???

Каков вообще принцип работы этой формулы ? Есть массив со значениями, в этом массиве мы выстраиваем от наименьшего, на этом все мо и познания по массивам закончились))))

Автор - Gopronotmore
Дата добавления - 29.03.2021 в 10:33
Serge_007 Дата: Понедельник, 29.03.2021, 10:37 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14465
Репутация: 2384 ±
Замечаний: ±

Excel 2010
Каков вообще принцип работы этой формулы ?
Здесь подробно: Извлечение уникальных значений формулами
Формулы почти идентичные :)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Каков вообще принцип работы этой формулы ?
Здесь подробно: Извлечение уникальных значений формулами
Формулы почти идентичные :)

Автор - Serge_007
Дата добавления - 29.03.2021 в 10:37
Gopronotmore Дата: Понедельник, 29.03.2021, 11:08 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 167
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Спасибо вам большое!
 
Ответить
СообщениеСпасибо вам большое!

Автор - Gopronotmore
Дата добавления - 29.03.2021 в 11:08
Gopronotmore Дата: Среда, 31.03.2021, 08:21 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 167
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Ребята, подскажите, думал сам справлюсь при помощи Serge_007, однако не вышло.

У меня есть список сколько было продано килограмм, как теперь сделать так, что бы в этот массив попадали только значения >0
К сообщению приложен файл: 6005155.xls(32.5 Kb)
 
Ответить
СообщениеРебята, подскажите, думал сам справлюсь при помощи Serge_007, однако не вышло.

У меня есть список сколько было продано килограмм, как теперь сделать так, что бы в этот массив попадали только значения >0

Автор - Gopronotmore
Дата добавления - 31.03.2021 в 08:21
Serge_007 Дата: Среда, 31.03.2021, 09:05 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 14465
Репутация: 2384 ±
Замечаний: ±

Excel 2010
Что должно быть в J2, если у Иванова Яблок = 0?

Не так надо?
Код
=СУММПРОИЗВ((B$2:B$19=H$2)*(C$2:C$19=I2)*D$2:D$19)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЧто должно быть в J2, если у Иванова Яблок = 0?

Не так надо?
Код
=СУММПРОИЗВ((B$2:B$19=H$2)*(C$2:C$19=I2)*D$2:D$19)

Автор - Serge_007
Дата добавления - 31.03.2021 в 09:05
Gopronotmore Дата: Среда, 31.03.2021, 09:17 | Сообщение № 8
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 167
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Serge_007, что бы массив строился только со значениями больше определенного числа, в моем случае 0
 
Ответить
СообщениеSerge_007, что бы массив строился только со значениями больше определенного числа, в моем случае 0

Автор - Gopronotmore
Дата добавления - 31.03.2021 в 09:17
Serge_007 Дата: Среда, 31.03.2021, 09:24 | Сообщение № 9
Группа: Админы
Ранг: Местный житель
Сообщений: 14465
Репутация: 2384 ±
Замечаний: ±

Excel 2010
Что должно быть в J2, если у Иванова Яблок = 0?
?


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Что должно быть в J2, если у Иванова Яблок = 0?
?

Автор - Serge_007
Дата добавления - 31.03.2021 в 09:24
Gopronotmore Дата: Среда, 31.03.2021, 15:51 | Сообщение № 10
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 167
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Serge_007, из массива должны браться значения больше 0 и отображаться. Картинку скинул, что должно получиться
К сообщению приложен файл: 6113976.jpg(16.0 Kb)
 
Ответить
СообщениеSerge_007, из массива должны браться значения больше 0 и отображаться. Картинку скинул, что должно получиться

Автор - Gopronotmore
Дата добавления - 31.03.2021 в 15:51
Pelena Дата: Среда, 31.03.2021, 16:07 | Сообщение № 11
Группа: Админы
Ранг: Местный житель
Сообщений: 17868
Репутация: 3975 ±
Замечаний: ±

Excel 2016 & Mac Excel
Просто добавьте ещё одно условие. Если, конечно, названия не повторяются у каждого персонажа
Код
=ЕСЛИОШИБКА(ИНДЕКС(C$2:C$19;НАИМЕНЬШИЙ(ЕСЛИ((H$2=B$2:B$19)*($D$2:$D$19>0);СТРОКА($1:$18));СТРОКА(A1)));"")


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПросто добавьте ещё одно условие. Если, конечно, названия не повторяются у каждого персонажа
Код
=ЕСЛИОШИБКА(ИНДЕКС(C$2:C$19;НАИМЕНЬШИЙ(ЕСЛИ((H$2=B$2:B$19)*($D$2:$D$19>0);СТРОКА($1:$18));СТРОКА(A1)));"")

Автор - Pelena
Дата добавления - 31.03.2021 в 16:07
Gopronotmore Дата: Среда, 31.03.2021, 16:11 | Сообщение № 12
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 167
Репутация: 1 ±
Замечаний: 0% ±

Excel 2007
Pelena, Спасибо!


Сообщение отредактировал Gopronotmore - Среда, 31.03.2021, 16:11
 
Ответить
СообщениеPelena, Спасибо!

Автор - Gopronotmore
Дата добавления - 31.03.2021 в 16:11
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подстановка значений при выборе значения из ячейки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!