Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Игнорирование пустых строк - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Игнорирование пустых строк (Формулы/Formulas)
Игнорирование пустых строк
kadig Дата: Суббота, 10.04.2021, 10:31 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Добрый день. Есть табличка с регламентной установленной з/п, которая считается как оклад + процент с порога. В течении года регламент начисления з/п может поменяться (например 4 раза). Есть даты и сумма выручки, Рядом с ними нужно видеть сумму начисленной з/п по регламенту. Подскажите, как проще сослаться на табличку с регламентом, игнорируя пустые ячейки регламентной таблички з/п. Думал про ЕПУСТО(), но как-то громоздко получается...
К сообщению приложен файл: 6350192.xlsx(9.3 Kb)
 
Ответить
СообщениеДобрый день. Есть табличка с регламентной установленной з/п, которая считается как оклад + процент с порога. В течении года регламент начисления з/п может поменяться (например 4 раза). Есть даты и сумма выручки, Рядом с ними нужно видеть сумму начисленной з/п по регламенту. Подскажите, как проще сослаться на табличку с регламентом, игнорируя пустые ячейки регламентной таблички з/п. Думал про ЕПУСТО(), но как-то громоздко получается...

Автор - kadig
Дата добавления - 10.04.2021 в 10:31
Nic70y Дата: Суббота, 10.04.2021, 10:51 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7017
Репутация: 1618 ±
Замечаний: 0% ±

Excel 2010
Думал про ЕПУСТО()
непонятно..
Код
=ЕСЛИ(B2>0;ВПР(A2;G$2:J$366;2);0)+ЕСЛИ(B2>ВПР(A2;G$2:J$366;3);(B2-ВПР(A2;G$2:J$366;3))*ВПР(A2;G$2:J$366;4)/100;0)
так?


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
Думал про ЕПУСТО()
непонятно..
Код
=ЕСЛИ(B2>0;ВПР(A2;G$2:J$366;2);0)+ЕСЛИ(B2>ВПР(A2;G$2:J$366;3);(B2-ВПР(A2;G$2:J$366;3))*ВПР(A2;G$2:J$366;4)/100;0)
так?

Автор - Nic70y
Дата добавления - 10.04.2021 в 10:51
kadig Дата: Воскресенье, 11.04.2021, 11:15 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, Спасибо. Формула работает
 
Ответить
СообщениеNic70y, Спасибо. Формула работает

Автор - kadig
Дата добавления - 11.04.2021 в 11:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Игнорирование пустых строк (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!