Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Функция индекс вывод строки в результате - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция индекс вывод строки в результате (Формулы/Formulas)
Функция индекс вывод строки в результате
pilot_danik Дата: Понедельник, 26.04.2021, 10:20 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Есть документ , делаю ячейку поиска для листа через функцию индекс. В результатах только значение одной ячейки, как сделать чтобы вся строка была в результате ил хотябы несколько ячеек строки.
К сообщению приложен файл: 7893539.xlsx(10.6 Kb)
 
Ответить
СообщениеЕсть документ , делаю ячейку поиска для листа через функцию индекс. В результатах только значение одной ячейки, как сделать чтобы вся строка была в результате ил хотябы несколько ячеек строки.

Автор - pilot_danik
Дата добавления - 26.04.2021 в 10:20
китин Дата: Понедельник, 26.04.2021, 10:43 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6489
Репутация: 991 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ну не знаю... типа того, но формула ну очень монструозная
Код
=ИНДЕКС(Код;НАИМЕНЬШИЙ(ЕСЛИ(ЕСЛИОШИБКА(ПОИСК($G$2;Код);0)>0;СТРОКА(Код)-СТРОКА($A$3);30);СТРОКА(ДВССЫЛ("A1:A"&ЧСТРОК(Код)))))&";"&ИНДЕКС($B$4:$B$19;НАИМЕНЬШИЙ(ЕСЛИ(ЕСЛИОШИБКА(ПОИСК($G$2;Код);0)>0;СТРОКА(Код)-СТРОКА($A$3);30);СТРОКА(ДВССЫЛ("A1:A"&ЧСТРОК(Код)))))

и дальнейшие ячейки меняйте диапазон в
Код
ИНДЕКС($B$4:$B$19;
К сообщению приложен файл: 1628231.xlsx(10.7 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениену не знаю... типа того, но формула ну очень монструозная
Код
=ИНДЕКС(Код;НАИМЕНЬШИЙ(ЕСЛИ(ЕСЛИОШИБКА(ПОИСК($G$2;Код);0)>0;СТРОКА(Код)-СТРОКА($A$3);30);СТРОКА(ДВССЫЛ("A1:A"&ЧСТРОК(Код)))))&";"&ИНДЕКС($B$4:$B$19;НАИМЕНЬШИЙ(ЕСЛИ(ЕСЛИОШИБКА(ПОИСК($G$2;Код);0)>0;СТРОКА(Код)-СТРОКА($A$3);30);СТРОКА(ДВССЫЛ("A1:A"&ЧСТРОК(Код)))))

и дальнейшие ячейки меняйте диапазон в
Код
ИНДЕКС($B$4:$B$19;

Автор - китин
Дата добавления - 26.04.2021 в 10:43
pilot_danik Дата: Понедельник, 26.04.2021, 11:14 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Да, формула монстр, а если еще добавить цену, так вообще на 5 строк))). Спасибо
 
Ответить
СообщениеДа, формула монстр, а если еще добавить цену, так вообще на 5 строк))). Спасибо

Автор - pilot_danik
Дата добавления - 26.04.2021 в 11:14
Nic70y Дата: Понедельник, 26.04.2021, 11:15 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 6928
Репутация: 1598 ±
Замечаний: 0% ±

Excel 2010
Код
=ИНДЕКС(Код&";"&B4:B19;НАИМЕНЬШИЙ(ЕСЛИ(ЕСЛИОШИБКА(ПОИСК($G$2;Код);0)>0;СТРОКА(Код)-СТРОКА($A$3);30);СТРОКА(ДВССЫЛ("A1:A"&ЧСТРОК(Код)))))
достаточно в массиве функции
К сообщению приложен файл: 92.xlsx(12.1 Kb)


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
Код
=ИНДЕКС(Код&";"&B4:B19;НАИМЕНЬШИЙ(ЕСЛИ(ЕСЛИОШИБКА(ПОИСК($G$2;Код);0)>0;СТРОКА(Код)-СТРОКА($A$3);30);СТРОКА(ДВССЫЛ("A1:A"&ЧСТРОК(Код)))))
достаточно в массиве функции

Автор - Nic70y
Дата добавления - 26.04.2021 в 11:15
pilot_danik Дата: Понедельник, 26.04.2021, 12:35 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Да так выглядит симпатичнее, Спасибо.
 
Ответить
СообщениеДа так выглядит симпатичнее, Спасибо.

Автор - pilot_danik
Дата добавления - 26.04.2021 в 12:35
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Функция индекс вывод строки в результате (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!