Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сумма продаж яблок в заданном промежутке дат - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма продаж яблок в заданном промежутке дат (Формулы/Formulas)
Сумма продаж яблок в заданном промежутке дат
adidas77 Дата: Среда, 28.04.2021, 07:06 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Доброго времени суток. Есть диапазон дат, есть яблоки, груши и вишни. Вопрос - Как формулой можно посчитать количество яблок, груш и вишни за промежуток времени? Сумму за диапазон посчитать могу, но что-то не могу привязать еще и "яблоки". Спасибо заранее.
К сообщению приложен файл: 4676131.xlsx(10.2 Kb)
 
Ответить
СообщениеДоброго времени суток. Есть диапазон дат, есть яблоки, груши и вишни. Вопрос - Как формулой можно посчитать количество яблок, груш и вишни за промежуток времени? Сумму за диапазон посчитать могу, но что-то не могу привязать еще и "яблоки". Спасибо заранее.

Автор - adidas77
Дата добавления - 28.04.2021 в 07:06
Egyptian Дата: Среда, 28.04.2021, 08:36 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 127
Репутация: 46 ±
Замечаний: 0% ±

Excel 2013/2016
Как-то так.
Код
=SUMIFS($C$2:$C$48;$B$2:$B$48;$F4;$A$2:$A$48;">="&$I$12;$A$2:$A$48;"<="&EOMONTH($I$13;0))
К сообщению приложен файл: 3336289.xlsx(10.5 Kb)
 
Ответить
СообщениеКак-то так.
Код
=SUMIFS($C$2:$C$48;$B$2:$B$48;$F4;$A$2:$A$48;">="&$I$12;$A$2:$A$48;"<="&EOMONTH($I$13;0))

Автор - Egyptian
Дата добавления - 28.04.2021 в 08:36
Pelena Дата: Среда, 28.04.2021, 08:41 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 17775
Репутация: 3956 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Используя Вашу доп. таблицу
Код
=СУММЕСЛИМН($C$2:$C$48;$B$2:$B$48;$F4;$A$2:$A$48;">="&ИНДЕКС($I$12:$I$22;ПОИСКПОЗ(G$3;$G$12:$G$22;0));$A$2:$A$48;"<="&ИНДЕКС($I$12:$I$22;ПОИСКПОЗ(G$3;$G$12:$G$22;0)+1))

без доп. таблицы
Код
=СУММПРОИЗВ($C$2:$C$48*($B$2:$B$48=$F4)*(ОТБР((МЕСЯЦ($A$2:$A$48)-1)/3)+1=--ЛЕВСИМВ(G$3)))

А эффективнее всего сводной таблицей (см. файл)
К сообщению приложен файл: 3857160.xlsx(16.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Используя Вашу доп. таблицу
Код
=СУММЕСЛИМН($C$2:$C$48;$B$2:$B$48;$F4;$A$2:$A$48;">="&ИНДЕКС($I$12:$I$22;ПОИСКПОЗ(G$3;$G$12:$G$22;0));$A$2:$A$48;"<="&ИНДЕКС($I$12:$I$22;ПОИСКПОЗ(G$3;$G$12:$G$22;0)+1))

без доп. таблицы
Код
=СУММПРОИЗВ($C$2:$C$48*($B$2:$B$48=$F4)*(ОТБР((МЕСЯЦ($A$2:$A$48)-1)/3)+1=--ЛЕВСИМВ(G$3)))

А эффективнее всего сводной таблицей (см. файл)

Автор - Pelena
Дата добавления - 28.04.2021 в 08:41
adidas77 Дата: Среда, 28.04.2021, 08:59 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Egyptian, Спасибо помогло.
 
Ответить
СообщениеEgyptian, Спасибо помогло.

Автор - adidas77
Дата добавления - 28.04.2021 в 08:59
adidas77 Дата: Среда, 28.04.2021, 09:00 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Pelena, Спасибо.
 
Ответить
СообщениеPelena, Спасибо.

Автор - adidas77
Дата добавления - 28.04.2021 в 09:00
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сумма продаж яблок в заданном промежутке дат (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!