Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сделать формулу для подсчета строчек - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сделать формулу для подсчета строчек (Формулы/Formulas)
Сделать формулу для подсчета строчек
Ocharovashka666 Дата: Четверг, 29.04.2021, 19:07 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Добрый вечер всем. Помогите придумать пожалуйста формулу... в файле выделено желтым. Надо что нибудь придумать, что б подсчет был корректный. Данный файл по факту в 7 раз больше и его заполняют 32 человека. у них есть шаблон и при переносе подсчет не корректный, т.к. количество строчек не одинаковый... можно что нибудь придумать что б считалось корректно? заранее спасибо за любую помощь
К сообщению приложен файл: 8301724.xlsx(13.4 Kb)


Рада нашему знакомству
 
Ответить
СообщениеДобрый вечер всем. Помогите придумать пожалуйста формулу... в файле выделено желтым. Надо что нибудь придумать, что б подсчет был корректный. Данный файл по факту в 7 раз больше и его заполняют 32 человека. у них есть шаблон и при переносе подсчет не корректный, т.к. количество строчек не одинаковый... можно что нибудь придумать что б считалось корректно? заранее спасибо за любую помощь

Автор - Ocharovashka666
Дата добавления - 29.04.2021 в 19:07
gling Дата: Четверг, 29.04.2021, 23:26 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2270
Репутация: 587 ±
Замечаний: 0% ±

2010
Формула массива для ячейки F1.
Код
=СУММ(F2:ИНДЕКС(F2:F100;ПОИСКПОЗ(;--ЕЧИСЛО($C2:$C100);0)-1))
Вставить формулу в F1 скопировать ячейку и вставить в другие желтые ячейки.


ЯД-41001506838083
 
Ответить
СообщениеФормула массива для ячейки F1.
Код
=СУММ(F2:ИНДЕКС(F2:F100;ПОИСКПОЗ(;--ЕЧИСЛО($C2:$C100);0)-1))
Вставить формулу в F1 скопировать ячейку и вставить в другие желтые ячейки.

Автор - gling
Дата добавления - 29.04.2021 в 23:26
Egyptian Дата: Пятница, 30.04.2021, 02:05 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 127
Репутация: 46 ±
Замечаний: 0% ±

Excel 2013/2016
gling, Я думаю ТС хочет, чтобы суммировались желтые ячейки по строкам, а не по столбцам. Тут подошла бы формула массива типа:
Код
=SUM(IF((MOD(COLUMN(F1:O1);2)=0);F1:O1))

Но, в ячейке Е1 она работать не будет из-за циклической ошибки. (формула из G1 ссылается на E1)
 
Ответить
Сообщениеgling, Я думаю ТС хочет, чтобы суммировались желтые ячейки по строкам, а не по столбцам. Тут подошла бы формула массива типа:
Код
=SUM(IF((MOD(COLUMN(F1:O1);2)=0);F1:O1))

Но, в ячейке Е1 она работать не будет из-за циклической ошибки. (формула из G1 ссылается на E1)

Автор - Egyptian
Дата добавления - 30.04.2021 в 02:05
Pelena Дата: Пятница, 30.04.2021, 08:18 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 17775
Репутация: 3956 ±
Замечаний: ±

Excel 2016 & Mac Excel
С учётом того, что некоторые числа сохранены как текст, можно такой вариант попробовать (на основе формулы Владимира)
Код
=СУММ(F2:ИНДЕКС(F2:F100;ПОИСКПОЗ(0;--$D2:$D100;0)-1))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеС учётом того, что некоторые числа сохранены как текст, можно такой вариант попробовать (на основе формулы Владимира)
Код
=СУММ(F2:ИНДЕКС(F2:F100;ПОИСКПОЗ(0;--$D2:$D100;0)-1))

Автор - Pelena
Дата добавления - 30.04.2021 в 08:18
Ocharovashka666 Дата: Воскресенье, 02.05.2021, 22:24 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 101
Репутация: 0 ±
Замечаний: 0% ±

Excel 2016
Спасибо вам всем огромное))) Очень меня выручили)))


Рада нашему знакомству
 
Ответить
СообщениеСпасибо вам всем огромное))) Очень меня выручили)))

Автор - Ocharovashka666
Дата добавления - 02.05.2021 в 22:24
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сделать формулу для подсчета строчек (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!