Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула разницы между числами с разными знаками - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула разницы между числами с разными знаками (Формулы/Formulas)
Формула разницы между числами с разными знаками
ars1734 Дата: Суббота, 01.05.2021, 02:40 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 62
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Здравствуйте уважаемые знатоки!

Прошу Вас, помочь с универсальной формулой нахождения разницы между числами с отрицательными, положительными или разными знаками по абсолютной величине. (зеркальная математика)
Т.е. -4 больше чем -2
Формула: Дельта= Знач.2 - Знач 1.

Для примера правильные ответы:
Значение 2 =2
Значение 1= 4
Дельта = -2

Значение 2 =-2
Значение 1= 4
Дельта = -6

Значение 2 =4
Значение 1= 2
Дельта = 2

Значение 2 =-4
Значение 1= -2
Дельта = 2

Как объединить в одной формуле такие вычисления?

Файл Exel прилагаю

С Уважением!
К сообщению приложен файл: 6619268.xlsx(10.8 Kb)
 
Ответить
СообщениеЗдравствуйте уважаемые знатоки!

Прошу Вас, помочь с универсальной формулой нахождения разницы между числами с отрицательными, положительными или разными знаками по абсолютной величине. (зеркальная математика)
Т.е. -4 больше чем -2
Формула: Дельта= Знач.2 - Знач 1.

Для примера правильные ответы:
Значение 2 =2
Значение 1= 4
Дельта = -2

Значение 2 =-2
Значение 1= 4
Дельта = -6

Значение 2 =4
Значение 1= 2
Дельта = 2

Значение 2 =-4
Значение 1= -2
Дельта = 2

Как объединить в одной формуле такие вычисления?

Файл Exel прилагаю

С Уважением!

Автор - ars1734
Дата добавления - 01.05.2021 в 02:40
Pelena Дата: Суббота, 01.05.2021, 08:24 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17775
Репутация: 3956 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Если правильно поняла
Код
=ЕСЛИ(ABS(A1)>ABS(B1);ЗНАК(A1);ЗНАК(B1))*(A1-B1)

или
Код
=ЕСЛИ(ЗНАК(A1)=ЗНАК(B1);ABS(A1)-ABS(B1);A1-B1)
К сообщению приложен файл: 5899721.xlsx(12.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Если правильно поняла
Код
=ЕСЛИ(ABS(A1)>ABS(B1);ЗНАК(A1);ЗНАК(B1))*(A1-B1)

или
Код
=ЕСЛИ(ЗНАК(A1)=ЗНАК(B1);ABS(A1)-ABS(B1);A1-B1)

Автор - Pelena
Дата добавления - 01.05.2021 в 08:24
ars1734 Дата: Суббота, 01.05.2021, 10:08 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 62
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Pelena, Спасибо огромное! Вторая формула работает, в первой формуле:
Знач 2= -4
Знач 1=2
Дельта =6

Во второй формуле считает -6 Это правильно.

Еще раз огромное спасибо!
 
Ответить
СообщениеPelena, Спасибо огромное! Вторая формула работает, в первой формуле:
Знач 2= -4
Знач 1=2
Дельта =6

Во второй формуле считает -6 Это правильно.

Еще раз огромное спасибо!

Автор - ars1734
Дата добавления - 01.05.2021 в 10:08
ars1734 Дата: Суббота, 01.05.2021, 15:54 | Сообщение № 4
Группа: Пользователи
Ранг: Участник
Сообщений: 62
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Pelena, Еще раз здравствуйте!

Обнаружил ошибку в обеих формулах:
Оба варианта считают так:

Знач 2= 4
Знач 1=-2
Дельта =6

Правильный ответ = -6

т.е. при разных знаках значений, дельта однозначно отрицательная

Как можно учесть этот вариант ответа в формуле?


Сообщение отредактировал ars1734 - Суббота, 01.05.2021, 15:56
 
Ответить
СообщениеPelena, Еще раз здравствуйте!

Обнаружил ошибку в обеих формулах:
Оба варианта считают так:

Знач 2= 4
Знач 1=-2
Дельта =6

Правильный ответ = -6

т.е. при разных знаках значений, дельта однозначно отрицательная

Как можно учесть этот вариант ответа в формуле?

Автор - ars1734
Дата добавления - 01.05.2021 в 15:54
Pelena Дата: Суббота, 01.05.2021, 17:04 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 17775
Репутация: 3956 ±
Замечаний: ±

Excel 2016 & Mac Excel
А если нулевые значения? Вы бы объяснили логику. Или примеров больше надо, и, желательно, в файле
Код
=ЕСЛИ(ЗНАК(A1)=ЗНАК(B1);ABS(A1)-ABS(B1);-(ABS(A1)+ABS(B1)))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеА если нулевые значения? Вы бы объяснили логику. Или примеров больше надо, и, желательно, в файле
Код
=ЕСЛИ(ЗНАК(A1)=ЗНАК(B1);ABS(A1)-ABS(B1);-(ABS(A1)+ABS(B1)))

Автор - Pelena
Дата добавления - 01.05.2021 в 17:04
ars1734 Дата: Суббота, 01.05.2021, 18:21 | Сообщение № 6
Группа: Пользователи
Ранг: Участник
Сообщений: 62
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Pelena, Вы правы! Считает правильно кроме нулей в значениях. Значение 1 это исходник.

Если Значение 1=0
То знак дельты = знаку значения 2

Если значение 2 =0, то дельта однозначно отрицательная

Пример:

Знач 2= 4
Знач 1= 0
Дельта =4

Знач 2= -4
Знач 1= 0
Дельта =-4

Знач 2= 0
Знач 1= -4
Дельта =-4

Знач 2= 0
Знач 1= 4
Дельта =-4

Можно ли учесть в формуле эти условия?


Сообщение отредактировал ars1734 - Суббота, 01.05.2021, 21:15
 
Ответить
СообщениеPelena, Вы правы! Считает правильно кроме нулей в значениях. Значение 1 это исходник.

Если Значение 1=0
То знак дельты = знаку значения 2

Если значение 2 =0, то дельта однозначно отрицательная

Пример:

Знач 2= 4
Знач 1= 0
Дельта =4

Знач 2= -4
Знач 1= 0
Дельта =-4

Знач 2= 0
Знач 1= -4
Дельта =-4

Знач 2= 0
Знач 1= 4
Дельта =-4

Можно ли учесть в формуле эти условия?

Автор - ars1734
Дата добавления - 01.05.2021 в 18:21
ars1734 Дата: Суббота, 01.05.2021, 21:34 | Сообщение № 7
Группа: Пользователи
Ранг: Участник
Сообщений: 62
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Еще раз Здравствуйте!

Сделал файл Exel с примерами правильных ответов в таблице для проверки и указанием ошибки

Надеюсь на Вашу помощь

С Уважением!
К сообщению приложен файл: 4450487.xlsx(12.0 Kb)
 
Ответить
СообщениеЕще раз Здравствуйте!

Сделал файл Exel с примерами правильных ответов в таблице для проверки и указанием ошибки

Надеюсь на Вашу помощь

С Уважением!

Автор - ars1734
Дата добавления - 01.05.2021 в 21:34
Pelena Дата: Суббота, 01.05.2021, 21:46 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 17775
Репутация: 3956 ±
Замечаний: ±

Excel 2016 & Mac Excel
Код
=ЕСЛИ(ИЛИ(ЗНАК(I9)=ЗНАК(I11);I11=0);ABS(I9)-ABS(I11);-(ABS(I9)+ABS(I11)))


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
Сообщение
Код
=ЕСЛИ(ИЛИ(ЗНАК(I9)=ЗНАК(I11);I11=0);ABS(I9)-ABS(I11);-(ABS(I9)+ABS(I11)))

Автор - Pelena
Дата добавления - 01.05.2021 в 21:46
ars1734 Дата: Суббота, 01.05.2021, 22:30 | Сообщение № 9
Группа: Пользователи
Ранг: Участник
Сообщений: 62
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Pelena, Огромное спасибо! Теперь все считает правильно!
 
Ответить
СообщениеPelena, Огромное спасибо! Теперь все считает правильно!

Автор - ars1734
Дата добавления - 01.05.2021 в 22:30
ars1734 Дата: Суббота, 01.05.2021, 22:48 | Сообщение № 10
Группа: Пользователи
Ранг: Участник
Сообщений: 62
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Еще одна просьба, если Вас не затруднит

Не могли бы Вы подкорректировать формулу для расчета прироста % для этих значений?
Формула расчета дельта %

(Знач.2-Знач1)/Знач 1*100

Проверка:

Знач 2= -2
Знач 1= 4
Дельта % =-150

Знач 2= 2
Знач 1= 4
Дельта % =-50

Знач 2= 4
Знач 1= 2
Дельта % =100

Знач 2= -4
Знач 1= -2
Дельта % =100

Буду очень признателен!
С Уважением!


Сообщение отредактировал ars1734 - Суббота, 01.05.2021, 23:22
 
Ответить
СообщениеЕще одна просьба, если Вас не затруднит

Не могли бы Вы подкорректировать формулу для расчета прироста % для этих значений?
Формула расчета дельта %

(Знач.2-Знач1)/Знач 1*100

Проверка:

Знач 2= -2
Знач 1= 4
Дельта % =-150

Знач 2= 2
Знач 1= 4
Дельта % =-50

Знач 2= 4
Знач 1= 2
Дельта % =100

Знач 2= -4
Знач 1= -2
Дельта % =100

Буду очень признателен!
С Уважением!

Автор - ars1734
Дата добавления - 01.05.2021 в 22:48
ars1734 Дата: Суббота, 01.05.2021, 23:21 | Сообщение № 11
Группа: Пользователи
Ранг: Участник
Сообщений: 62
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Еще раз здравствуйте, обнаружил ошибку в знаках при расчете дельта%
По формуле: (Знач.2-Знач1)/Знач 1*100

Прилагаю файл Exel. Ошибочные ответы выделил розовой заливкой

Прошу помочь разделить правильно. Знак Дельта% должен соотв. знаку Дельта

С Уважением!
К сообщению приложен файл: 1811320.xlsx(12.1 Kb)


Сообщение отредактировал ars1734 - Суббота, 01.05.2021, 23:32
 
Ответить
СообщениеЕще раз здравствуйте, обнаружил ошибку в знаках при расчете дельта%
По формуле: (Знач.2-Знач1)/Знач 1*100

Прилагаю файл Exel. Ошибочные ответы выделил розовой заливкой

Прошу помочь разделить правильно. Знак Дельта% должен соотв. знаку Дельта

С Уважением!

Автор - ars1734
Дата добавления - 01.05.2021 в 23:21
Светлый Дата: Воскресенье, 02.05.2021, 00:38 | Сообщение № 12
Группа: Друзья
Ранг: Старожил
Сообщений: 1633
Репутация: 435 ±
Замечаний: 0% ±

Excel 2013, 2016
Код
=ЕСЛИОШИБКА((-1^И(ЗНАК(I9)-ЗНАК(I11);I11)*ABS(I9)-ABS(I11))/ABS(I11%);"")


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА((-1^И(ЗНАК(I9)-ЗНАК(I11);I11)*ABS(I9)-ABS(I11))/ABS(I11%);"")

Автор - Светлый
Дата добавления - 02.05.2021 в 00:38
ars1734 Дата: Воскресенье, 02.05.2021, 01:10 | Сообщение № 13
Группа: Пользователи
Ранг: Участник
Сообщений: 62
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Светлый, Огромное спасибо!
 
Ответить
СообщениеСветлый, Огромное спасибо!

Автор - ars1734
Дата добавления - 02.05.2021 в 01:10
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула разницы между числами с разными знаками (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!