Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчёт интервалов между повторяющимися значениями - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт интервалов между повторяющимися значениями (Формулы/Formulas)
Подсчёт интервалов между повторяющимися значениями
emmett_brown Дата: Среда, 05.05.2021, 17:41 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Необходимо в столбце подсчитать количество ячеек между повторяющимися значениями в столбце B, как в столбце С только автоматически, но при условии что считаются только первые 1,2,3 до того момента пока следующим, за 1,2или 3 числом не будет 1, тогда интервал начинает считаться заново, если его не будет тогда счет продолжается, соответственно следующие 1,2 или три будут по счету будут 4,5,6 и т.д. Объяснил криво но надеюсь, на снисходительность и помощь .Помогите, пожалуйста, заранее спасибо.
К сообщению приложен файл: 20-21_1.xlsx(14.6 Kb)


Rock'N'Roll

Сообщение отредактировал emmett_brown - Среда, 05.05.2021, 18:07
 
Ответить
СообщениеНеобходимо в столбце подсчитать количество ячеек между повторяющимися значениями в столбце B, как в столбце С только автоматически, но при условии что считаются только первые 1,2,3 до того момента пока следующим, за 1,2или 3 числом не будет 1, тогда интервал начинает считаться заново, если его не будет тогда счет продолжается, соответственно следующие 1,2 или три будут по счету будут 4,5,6 и т.д. Объяснил криво но надеюсь, на снисходительность и помощь .Помогите, пожалуйста, заранее спасибо.

Автор - emmett_brown
Дата добавления - 05.05.2021 в 17:41
bmv98rus Дата: Среда, 05.05.2021, 17:58 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3496
Репутация: 616 ±
Замечаний: 0% ±

Excel 2013/2016
поясните, почему в с10 4, а в с40 неожиданно 5


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениепоясните, почему в с10 4, а в с40 неожиданно 5

Автор - bmv98rus
Дата добавления - 05.05.2021 в 17:58
emmett_brown Дата: Среда, 05.05.2021, 18:21 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
поясните, почему в с10 4, а в с40 неожиданно 5...
Так как с A2 по A4, идет 1, соответственно счет начинается снова, А5 по А7, не следует 1, то счет продолжается до А10, так как в ячейке A11 значение 1, с С40 такая же логика, так как за ячейками с А34 по А36 значение не 1, то соответственно счет продолжается до А40, так как А41 1, а считаются только 1,2,3...Как то так,а в столбце С подсчитаны вручную эти значения...


Rock'N'Roll

Сообщение отредактировал emmett_brown - Среда, 05.05.2021, 18:23
 
Ответить
Сообщениепоясните, почему в с10 4, а в с40 неожиданно 5...
Так как с A2 по A4, идет 1, соответственно счет начинается снова, А5 по А7, не следует 1, то счет продолжается до А10, так как в ячейке A11 значение 1, с С40 такая же логика, так как за ячейками с А34 по А36 значение не 1, то соответственно счет продолжается до А40, так как А41 1, а считаются только 1,2,3...Как то так,а в столбце С подсчитаны вручную эти значения...

Автор - emmett_brown
Дата добавления - 05.05.2021 в 18:21
Светлый Дата: Среда, 05.05.2021, 18:22 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1617
Репутация: 426 ±
Замечаний: 0% ±

Excel 2010, 2013
Может быть, для столбца C такая массивная формула подойдёт?
Код
=ЕСЛИ((B3=1)*(B2<>"");СУММ(Ч((ИНДЕКС(B:B;1+МАКС((C$1:C1<>"")*СТРОКА($1:1))):B2)<>""));"")
В C2 и протянуть вниз.


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Среда, 05.05.2021, 18:24
 
Ответить
СообщениеМожет быть, для столбца C такая массивная формула подойдёт?
Код
=ЕСЛИ((B3=1)*(B2<>"");СУММ(Ч((ИНДЕКС(B:B;1+МАКС((C$1:C1<>"")*СТРОКА($1:1))):B2)<>""));"")
В C2 и протянуть вниз.

Автор - Светлый
Дата добавления - 05.05.2021 в 18:22
emmett_brown Дата: Среда, 05.05.2021, 18:32 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Цитата Светлый, 05.05.2021 в 18:22, в сообщении № 4 ()
Может быть, для столбца C такая массивная формула подойдёт?

Да, спасибо огромное это то что нужно)


Rock'N'Roll
 
Ответить
Сообщение
Цитата Светлый, 05.05.2021 в 18:22, в сообщении № 4 ()
Может быть, для столбца C такая массивная формула подойдёт?

Да, спасибо огромное это то что нужно)

Автор - emmett_brown
Дата добавления - 05.05.2021 в 18:32
emmett_brown Дата: Среда, 05.05.2021, 18:51 | Сообщение № 6
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Цитата Светлый, 05.05.2021 в 18:22, в сообщении № 4 ()

Код
=ЕСЛИ((B3=1)*(B2<>"");СУММ(Ч((ИНДЕКС(B:B;1+МАКС((C$1:C1<>"")*СТРОКА($1:1))):B2)<>""));"")

В C2 и протянуть вниз.

А можно сделать так , что бы формула считала тоже самое непосредственно со столбца A?


Rock'N'Roll

Сообщение отредактировал Serge_007 - Четверг, 06.05.2021, 09:06
 
Ответить
Сообщение
Цитата Светлый, 05.05.2021 в 18:22, в сообщении № 4 ()

Код
=ЕСЛИ((B3=1)*(B2<>"");СУММ(Ч((ИНДЕКС(B:B;1+МАКС((C$1:C1<>"")*СТРОКА($1:1))):B2)<>""));"")

В C2 и протянуть вниз.

А можно сделать так , что бы формула считала тоже самое непосредственно со столбца A?

Автор - emmett_brown
Дата добавления - 05.05.2021 в 18:51
Светлый Дата: Среда, 05.05.2021, 19:16 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1617
Репутация: 426 ±
Замечаний: 0% ±

Excel 2010, 2013
непосредственно со столбца A
Код
=ЕСЛИ((A3=1)*(A2<4);СУММ(Ч((ИНДЕКС(A:A;1+МАКС((C$1:C1<>"")*СТРОКА($1:1))):A2)<4));"")


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
непосредственно со столбца A
Код
=ЕСЛИ((A3=1)*(A2<4);СУММ(Ч((ИНДЕКС(A:A;1+МАКС((C$1:C1<>"")*СТРОКА($1:1))):A2)<4));"")

Автор - Светлый
Дата добавления - 05.05.2021 в 19:16
emmett_brown Дата: Среда, 05.05.2021, 22:20 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Цитата Светлый, 05.05.2021 в 19:16, в сообщении № 7 ()
Код
=ЕСЛИ((A3=1)*(A2<4);СУММ(Ч((ИНДЕКС(A:A;1+МАКС((C$1:C1<>"")*СТРОКА($1:1))):A2)<4));"")

Спасибо большое, все работает)


Rock'N'Roll

Сообщение отредактировал Serge_007 - Четверг, 06.05.2021, 09:05
 
Ответить
Сообщение
Цитата Светлый, 05.05.2021 в 19:16, в сообщении № 7 ()
Код
=ЕСЛИ((A3=1)*(A2<4);СУММ(Ч((ИНДЕКС(A:A;1+МАКС((C$1:C1<>"")*СТРОКА($1:1))):A2)<4));"")

Спасибо большое, все работает)

Автор - emmett_brown
Дата добавления - 05.05.2021 в 22:20
emmett_brown Дата: Четверг, 06.05.2021, 09:00 | Сообщение № 9
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Цитата Светлый, 05.05.2021 в 19:16, в сообщении № 7 ()
Код
=ЕСЛИ((A3=1)*(A2<4);СУММ(Ч((ИНДЕКС(A:A;1+МАКС((C$1:C1<>"")*СТРОКА($1:1))):A2)<4));"")

Подскажите пожалуйста,а как сделать так что бы был виден процесс счета, 12345, а не только конечные значения


Rock'N'Roll

Сообщение отредактировал emmett_brown - Четверг, 06.05.2021, 09:06
 
Ответить
Сообщение
Цитата Светлый, 05.05.2021 в 19:16, в сообщении № 7 ()
Код
=ЕСЛИ((A3=1)*(A2<4);СУММ(Ч((ИНДЕКС(A:A;1+МАКС((C$1:C1<>"")*СТРОКА($1:1))):A2)<4));"")

Подскажите пожалуйста,а как сделать так что бы был виден процесс счета, 12345, а не только конечные значения

Автор - emmett_brown
Дата добавления - 06.05.2021 в 09:00
Serge_007 Дата: Четверг, 06.05.2021, 09:04 | Сообщение № 10
Группа: Админы
Ранг: Местный житель
Сообщений: 14170
Репутация: 2344 ±
Замечаний: ±

Excel 2010
Формулы - вычислить формулу


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеФормулы - вычислить формулу

Автор - Serge_007
Дата добавления - 06.05.2021 в 09:04
emmett_brown Дата: Четверг, 06.05.2021, 17:24 | Сообщение № 11
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Serge_007, Что это значит не могли бы пояснить?


Rock'N'Roll
 
Ответить
СообщениеSerge_007, Что это значит не могли бы пояснить?

Автор - emmett_brown
Дата добавления - 06.05.2021 в 17:24
Serge_007 Дата: Четверг, 06.05.2021, 17:29 | Сообщение № 12
Группа: Админы
Ранг: Местный житель
Сообщений: 14170
Репутация: 2344 ±
Замечаний: ±

Excel 2010
как сделать так что бы был виден процесс счета
Формулы - вычислить формулу


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
как сделать так что бы был виден процесс счета
Формулы - вычислить формулу

Автор - Serge_007
Дата добавления - 06.05.2021 в 17:29
Светлый Дата: Четверг, 06.05.2021, 19:45 | Сообщение № 13
Группа: Друзья
Ранг: Старожил
Сообщений: 1617
Репутация: 426 ±
Замечаний: 0% ±

Excel 2010, 2013
В ячейку E2 и протянуть вниз:
Код
=ЕСЛИ(A2<4;ЕСЛИ(И(A2=1;Ч(A1)<4);1;ПРОСМОТР(99;E$1:E1)+1);"")


Программировать проще, чем писать стихи.
 
Ответить
СообщениеВ ячейку E2 и протянуть вниз:
Код
=ЕСЛИ(A2<4;ЕСЛИ(И(A2=1;Ч(A1)<4);1;ПРОСМОТР(99;E$1:E1)+1);"")

Автор - Светлый
Дата добавления - 06.05.2021 в 19:45
emmett_brown Дата: Четверг, 06.05.2021, 20:35 | Сообщение № 14
Группа: Пользователи
Ранг: Новичок
Сообщений: 20
Репутация: 0 ±
Замечаний: 0% ±

Excel 2019
Светлый, спасибо большое) Именно так


Rock'N'Roll
 
Ответить
СообщениеСветлый, спасибо большое) Именно так

Автор - emmett_brown
Дата добавления - 06.05.2021 в 20:35
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчёт интервалов между повторяющимися значениями (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!