Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/просмотр и впр показывают разные значения - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » просмотр и впр показывают разные значения (Формулы/Formulas)
просмотр и впр показывают разные значения
TurboRadost Дата: Пятница, 14.05.2021, 17:30 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Добрый день.
Столкнулся с проблемой, которую не могу решить.
Есть список, есть ВПР и есть ПРОСМОТР, но в одном из вариантов ПРОСМОТР показывает не верное значение.
1. изменял название диапазона (вид_обслуживания)
2. менял границы диапазона
3. добавлял и убирал значения, менял их название.

но все равно при выборе Итого получаю рандомную цифру. скрин и файл в прицепе.
помогите разобраться
К сообщению приложен файл: exz.xlsx(9.4 Kb) · 0008682.png(59.8 Kb)


Сообщение отредактировал TurboRadost - Пятница, 14.05.2021, 17:31
 
Ответить
СообщениеДобрый день.
Столкнулся с проблемой, которую не могу решить.
Есть список, есть ВПР и есть ПРОСМОТР, но в одном из вариантов ПРОСМОТР показывает не верное значение.
1. изменял название диапазона (вид_обслуживания)
2. менял границы диапазона
3. добавлял и убирал значения, менял их название.

но все равно при выборе Итого получаю рандомную цифру. скрин и файл в прицепе.
помогите разобраться

Автор - TurboRadost
Дата добавления - 14.05.2021 в 17:30
Serge_007 Дата: Пятница, 14.05.2021, 17:34 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14169
Репутация: 2344 ±
Замечаний: ±

Excel 2010
Здравствуйте

Вы разные критерии поиска берете, в ПРОСМОТР() - неточное совпадение, а в ВПР() - точное, отсюда и разница

Сравните
Код
=ВПР(C2;H:I;2)
и
Код
=ПРОСМОТР(C2;H:H;I:I)
- результат будет одинаков

Столкнулся с проблемой
А проблема-то в чём? Для Вашей задачи ПРОСМОТР() не подходит в принципе. Либо ВПР(), либо ИНДЕКС(ПОИСКПОЗ())


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Вы разные критерии поиска берете, в ПРОСМОТР() - неточное совпадение, а в ВПР() - точное, отсюда и разница

Сравните
Код
=ВПР(C2;H:I;2)
и
Код
=ПРОСМОТР(C2;H:H;I:I)
- результат будет одинаков

Столкнулся с проблемой
А проблема-то в чём? Для Вашей задачи ПРОСМОТР() не подходит в принципе. Либо ВПР(), либо ИНДЕКС(ПОИСКПОЗ())

Автор - Serge_007
Дата добавления - 14.05.2021 в 17:34
TurboRadost Дата: Пятница, 14.05.2021, 17:42 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
Для Вашей задачи ПРОСМОТР() не подходит

остальные показатели показывают такие же значения как и ВПР, вот и появился вопрос. почему только итого криво отображается.


Сообщение отредактировал TurboRadost - Пятница, 14.05.2021, 17:43
 
Ответить
Сообщение
Для Вашей задачи ПРОСМОТР() не подходит

остальные показатели показывают такие же значения как и ВПР, вот и появился вопрос. почему только итого криво отображается.

Автор - TurboRadost
Дата добавления - 14.05.2021 в 17:42
Serge_007 Дата: Пятница, 14.05.2021, 17:45 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14169
Репутация: 2344 ±
Замечаний: ±

Excel 2010
Это просто совпадение. Нечеткий поиск с текстом работает по сложному алгоритму, лично я так и не нашел подробного его описания


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЭто просто совпадение. Нечеткий поиск с текстом работает по сложному алгоритму, лично я так и не нашел подробного его описания

Автор - Serge_007
Дата добавления - 14.05.2021 в 17:45
TurboRadost Дата: Пятница, 14.05.2021, 17:47 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Excel 2010
спасибо.
 
Ответить
Сообщениеспасибо.

Автор - TurboRadost
Дата добавления - 14.05.2021 в 17:47
Serge_007 Дата: Пятница, 14.05.2021, 17:48 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 14169
Репутация: 2344 ±
Замечаний: ±

Excel 2010
Пожалуйста)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеПожалуйста)

Автор - Serge_007
Дата добавления - 14.05.2021 в 17:48
bmv98rus Дата: Пятница, 14.05.2021, 21:29 | Сообщение № 7
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3496
Репутация: 616 ±
Замечаний: 0% ±

Excel 2013/2016
Нечеткий поиск с текстом работает по сложному алгоритму, лично я так и не нашел подробного его описания
нет там ничего сложного. Если отсортировать первый столбец по возрастанию, то результат совпадет. В противном случае не точный поиск по тексту будет всегда выводить последнее значение. а точный первое удовлетворяющее условию.


Замечательный Временно просто медведь , процентов на 20.

Сообщение отредактировал bmv98rus - Пятница, 14.05.2021, 21:53
 
Ответить
Сообщение
Нечеткий поиск с текстом работает по сложному алгоритму, лично я так и не нашел подробного его описания
нет там ничего сложного. Если отсортировать первый столбец по возрастанию, то результат совпадет. В противном случае не точный поиск по тексту будет всегда выводить последнее значение. а точный первое удовлетворяющее условию.

Автор - bmv98rus
Дата добавления - 14.05.2021 в 21:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » просмотр и впр показывают разные значения (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!