Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение двух списков и определение соответс. значений - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение двух списков и определение соответс. значений (Формулы/Formulas)
Сравнение двух списков и определение соответс. значений
insomnia_rr Дата: Пятница, 04.06.2021, 13:19 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте. Необходимо сравнить два списка, если в "список 2" есть ячейка равная ячейке из "список 1", то в "список 3" вставить значение соответствующее значению из списка 2. Например, ячейка B3 равна "88", в "список 2" есть ячейка с таким же значением, это ячейка D7, соответственно в "список 3" идет значение ячейки E7, но на ту же строку, на которой находится ячейка из "список 1". Рабочие таблицы намного больше, с огромным количеством строк и столбцов. Есть повторяющиеся значения в столбцах B и D. Можно ли обойтись без ВПР? Помогите, пожалуйста, как быть?
К сообщению приложен файл: 2296434.xlsx(9.6 Kb)


Сообщение отредактировал insomnia_rr - Пятница, 04.06.2021, 15:04
 
Ответить
СообщениеЗдравствуйте. Необходимо сравнить два списка, если в "список 2" есть ячейка равная ячейке из "список 1", то в "список 3" вставить значение соответствующее значению из списка 2. Например, ячейка B3 равна "88", в "список 2" есть ячейка с таким же значением, это ячейка D7, соответственно в "список 3" идет значение ячейки E7, но на ту же строку, на которой находится ячейка из "список 1". Рабочие таблицы намного больше, с огромным количеством строк и столбцов. Есть повторяющиеся значения в столбцах B и D. Можно ли обойтись без ВПР? Помогите, пожалуйста, как быть?

Автор - insomnia_rr
Дата добавления - 04.06.2021 в 13:19
Serge_007 Дата: Пятница, 04.06.2021, 13:30 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14169
Репутация: 2344 ±
Замечаний: ±

Excel 2010
Здравствуйте

Код
=ЕСЛИОШИБКА(ВПР(B3;D$3:E$13;2;);"")


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Код
=ЕСЛИОШИБКА(ВПР(B3;D$3:E$13;2;);"")

Автор - Serge_007
Дата добавления - 04.06.2021 в 13:30
insomnia_rr Дата: Пятница, 04.06.2021, 14:57 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

К сожалению, ВПР не подходит, в таблице есть повторяющиеся значения, ВПР выдает первое попавшееся в списке значение.
Прикреплю новый файл, чтобы было понятнее.
К сообщению приложен файл: 0063093.xlsx(9.6 Kb)


Сообщение отредактировал Serge_007 - Пятница, 04.06.2021, 15:40
 
Ответить
СообщениеК сожалению, ВПР не подходит, в таблице есть повторяющиеся значения, ВПР выдает первое попавшееся в списке значение.
Прикреплю новый файл, чтобы было понятнее.

Автор - insomnia_rr
Дата добавления - 04.06.2021 в 14:57
Serge_007 Дата: Пятница, 04.06.2021, 15:45 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14169
Репутация: 2344 ±
Замечаний: ±

Excel 2010
Формула массива:
Код
=ИНДЕКС(E$3:E$14;НАИМЕНЬШИЙ(ЕСЛИ(B3=D$3:D$14;СТРОКА($1:$12));СЧЁТЕСЛИ(B$3:B3;B3)))
К сообщению приложен файл: 20210604_insomn.xls(31.5 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеФормула массива:
Код
=ИНДЕКС(E$3:E$14;НАИМЕНЬШИЙ(ЕСЛИ(B3=D$3:D$14;СТРОКА($1:$12));СЧЁТЕСЛИ(B$3:B3;B3)))

Автор - Serge_007
Дата добавления - 04.06.2021 в 15:45
insomnia_rr Дата: Пятница, 04.06.2021, 16:04 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Спасибо большое, все работает. Но только в рамках того файла, что я скинул. Подскажите, пожалуйста, для чего используется вот этот отрезок?
СТРОКА($1:$12)
Если смогу разобраться, то смогу добавить формулу в рабочий файл.


Сообщение отредактировал Serge_007 - Пятница, 04.06.2021, 16:16
 
Ответить
СообщениеСпасибо большое, все работает. Но только в рамках того файла, что я скинул. Подскажите, пожалуйста, для чего используется вот этот отрезок?
СТРОКА($1:$12)
Если смогу разобраться, то смогу добавить формулу в рабочий файл.

Автор - insomnia_rr
Дата добавления - 04.06.2021 в 16:04
Serge_007 Дата: Пятница, 04.06.2021, 16:17 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 14169
Репутация: 2344 ±
Замечаний: ±

Excel 2010
Введите в строку формул
Код
=СТРОКА($1:$12)
, выделите и нажмите F9

[p.s.]И перестаньте, пожалуйста бессмысленно цитировать, это нарушение правил форума[/p.s.]


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеВведите в строку формул
Код
=СТРОКА($1:$12)
, выделите и нажмите F9

[p.s.]И перестаньте, пожалуйста бессмысленно цитировать, это нарушение правил форума[/p.s.]

Автор - Serge_007
Дата добавления - 04.06.2021 в 16:17
insomnia_rr Дата: Пятница, 04.06.2021, 17:03 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Спасибо большое, все работает.
 
Ответить
СообщениеСпасибо большое, все работает.

Автор - insomnia_rr
Дата добавления - 04.06.2021 в 17:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение двух списков и определение соответс. значений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!