Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Как присвоить регион номеру моб.телефона - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как присвоить регион номеру моб.телефона (Формулы/Formulas)
Как присвоить регион номеру моб.телефона
Евгений8722 Дата: Четверг, 10.06.2021, 08:39 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Народ, помогите не сойти с ума. Задачка вроде простая и решение где-то рядом, но где..
Есть список номеров, каждому из которых надо присвоить регион из справочника. В справочнике есть регионы и относящиеся к ним интервалы номеров (от и до)
Можно с помощью ВПР вернуть нужный регион, но для этого надо растянуть все интервалы на номера, а это десятки миллионов строк...
Остановился на проверке принадлежности номера интервалу по одному региону (строке), дальше не могу понять как это сделать по всем интервалам.
В готовых решениях не нашел, может кто-то уже делал подобное...
К сообщению приложен файл: ____.xlsx(10.2 Kb)
 
Ответить
СообщениеНарод, помогите не сойти с ума. Задачка вроде простая и решение где-то рядом, но где..
Есть список номеров, каждому из которых надо присвоить регион из справочника. В справочнике есть регионы и относящиеся к ним интервалы номеров (от и до)
Можно с помощью ВПР вернуть нужный регион, но для этого надо растянуть все интервалы на номера, а это десятки миллионов строк...
Остановился на проверке принадлежности номера интервалу по одному региону (строке), дальше не могу понять как это сделать по всем интервалам.
В готовых решениях не нашел, может кто-то уже делал подобное...

Автор - Евгений8722
Дата добавления - 10.06.2021 в 08:39
Nic70y Дата: Четверг, 10.06.2021, 08:50 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6874
Репутация: 1574 ±
Замечаний: 0% ±

Excel 2010
вариант с допами,
можно без них массивной, но лень
К сообщению приложен файл: 1101218.xlsx(11.7 Kb)


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщениевариант с допами,
можно без них массивной, но лень

Автор - Nic70y
Дата добавления - 10.06.2021 в 08:50
YouGreed Дата: Четверг, 10.06.2021, 09:33 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 576
Репутация: 120 ±
Замечаний: 0% ±

Excel 2010
Евгений8722, Получилась такая формула. Сейчас сверю, верно ли она считает.

Код
=ИНДЕКС($G$2:$G$16;СУММ(($E$2:$E$16<$A2)*($F$2:$F$16>$A2)*СТРОКА($A$1:$A$15));1)


Формула массива, вводится одновременным нажатием Ctrl+Shift+Enter
К сообщению приложен файл: 3583421.xlsx(11.7 Kb)


Сообщение отредактировал YouGreed - Четверг, 10.06.2021, 10:11
 
Ответить
СообщениеЕвгений8722, Получилась такая формула. Сейчас сверю, верно ли она считает.

Код
=ИНДЕКС($G$2:$G$16;СУММ(($E$2:$E$16<$A2)*($F$2:$F$16>$A2)*СТРОКА($A$1:$A$15));1)


Формула массива, вводится одновременным нажатием Ctrl+Shift+Enter

Автор - YouGreed
Дата добавления - 10.06.2021 в 09:33
Digital Дата: Четверг, 10.06.2021, 10:08 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 201
Репутация: 0 ±
Замечаний: 0% ±

Excel 2007
Добрый день, Евгений8722!
В случае если подойдет вариант с двумя доп.столбцами. Количество отбрасываемых цифр в дополнительных столбцах можно уменьшать или увеличивать.
К сообщению приложен файл: 8125839.xlsx(11.0 Kb)
 
Ответить
СообщениеДобрый день, Евгений8722!
В случае если подойдет вариант с двумя доп.столбцами. Количество отбрасываемых цифр в дополнительных столбцах можно уменьшать или увеличивать.

Автор - Digital
Дата добавления - 10.06.2021 в 10:08
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Как присвоить регион номеру моб.телефона (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!