Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выборка из массива данных по множеству условий - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка из массива данных по множеству условий (Формулы/Formulas)
Выборка из массива данных по множеству условий
4atckuu Дата: Четверг, 10.06.2021, 09:20 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

2019
Добрый день, помогите подобрать формулы, макрос не желательно, для выборки данных из массива по множеству условий.
К сообщению приложен файл: ___.xlsx(20.2 Kb)
 
Ответить
СообщениеДобрый день, помогите подобрать формулы, макрос не желательно, для выборки данных из массива по множеству условий.

Автор - 4atckuu
Дата добавления - 10.06.2021 в 09:20
alexa1965 Дата: Четверг, 10.06.2021, 13:40 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 234
Репутация: 17 ±
Замечаний: 0% ±

2003> 2010> 2016
Добрый день!
Код
ИНДЕКС(E$1:E$33;НАИМЕНЬШИЙ(ЕСЛИ((B$10:B$33=S$3)*(F$10:F$33=S$4)*(ЛЕВСИМВ(E$10:E$33;2)=S$2);СТРОКА(E$10:E$33);33);СТРОКА(A1)))&""
для ячейки К10, далее по аналогии, только условие выборки группы надо вводить с точкой, либо два символа. Сортировку по массе увы не смог. Может кто допилит формулы.
К сообщению приложен файл: -3-.xlsx(22.2 Kb)


Главное не быть балабастиком
 
Ответить
СообщениеДобрый день!
Код
ИНДЕКС(E$1:E$33;НАИМЕНЬШИЙ(ЕСЛИ((B$10:B$33=S$3)*(F$10:F$33=S$4)*(ЛЕВСИМВ(E$10:E$33;2)=S$2);СТРОКА(E$10:E$33);33);СТРОКА(A1)))&""
для ячейки К10, далее по аналогии, только условие выборки группы надо вводить с точкой, либо два символа. Сортировку по массе увы не смог. Может кто допилит формулы.

Автор - alexa1965
Дата добавления - 10.06.2021 в 13:40
YouGreed Дата: Четверг, 10.06.2021, 14:11 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 576
Репутация: 120 ±
Замечаний: 0% ±

Excel 2010
alexa1965,
Цитата
Может кто допилит формулы.

1.
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$10:$H$32;НАИМЕНЬШИЙ(ЕСЛИ(($B$10:$B$32=$S$3)*($F$10:$F$32=$S$4)*(ЛЕВСИМВ($E$10:$E$32;2)=$S$2);$A$10:$A$32;33);СТРОКА($A1));ПОИСКПОЗ(K$9;$B$9:$H$9;));"")


2.
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$10:$H$32;ПОИСКПОЗ(НАИМЕНЬШИЙ(ЕСЛИ(($B$10:$B$32=$S$3)*($F$10:$F$32=$S$4)*(ЛЕВСИМВ($E$10:$E$32;2)=$S$2);$G$10:$G$32;"");СТРОКА($A1));$G$10:$G$32;);ПОИСКПОЗ(K$9;$B$9:$H$9;));"")
- Сортировка
К сообщению приложен файл: -___-.xlsx(22.8 Kb)


Сообщение отредактировал YouGreed - Четверг, 10.06.2021, 14:23
 
Ответить
Сообщениеalexa1965,
Цитата
Может кто допилит формулы.

1.
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$10:$H$32;НАИМЕНЬШИЙ(ЕСЛИ(($B$10:$B$32=$S$3)*($F$10:$F$32=$S$4)*(ЛЕВСИМВ($E$10:$E$32;2)=$S$2);$A$10:$A$32;33);СТРОКА($A1));ПОИСКПОЗ(K$9;$B$9:$H$9;));"")


2.
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$10:$H$32;ПОИСКПОЗ(НАИМЕНЬШИЙ(ЕСЛИ(($B$10:$B$32=$S$3)*($F$10:$F$32=$S$4)*(ЛЕВСИМВ($E$10:$E$32;2)=$S$2);$G$10:$G$32;"");СТРОКА($A1));$G$10:$G$32;);ПОИСКПОЗ(K$9;$B$9:$H$9;));"")
- Сортировка

Автор - YouGreed
Дата добавления - 10.06.2021 в 14:11
alexa1965 Дата: Четверг, 10.06.2021, 14:22 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 234
Репутация: 17 ±
Замечаний: 0% ±

2003> 2010> 2016
В принципе если важен вывод по нарастанию массы, то можно предварительно в таблице 1 сделать сортировку не по дате а по группе и затем по массе


Главное не быть балабастиком
 
Ответить
СообщениеВ принципе если важен вывод по нарастанию массы, то можно предварительно в таблице 1 сделать сортировку не по дате а по группе и затем по массе

Автор - alexa1965
Дата добавления - 10.06.2021 в 14:22
YouGreed Дата: Четверг, 10.06.2021, 14:27 | Сообщение № 5
Группа: Проверенные
Ранг: Ветеран
Сообщений: 576
Репутация: 120 ±
Замечаний: 0% ±

Excel 2010
alexa1965,
Цитата
сделать сортировку


На самом деле, не хватило чуть-чуть hands

Нужно еще, найти обход ошибки в случае если в условии по Признаку 2, не будет ничего указано...
 
Ответить
Сообщениеalexa1965,
Цитата
сделать сортировку


На самом деле, не хватило чуть-чуть hands

Нужно еще, найти обход ошибки в случае если в условии по Признаку 2, не будет ничего указано...

Автор - YouGreed
Дата добавления - 10.06.2021 в 14:27
alexa1965 Дата: Четверг, 10.06.2021, 14:30 | Сообщение № 6
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 234
Репутация: 17 ±
Замечаний: 0% ±

2003> 2010> 2016
Нужно еще, найти обход ошибки в случае если в условии по Признаку 2, не будет ничего указано...
 

да тоже упустил... И еще в исходнике то числа то как текст...


Главное не быть балабастиком
 
Ответить
Сообщение
Нужно еще, найти обход ошибки в случае если в условии по Признаку 2, не будет ничего указано...
 

да тоже упустил... И еще в исходнике то числа то как текст...

Автор - alexa1965
Дата добавления - 10.06.2021 в 14:30
4atckuu Дата: Пятница, 11.06.2021, 07:39 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

2019
огромное спасибо, таких крутых формул я сам бы точно не придумал.
 
Ответить
Сообщениеогромное спасибо, таких крутых формул я сам бы точно не придумал.

Автор - 4atckuu
Дата добавления - 11.06.2021 в 07:39
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выборка из массива данных по множеству условий (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!