Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Среднее значение за последние 10 дней с условием - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Среднее значение за последние 10 дней с условием (Формулы/Formulas)
Среднее значение за последние 10 дней с условием
kadig Дата: Среда, 16.06.2021, 03:21 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Доброй ночи! Помогите правильно сделать формулу для ежедневного определения средней суммы поступлений за последние 10 дней. Условно: Если дата >=дате начала+10 дней, тогда среднее значение за предыдущие 10 дней, иначе среднее значение за период с даты начала по дата-1 день. Нули в расчет среднего не берем. Может с функцией "Смещ" как-то попробовать, голову сломал %)
К сообщению приложен файл: 8709819.xlsx(10.5 Kb)
 
Ответить
СообщениеДоброй ночи! Помогите правильно сделать формулу для ежедневного определения средней суммы поступлений за последние 10 дней. Условно: Если дата >=дате начала+10 дней, тогда среднее значение за предыдущие 10 дней, иначе среднее значение за период с даты начала по дата-1 день. Нули в расчет среднего не берем. Может с функцией "Смещ" как-то попробовать, голову сломал %)

Автор - kadig
Дата добавления - 16.06.2021 в 03:21
Serge_007 Дата: Среда, 16.06.2021, 09:05 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14333
Репутация: 2368 ±
Замечаний: ±

Excel 2010
Здравствуйте

Формула массива:
Код
=СРЗНАЧ(ЕСЛИ((A1:A$2>=I$1)*(B1:B$2>0);B1:B$2))
К сообщению приложен файл: 20210616_kadig.xls(57.0 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Формула массива:
Код
=СРЗНАЧ(ЕСЛИ((A1:A$2>=I$1)*(B1:B$2>0);B1:B$2))

Автор - Serge_007
Дата добавления - 16.06.2021 в 09:05
kadig Дата: Среда, 16.06.2021, 11:41 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Serge_007, Спасибо большое. Не очень дружу с массивами. Посмотрите пожалуйста в своем файле: с 23.01 пошло расхождение по определению среднего значения
 
Ответить
СообщениеSerge_007, Спасибо большое. Не очень дружу с массивами. Посмотрите пожалуйста в своем файле: с 23.01 пошло расхождение по определению среднего значения

Автор - kadig
Дата добавления - 16.06.2021 в 11:41
Serge_007 Дата: Среда, 16.06.2021, 13:09 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14333
Репутация: 2368 ±
Замечаний: ±

Excel 2010
kadig, видел
У Вас ошибочно посчитано среднее


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщениеkadig, видел
У Вас ошибочно посчитано среднее

Автор - Serge_007
Дата добавления - 16.06.2021 в 13:09
kadig Дата: Среда, 16.06.2021, 13:52 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

Serge_007, Не понял. Для расчета среднего значения для даты 25.01.2021 я выделяю диапазон "Поступление" предыдущих 10 ячеек с 15.01.2021 по 24.01.2021 (10 ячеек). Сумма этого диапазона = 56686. Т.к. в "Поступлениях" 15.01 и 21.01 нулевые значения (2 ячейки), отсюда следует, что среднее значение ненулевых значений с 15.01.2021 по 24.01.2021 = 56686/(10-2) = 7085,75.


Сообщение отредактировал kadig - Среда, 16.06.2021, 14:04
 
Ответить
СообщениеSerge_007, Не понял. Для расчета среднего значения для даты 25.01.2021 я выделяю диапазон "Поступление" предыдущих 10 ячеек с 15.01.2021 по 24.01.2021 (10 ячеек). Сумма этого диапазона = 56686. Т.к. в "Поступлениях" 15.01 и 21.01 нулевые значения (2 ячейки), отсюда следует, что среднее значение ненулевых значений с 15.01.2021 по 24.01.2021 = 56686/(10-2) = 7085,75.

Автор - kadig
Дата добавления - 16.06.2021 в 13:52
bigor Дата: Среда, 16.06.2021, 14:54 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 461
Репутация: 89 ±
Замечаний: 0% ±

нет
kadig, попробуйте так:
Код
=IFERROR(AVERAGE(IF((A1:A$2>=I$1)*(B1:B$2>0)*(A1:A$2>(A1-10));B1:B$2));0)


Сообщение отредактировал bigor - Среда, 16.06.2021, 14:56
 
Ответить
Сообщениеkadig, попробуйте так:
Код
=IFERROR(AVERAGE(IF((A1:A$2>=I$1)*(B1:B$2>0)*(A1:A$2>(A1-10));B1:B$2));0)

Автор - bigor
Дата добавления - 16.06.2021 в 14:54
kadig Дата: Среда, 16.06.2021, 15:05 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 26
Репутация: 0 ±
Замечаний: 0% ±

bigor, Спасибо большое! Отклонения ушли. Буду изучать массивы, т.к. формула для меня не очевидна и не понятна
 
Ответить
Сообщениеbigor, Спасибо большое! Отклонения ушли. Буду изучать массивы, т.к. формула для меня не очевидна и не понятна

Автор - kadig
Дата добавления - 16.06.2021 в 15:05
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Среднее значение за последние 10 дней с условием (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!