Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Протянуть ячейки с заданным шагом на диапазоне - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Протянуть ячейки с заданным шагом на диапазоне (Формулы/Formulas)
Протянуть ячейки с заданным шагом на диапазоне
belproof2102 Дата: Среда, 16.06.2021, 10:57 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте! Переношу данные из одного файла excel в другой, при этом необходимые данные располагаются в столбце таблицы два через два. Подскажите, как мне задать диапазон два через два. Похожий пример есть здесь - https://www.planetaexcel.ru/forum....D=30648 , но я пока не сильно понимаю, как сделать так, чтобы переносились два значения, два пропускались и два опять переносились.
К сообщению приложен файл: 7123952.xlsx(8.2 Kb)
 
Ответить
СообщениеЗдравствуйте! Переношу данные из одного файла excel в другой, при этом необходимые данные располагаются в столбце таблицы два через два. Подскажите, как мне задать диапазон два через два. Похожий пример есть здесь - https://www.planetaexcel.ru/forum....D=30648 , но я пока не сильно понимаю, как сделать так, чтобы переносились два значения, два пропускались и два опять переносились.

Автор - belproof2102
Дата добавления - 16.06.2021 в 10:57
Serge_007 Дата: Среда, 16.06.2021, 11:03 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14333
Репутация: 2368 ±
Замечаний: ±

Excel 2010
Здравствуйте

Что, откуда, куда и как должно переноситься?


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Что, откуда, куда и как должно переноситься?

Автор - Serge_007
Дата добавления - 16.06.2021 в 11:03
belproof2102 Дата: Среда, 16.06.2021, 11:34 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Serge_007, нужно перенести данные из одной файла excel в другой(пример файла, откуда переносятся данные, указал выше и прикреплю здесь). То есть я использую конструкцию типа ИНДЕКС(IMPORTRANGE(ссылка на файл, откуда переносится; диапазон ячеек с которыми работаем); ?). Там где вопрос, мне надо вставить что-то типа регулярного выражения(может в excel не так называется), если на пальцах объяснить, то мне нужно чтоб этот параметр позволял получать доступ к первым двум ячейкам выбранного столбца файла, откуда мы переносим данные, затем пропускал две ячейки и потом опять переносил две ячейки в новый файл. Для моего примера: переносит 3,4 в новый файл, две ячейки пропускает, переносит 5,6 и тд. Я нашёл похожий пример для задачи, где берётся одна ячейка, восемь пропускается, затем опять берётся ячейка(10+ИНДЕКС(Лист2!$A$1:$A$100;(СТРОКА(1:1)-1)*8+1) - такая вот конструкция). И вот мне нужно получить что-то похожее на эту конструкцию, но с моим условием.
К сообщению приложен файл: 3736817.xlsx(8.2 Kb)
 
Ответить
СообщениеSerge_007, нужно перенести данные из одной файла excel в другой(пример файла, откуда переносятся данные, указал выше и прикреплю здесь). То есть я использую конструкцию типа ИНДЕКС(IMPORTRANGE(ссылка на файл, откуда переносится; диапазон ячеек с которыми работаем); ?). Там где вопрос, мне надо вставить что-то типа регулярного выражения(может в excel не так называется), если на пальцах объяснить, то мне нужно чтоб этот параметр позволял получать доступ к первым двум ячейкам выбранного столбца файла, откуда мы переносим данные, затем пропускал две ячейки и потом опять переносил две ячейки в новый файл. Для моего примера: переносит 3,4 в новый файл, две ячейки пропускает, переносит 5,6 и тд. Я нашёл похожий пример для задачи, где берётся одна ячейка, восемь пропускается, затем опять берётся ячейка(10+ИНДЕКС(Лист2!$A$1:$A$100;(СТРОКА(1:1)-1)*8+1) - такая вот конструкция). И вот мне нужно получить что-то похожее на эту конструкцию, но с моим условием.

Автор - belproof2102
Дата добавления - 16.06.2021 в 11:34
Serge_007 Дата: Среда, 16.06.2021, 11:39 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14333
Репутация: 2368 ±
Замечаний: ±

Excel 2010
Много букв, читать не стал

Файл-пример выложите, в котором будет пример исходных данных и желаемого результата (заполните вручную)
Достаточно десятка строк


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеМного букв, читать не стал

Файл-пример выложите, в котором будет пример исходных данных и желаемого результата (заполните вручную)
Достаточно десятка строк

Автор - Serge_007
Дата добавления - 16.06.2021 в 11:39
belproof2102 Дата: Среда, 16.06.2021, 12:48 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Serge_007,
К сообщению приложен файл: 7971914.xlsx(9.0 Kb)
 
Ответить
СообщениеSerge_007,

Автор - belproof2102
Дата добавления - 16.06.2021 в 12:48
Serge_007 Дата: Среда, 16.06.2021, 13:15 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 14333
Репутация: 2368 ±
Замечаний: ±

Excel 2010
В А2:
Код
=ИНДЕКС(Исходный!$A$2:$B$11;ЦЕЛОЕ((СТРОКА()-2)/2)*2+СТРОКА(A1);СТОЛБЕЦ())
, и копируйте на остальные ячейки
К сообщению приложен файл: 20210616_belpro.xls(59.5 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеВ А2:
Код
=ИНДЕКС(Исходный!$A$2:$B$11;ЦЕЛОЕ((СТРОКА()-2)/2)*2+СТРОКА(A1);СТОЛБЕЦ())
, и копируйте на остальные ячейки

Автор - Serge_007
Дата добавления - 16.06.2021 в 13:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Протянуть ячейки с заданным шагом на диапазоне (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!