Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ЕСЛИ (ПОИСКПОЗ ИНДЕКС не корректно условие если лож - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ЕСЛИ (ПОИСКПОЗ ИНДЕКС не корректно условие если лож (Формулы/Formulas)
ЕСЛИ (ПОИСКПОЗ ИНДЕКС не корректно условие если лож
p0n40257 Дата: Четверг, 17.06.2021, 11:16 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте.

Задача в столбец С через значение =ЕСЛИ (условие ПОИСКПОЗ надо найти слово в столбце I, при его нахождении подтягиваем цифры из столбика М на против найденного слова (пока все работает), Но при отсутствии слова в столбце I ЕСЛИ ложь выбивает в ячейке С - Н/Д, а нужен 0, в условии ЕСЛИ ложь прописан ;0)

Не как не могу понять что не так, помогите пожалуйста.

Пример прикладываю
К сообщению приложен файл: 8314050.xlsx(10.9 Kb)
 
Ответить
СообщениеЗдравствуйте.

Задача в столбец С через значение =ЕСЛИ (условие ПОИСКПОЗ надо найти слово в столбце I, при его нахождении подтягиваем цифры из столбика М на против найденного слова (пока все работает), Но при отсутствии слова в столбце I ЕСЛИ ложь выбивает в ячейке С - Н/Д, а нужен 0, в условии ЕСЛИ ложь прописан ;0)

Не как не могу понять что не так, помогите пожалуйста.

Пример прикладываю

Автор - p0n40257
Дата добавления - 17.06.2021 в 11:16
alexa1965 Дата: Четверг, 17.06.2021, 11:39 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 246
Репутация: 19 ±
Замечаний: 0% ±

2003> 2010> 2016
Добрый день! Как то так
Код
=ЕСЛИОШИБКА(ЕСЛИ(ПОИСКПОЗ(B3;$I$3:$I$41;0);ИНДЕКС($M$3:$M$41;ПОИСКПОЗ(B3;$I$3:$I$41;0));0);0)
для ячейки С3 и протянуть и еще корректно данные вводите в ячейке В3 данные с двумя пробелами а искомое с одним.


Главное не быть балабастиком

Сообщение отредактировал alexa1965 - Четверг, 17.06.2021, 11:43
 
Ответить
СообщениеДобрый день! Как то так
Код
=ЕСЛИОШИБКА(ЕСЛИ(ПОИСКПОЗ(B3;$I$3:$I$41;0);ИНДЕКС($M$3:$M$41;ПОИСКПОЗ(B3;$I$3:$I$41;0));0);0)
для ячейки С3 и протянуть и еще корректно данные вводите в ячейке В3 данные с двумя пробелами а искомое с одним.

Автор - alexa1965
Дата добавления - 17.06.2021 в 11:39
Serge_007 Дата: Четверг, 17.06.2021, 11:39 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 14465
Репутация: 2384 ±
Замечаний: ±

Excel 2010
Здравствуйте

Код
=ЕСНД(ИНДЕКС(M$1:M$30;ПОИСКПОЗ(B3;I$1:I$30;));0)
Код
=ЕСНД(ВПР(B3;I$1:M$30;5;);0)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Код
=ЕСНД(ИНДЕКС(M$1:M$30;ПОИСКПОЗ(B3;I$1:I$30;));0)
Код
=ЕСНД(ВПР(B3;I$1:M$30;5;);0)

Автор - Serge_007
Дата добавления - 17.06.2021 в 11:39
bigor Дата: Четверг, 17.06.2021, 11:40 | Сообщение № 4
Группа: Проверенные
Ранг: Обитатель
Сообщений: 489
Репутация: 94 ±
Замечаний: 0% ±

нет
Добрый день
Попробуйте в с3 и протянуть вниз
Код
=IFERROR(INDEX($M$3:$M$41;MATCH(B3;$I$3:$I$41;0));0)

только удалите лишний пробел в B3
 
Ответить
СообщениеДобрый день
Попробуйте в с3 и протянуть вниз
Код
=IFERROR(INDEX($M$3:$M$41;MATCH(B3;$I$3:$I$41;0));0)

только удалите лишний пробел в B3

Автор - bigor
Дата добавления - 17.06.2021 в 11:40
p0n40257 Дата: Четверг, 17.06.2021, 12:16 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

bigor, Работает! Отлично!

Спасибо большое!
Благодарю всех за помощь, работает хорошо через ЕСЛИОШИБКА to bigor еще и сократил массивную формулу.

Я бы с удовольствием пользовался ссылкой на В3 но в столбике исходных данных может иногда совпадать только "Масляная" или "С4:0 Масляная"

Например В3="С4:0 Масляная" а I$="С4:0 Масляная / бутановая кислота" и прочие варианты (большинство исходных данных не мои).

Еще раз всем спасибо!
 
Ответить
Сообщениеbigor, Работает! Отлично!

Спасибо большое!
Благодарю всех за помощь, работает хорошо через ЕСЛИОШИБКА to bigor еще и сократил массивную формулу.

Я бы с удовольствием пользовался ссылкой на В3 но в столбике исходных данных может иногда совпадать только "Масляная" или "С4:0 Масляная"

Например В3="С4:0 Масляная" а I$="С4:0 Масляная / бутановая кислота" и прочие варианты (большинство исходных данных не мои).

Еще раз всем спасибо!

Автор - p0n40257
Дата добавления - 17.06.2021 в 12:16
Serge_007 Дата: Четверг, 17.06.2021, 12:25 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 14465
Репутация: 2384 ±
Замечаний: ±

Excel 2010
Например В3="С4:0 Масляная" а I$="С4:0 Масляная / бутановая кислота"
Есть функции
Код
ПОИСК()
и
Код
НАЙТИ()

С их помощью можно искать неполное совпадение


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Например В3="С4:0 Масляная" а I$="С4:0 Масляная / бутановая кислота"
Есть функции
Код
ПОИСК()
и
Код
НАЙТИ()

С их помощью можно искать неполное совпадение

Автор - Serge_007
Дата добавления - 17.06.2021 в 12:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ЕСЛИ (ПОИСКПОЗ ИНДЕКС не корректно условие если лож (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!