Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/В ячейке цифры в виде дроби - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » В ячейке цифры в виде дроби (Формулы/Formulas)
В ячейке цифры в виде дроби
Юрий_Ф Дата: Вторник, 22.06.2021, 01:23 | Сообщение № 1
Группа: Проверенные
Ранг: Обитатель
Сообщений: 328
Репутация: -5 ±
Замечаний: 20% ±

Excel 2010
Приветствую всех!

В лётной книжке (в электронном виде) есть столбец с записью погоды.
Записать погоду, как нужно, я пока не смог. И запись у меня носит такой формат:
8:7.5/0.6-4
(Если кому интересно, расшифрую: облачность 8 баллов, верхний край 7500 м, нижний - 600 м, видимость 4 км).
Можно ли в Excel в нужные ячейки ввести вид такой, как я изобразил в Word?
К сообщению приложен файл: 86.docx(14.9 Kb)


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!


Сообщение отредактировал Юрий_Ф - Вторник, 22.06.2021, 01:24
 
Ответить
СообщениеПриветствую всех!

В лётной книжке (в электронном виде) есть столбец с записью погоды.
Записать погоду, как нужно, я пока не смог. И запись у меня носит такой формат:
8:7.5/0.6-4
(Если кому интересно, расшифрую: облачность 8 баллов, верхний край 7500 м, нижний - 600 м, видимость 4 км).
Можно ли в Excel в нужные ячейки ввести вид такой, как я изобразил в Word?

Автор - Юрий_Ф
Дата добавления - 22.06.2021 в 01:23
Nic70y Дата: Вторник, 22.06.2021, 09:24 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 6932
Репутация: 1599 ±
Замечаний: 0% ±

Excel 2010
Вставка - формула,
я бы использовал 6 ячеек (наверное, а может и нет вовсе)


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
СообщениеВставка - формула,
я бы использовал 6 ячеек (наверное, а может и нет вовсе)

Автор - Nic70y
Дата добавления - 22.06.2021 в 09:24
NikitaDvorets Дата: Вторник, 22.06.2021, 13:59 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 176
Репутация: 40 ±
Замечаний: 0% ±

Excel 2019
Юрий_Ф, добрый день.
Возможный вариант - в приложении.
К сообщению приложен файл: ___22-06-2021.xlsm(25.4 Kb)
 
Ответить
СообщениеЮрий_Ф, добрый день.
Возможный вариант - в приложении.

Автор - NikitaDvorets
Дата добавления - 22.06.2021 в 13:59
Светлый Дата: Вторник, 22.06.2021, 15:09 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 1639
Репутация: 437 ±
Замечаний: 0% ±

Excel 2013, 2016
Формулой, если формат не поменяется:
Код
=ЕСЛИ(-ЛЕВБ(A1;ПОИСК(":";A1)-1);"Облачность "&--ЛЕВБ(A1;ПОИСК(":";A1)-1)&" баллов, верхний край "&ЕСЛИОШИБКА(ЛЕВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПСТР(A1;ПОИСК(":";A1)+1;9);"/";"    ");".";ПСТР(1/2;2;1));7)*1000&" м,";"- неизвестен,")&" нижний - "&ЕСЛИОШИБКА(ЛЕВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПСТР(A1;ПОИСК("/";A1)+1;9);"-";"    ");".";ПСТР(1/2;2;1));7)*1000&" м,";"незвестен, ");"Безоблачно,")&" видимость "&-ПСТР(A1;ПОИСК("-";A1);9)&" км."


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Вторник, 22.06.2021, 15:10
 
Ответить
СообщениеФормулой, если формат не поменяется:
Код
=ЕСЛИ(-ЛЕВБ(A1;ПОИСК(":";A1)-1);"Облачность "&--ЛЕВБ(A1;ПОИСК(":";A1)-1)&" баллов, верхний край "&ЕСЛИОШИБКА(ЛЕВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПСТР(A1;ПОИСК(":";A1)+1;9);"/";"    ");".";ПСТР(1/2;2;1));7)*1000&" м,";"- неизвестен,")&" нижний - "&ЕСЛИОШИБКА(ЛЕВБ(ПОДСТАВИТЬ(ПОДСТАВИТЬ(ПСТР(A1;ПОИСК("/";A1)+1;9);"-";"    ");".";ПСТР(1/2;2;1));7)*1000&" м,";"незвестен, ");"Безоблачно,")&" видимость "&-ПСТР(A1;ПОИСК("-";A1);9)&" км."

Автор - Светлый
Дата добавления - 22.06.2021 в 15:09
Юрий_Ф Дата: Четверг, 24.06.2021, 20:56 | Сообщение № 5
Группа: Проверенные
Ранг: Обитатель
Сообщений: 328
Репутация: -5 ±
Замечаний: 20% ±

Excel 2010
NikitaDvorets

Вот это да! И так можно? Как интересно! Я думал: эта задача в Excel решения не имеет!
hands


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!


Сообщение отредактировал Юрий_Ф - Четверг, 24.06.2021, 20:56
 
Ответить
СообщениеNikitaDvorets

Вот это да! И так можно? Как интересно! Я думал: эта задача в Excel решения не имеет!
hands

Автор - Юрий_Ф
Дата добавления - 24.06.2021 в 20:56
Юрий_Ф Дата: Четверг, 24.06.2021, 21:01 | Сообщение № 6
Группа: Проверенные
Ранг: Обитатель
Сообщений: 328
Репутация: -5 ±
Замечаний: 20% ±

Excel 2010
Светлый,

А данные для формулы откуда брать? Или тоже по ячейкам разбросать данные?


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеСветлый,

А данные для формулы откуда брать? Или тоже по ячейкам разбросать данные?

Автор - Юрий_Ф
Дата добавления - 24.06.2021 в 21:01
Светлый Дата: Четверг, 24.06.2021, 23:57 | Сообщение № 7
Группа: Друзья
Ранг: Старожил
Сообщений: 1639
Репутация: 437 ±
Замечаний: 0% ±

Excel 2013, 2016
А данные для формулы откуда брать?
В ячейке A1 в виде
8:7.5/0.6-4

И ниже, а формулу протянуть вниз.


Программировать проще, чем писать стихи.
 
Ответить
Сообщение
А данные для формулы откуда брать?
В ячейке A1 в виде
8:7.5/0.6-4

И ниже, а формулу протянуть вниз.

Автор - Светлый
Дата добавления - 24.06.2021 в 23:57
Юрий_Ф Дата: Суббота, 26.06.2021, 12:40 | Сообщение № 8
Группа: Проверенные
Ранг: Обитатель
Сообщений: 328
Репутация: -5 ±
Замечаний: 20% ±

Excel 2010
Светлый

Спасибо, конечно. Вы просто то, что я кратко изложил, перевели в текст. Тоже интересный опыт.
А нужно было то, что в ячейке А1 представить в виде дроби, а не текста!


То, что мы делаем, завораживает!
Кстати! Я не могу всем нравиться! И это взаимно!
 
Ответить
СообщениеСветлый

Спасибо, конечно. Вы просто то, что я кратко изложил, перевели в текст. Тоже интересный опыт.
А нужно было то, что в ячейке А1 представить в виде дроби, а не текста!

Автор - Юрий_Ф
Дата добавления - 26.06.2021 в 12:40
Мир MS Excel » Вопросы и решения » Вопросы по Excel » В ячейке цифры в виде дроби (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!