Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск значения по сравнению двух столбцов. - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения по сравнению двух столбцов. (Формулы/Formulas)
Поиск значения по сравнению двух столбцов.
kaovrn36 Дата: Пятница, 25.06.2021, 13:46 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 1
Репутация: 0 ±
Замечаний: 0% ±

Необходимо определить какая соответствует высота справа/ высота слева из таблицы H1:J33 началу участка из таблицы A1:B223. Проблем заключается в том, что нужно найти ближайшее значение из столбца H к столбцу А и по критерию "местоположение" вывести значения ближайшего участка. Хотел решить проблему через связку индекс и поискпоз. Но никак не могу с этим разобраться. Искал похожие проблемы на форуме, но не нашел то, что сможет решить мою проблему.
К сообщению приложен файл: 3412952.xlsx(11.1 Kb)
 
Ответить
СообщениеНеобходимо определить какая соответствует высота справа/ высота слева из таблицы H1:J33 началу участка из таблицы A1:B223. Проблем заключается в том, что нужно найти ближайшее значение из столбца H к столбцу А и по критерию "местоположение" вывести значения ближайшего участка. Хотел решить проблему через связку индекс и поискпоз. Но никак не могу с этим разобраться. Искал похожие проблемы на форуме, но не нашел то, что сможет решить мою проблему.

Автор - kaovrn36
Дата добавления - 25.06.2021 в 13:46
Serge_007 Дата: Пятница, 25.06.2021, 14:09 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14333
Репутация: 2368 ±
Замечаний: ±

Excel 2010
Здравствуйте

Код
=ВПР($A2;$H$1:$J$33;СТОЛБЕЦ())
К сообщению приложен файл: 20210625_kaovrn.xls(84.5 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Код
=ВПР($A2;$H$1:$J$33;СТОЛБЕЦ())

Автор - Serge_007
Дата добавления - 25.06.2021 в 14:09
китин Дата: Пятница, 25.06.2021, 14:09 | Сообщение № 3
Группа: Модераторы
Ранг: Экселист
Сообщений: 6495
Репутация: 992 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
ближайшее значение из столбца H к столбцу А и по критерию "местоположение"


с чем сравнивать 5,080 с 4,000 или 5,140 ? каковы критерии "ближайшего"?


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
ближайшее значение из столбца H к столбцу А и по критерию "местоположение"


с чем сравнивать 5,080 с 4,000 или 5,140 ? каковы критерии "ближайшего"?

Автор - китин
Дата добавления - 25.06.2021 в 14:09
NikitaDvorets Дата: Вторник, 29.06.2021, 17:56 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 176
Репутация: 40 ±
Замечаний: 0% ±

Excel 2019
Согласен с китин,
Цитата
с чем сравнивать 5,080 с 4,000 или 5,140 ? каковы критерии "ближайшего"?


kaovrn36,

Комментарий относительно термина "ближайший". Похоже, без указания критерия "допустимое отклонение" - ДО (относительное расстояние между координатами "начало участка" и "местоположение", в км) задача решения не имеет.
ДО должно быть выбрано с соблюдением "разумных ограничений":
При ограничении
Код
ДО = 0 км
- при поиске "ближайшего" не будет найдено ни одного местоположения рядом с началом участка,
При ограничении
Код
ДО = 30 км
- при поиске "ближайшего" будет найдено достаточно много "ближайших" местоположений относительно начала участка. Какое из них тогда лучше выбрать?
Для определения "разумного" ДО можно выбрать максимальное значение из массива минимальных отклонений между точками "начало участка" и массивом "местоположение":
Код
{=МИН(ABS(A2-$E$2:$E$33))}


Сообщение отредактировал NikitaDvorets - Вторник, 29.06.2021, 17:58
 
Ответить
СообщениеСогласен с китин,
Цитата
с чем сравнивать 5,080 с 4,000 или 5,140 ? каковы критерии "ближайшего"?


kaovrn36,

Комментарий относительно термина "ближайший". Похоже, без указания критерия "допустимое отклонение" - ДО (относительное расстояние между координатами "начало участка" и "местоположение", в км) задача решения не имеет.
ДО должно быть выбрано с соблюдением "разумных ограничений":
При ограничении
Код
ДО = 0 км
- при поиске "ближайшего" не будет найдено ни одного местоположения рядом с началом участка,
При ограничении
Код
ДО = 30 км
- при поиске "ближайшего" будет найдено достаточно много "ближайших" местоположений относительно начала участка. Какое из них тогда лучше выбрать?
Для определения "разумного" ДО можно выбрать максимальное значение из массива минимальных отклонений между точками "начало участка" и массивом "местоположение":
Код
{=МИН(ABS(A2-$E$2:$E$33))}

Автор - NikitaDvorets
Дата добавления - 29.06.2021 в 17:56
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск значения по сравнению двух столбцов. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!