Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск позиции с выводом строки на втором листе - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск позиции с выводом строки на втором листе (Формулы/Formulas)
Поиск позиции с выводом строки на втором листе
Derriktor Дата: Четверг, 01.07.2021, 09:35 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте!
Цель следующая, нужно формулой или макросом создать поиск по листу1 с выводом найденного значения и его строки на листе2
По поиску наименование должно выводится размер и количество
Пробую
Код
=ИНДЕКС(Лист1!A1:A17;ПОИСКПОЗ(G2;Лист1!B1:F6;1);2)
Не получается на разных листах
Можно и макрос, главное результат.
Прикладываю Файл
Заранее Спасибо!
К сообщению приложен файл: 1513891.xlsx(15.4 Kb)


Сообщение отредактировал Derriktor - Четверг, 01.07.2021, 10:04
 
Ответить
СообщениеЗдравствуйте!
Цель следующая, нужно формулой или макросом создать поиск по листу1 с выводом найденного значения и его строки на листе2
По поиску наименование должно выводится размер и количество
Пробую
Код
=ИНДЕКС(Лист1!A1:A17;ПОИСКПОЗ(G2;Лист1!B1:F6;1);2)
Не получается на разных листах
Можно и макрос, главное результат.
Прикладываю Файл
Заранее Спасибо!

Автор - Derriktor
Дата добавления - 01.07.2021 в 09:35
китин Дата: Четверг, 01.07.2021, 09:53 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6531
Репутация: 997 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Derriktor, - Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеDerriktor, - Прочитайте Правила форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

Автор - китин
Дата добавления - 01.07.2021 в 09:53
Serge_007 Дата: Четверг, 01.07.2021, 10:10 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 14465
Репутация: 2384 ±
Замечаний: ±

Excel 2010
Код
=ИНДЕКС(Лист1!A1:A17;ПОИСКПОЗ(G2;Лист1!B1:F6;1);2)
Код
=ИНДЕКС(Лист1!C1:C17;ПОИСКПОЗ(B5;Лист1!B1:B6;);)


Код
=ВПР($B5;Лист1!$B$2:$D$6;СТОЛБЕЦ()-1;0)
К сообщению приложен файл: 20210701_Derrik.xls(63.5 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Код
=ИНДЕКС(Лист1!A1:A17;ПОИСКПОЗ(G2;Лист1!B1:F6;1);2)
Код
=ИНДЕКС(Лист1!C1:C17;ПОИСКПОЗ(B5;Лист1!B1:B6;);)


Код
=ВПР($B5;Лист1!$B$2:$D$6;СТОЛБЕЦ()-1;0)

Автор - Serge_007
Дата добавления - 01.07.2021 в 10:10
китин Дата: Четверг, 01.07.2021, 10:11 | Сообщение № 4
Группа: Модераторы
Ранг: Экселист
Сообщений: 6531
Репутация: 997 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Код
=ИНДЕКС(Лист1!C$3:C$6;ПОИСКПОЗ(Лист2!$B$5;Лист1!$B$3:$B$6;0))
К сообщению приложен файл: 2482032.xlsx(15.3 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Код
=ИНДЕКС(Лист1!C$3:C$6;ПОИСКПОЗ(Лист2!$B$5;Лист1!$B$3:$B$6;0))

Автор - китин
Дата добавления - 01.07.2021 в 10:11
Derriktor Дата: Четверг, 01.07.2021, 10:22 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Спасибо Всем! Все получилось!
 
Ответить
СообщениеСпасибо Всем! Все получилось!

Автор - Derriktor
Дата добавления - 01.07.2021 в 10:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск позиции с выводом строки на втором листе (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!