Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Удалить значения в конце текста - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Удалить значения в конце текста (Формулы/Formulas)
Удалить значения в конце текста
pashatank Дата: Вторник, 06.07.2021, 07:53 | Сообщение № 1
Группа: Пользователи
Ранг: Участник
Сообщений: 56
Репутация: 0 ±
Замечаний: 40% ±

Excel 2010
Приветствую, уважаемые! Помогите решить вопрос, необходимо удалить цифровые значения заключенные в скобки, в конце текста, пример:

L-Карнитин 500мг ВИТАМИР №30 таб. (4207)
Агарикус(лиственничная губка) "Хорст" 30г (3900)
АД-Норма №60капс (0357,5604)
Гематоген Детский турбо (Школьник) 30г (4907)

нужно удалить именно цифры в конце, не трогая текст в скобках в середине, пример прицепил
К сообщению приложен файл: 4374904.xlsx(134.1 Kb)
 
Ответить
СообщениеПриветствую, уважаемые! Помогите решить вопрос, необходимо удалить цифровые значения заключенные в скобки, в конце текста, пример:

L-Карнитин 500мг ВИТАМИР №30 таб. (4207)
Агарикус(лиственничная губка) "Хорст" 30г (3900)
АД-Норма №60капс (0357,5604)
Гематоген Детский турбо (Школьник) 30г (4907)

нужно удалить именно цифры в конце, не трогая текст в скобках в середине, пример прицепил

Автор - pashatank
Дата добавления - 06.07.2021 в 07:53
Pelena Дата: Вторник, 06.07.2021, 09:15 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17889
Репутация: 3982 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Вариант
Код
=ЕСЛИ(ПРАВСИМВ(A2)=")";СЖПРОБЕЛЫ(ЛЕВСИМВ(A2;ПОИСК("#";ПОДСТАВИТЬ(A2;"(";"#";ДЛСТР(A2)-ДЛСТР(ПОДСТАВИТЬ(A2;"(";""))))-1));A2)
К сообщению приложен файл: 7324801.xlsx(130.3 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Вариант
Код
=ЕСЛИ(ПРАВСИМВ(A2)=")";СЖПРОБЕЛЫ(ЛЕВСИМВ(A2;ПОИСК("#";ПОДСТАВИТЬ(A2;"(";"#";ДЛСТР(A2)-ДЛСТР(ПОДСТАВИТЬ(A2;"(";""))))-1));A2)

Автор - Pelena
Дата добавления - 06.07.2021 в 09:15
Светлый Дата: Вторник, 06.07.2021, 09:20 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1685
Репутация: 450 ±
Замечаний: 0% ±

Excel 2013, 2016
Формула массива вводится одновременным нажатием Ctrl+Shift+Enter:
Код
=СЖПРОБЕЛЫ(ЛЕВБ(A2;ЕСЛИОШИБКА(АГРЕГАТ(14;6;ПОИСК("("&Ч(ИНДЕКС(СТРОКА($1:$10)-1;));A2);1)-1;999)))
*Лишнее можно убрать.
Код
=СЖПРОБЕЛЫ(ЛЕВБ(A2;ЕСЛИОШИБКА(АГРЕГАТ(14;6;ПОИСК("("&СТРОКА($1:$10)-1;A2);1)-1;999)))
**С АГРЕГАТ можно немассивные формулы, без АГРЕГАТ массивная:
Код
=СЖПРОБЕЛЫ(ЛЕВБ(A2;ТЕКСТ(МАКС(ЕСЛИОШИБКА(ПОИСК("("&СТРОКА($1:$10)-1;A2);))-1;"0;999")))
***Ещё массивный вариант, если после правой скобки ничего не будет:
Код
=ЕСЛИ(ПРАВБ(A2)=")";ЛЕВБ(A2;МАКС((ПСТР(A2;СТРОКА($2:$99);1)="(")*СТРОКА($1:$98)));A2)
****
Код
=ЛЕВБ(A2;МАКС((ПСТР(A2;СТРОКА($2:$99);1)="(")*СТРОКА($1:$98))+(ПРАВБ(A2)<>")")*99)
*****Так будет лучше:
Код
=ЛЕВБ(A2;ЕСЛИОШИБКА(-ПРОСМОТР(;1-ПОИСК("("&СТРОКА($1:$9);A2));999))


Программировать проще, чем писать стихи.

Сообщение отредактировал Светлый - Вторник, 06.07.2021, 14:54
 
Ответить
СообщениеФормула массива вводится одновременным нажатием Ctrl+Shift+Enter:
Код
=СЖПРОБЕЛЫ(ЛЕВБ(A2;ЕСЛИОШИБКА(АГРЕГАТ(14;6;ПОИСК("("&Ч(ИНДЕКС(СТРОКА($1:$10)-1;));A2);1)-1;999)))
*Лишнее можно убрать.
Код
=СЖПРОБЕЛЫ(ЛЕВБ(A2;ЕСЛИОШИБКА(АГРЕГАТ(14;6;ПОИСК("("&СТРОКА($1:$10)-1;A2);1)-1;999)))
**С АГРЕГАТ можно немассивные формулы, без АГРЕГАТ массивная:
Код
=СЖПРОБЕЛЫ(ЛЕВБ(A2;ТЕКСТ(МАКС(ЕСЛИОШИБКА(ПОИСК("("&СТРОКА($1:$10)-1;A2);))-1;"0;999")))
***Ещё массивный вариант, если после правой скобки ничего не будет:
Код
=ЕСЛИ(ПРАВБ(A2)=")";ЛЕВБ(A2;МАКС((ПСТР(A2;СТРОКА($2:$99);1)="(")*СТРОКА($1:$98)));A2)
****
Код
=ЛЕВБ(A2;МАКС((ПСТР(A2;СТРОКА($2:$99);1)="(")*СТРОКА($1:$98))+(ПРАВБ(A2)<>")")*99)
*****Так будет лучше:
Код
=ЛЕВБ(A2;ЕСЛИОШИБКА(-ПРОСМОТР(;1-ПОИСК("("&СТРОКА($1:$9);A2));999))

Автор - Светлый
Дата добавления - 06.07.2021 в 09:20
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Удалить значения в конце текста (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!