Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула для поиска совпадений по двум условиям - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для поиска совпадений по двум условиям (Формулы/Formulas)
Формула для поиска совпадений по двум условиям
Mazila Дата: Суббота, 10.07.2021, 13:55 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Добрый день! Помогите, пожалуйста)
Нужна формула (по принципу ВПР наверное, но с дополнительными условиями), которая сможет найти значения из столбца B в столбце А, но нужны не просто совпадения, а чтобы выполнялся ряд условий:
1) совпадают первые 8 символов
2) числа из столбца B заканчиваются на 001 (эти числа в столбце Б будут длиннее, чем в столбце А, поэтому 001 будет за рамками первых 8 символов)

То есть, мне нужно найти те номера, которые были короткие в первом столбце и стали длинными во втором и заканчиваются на 001, вот как-то так) Я полистал похожие темы на форуме, но, к сожалению, не могу пока придумать, как решить свою задачу(
К сообщению приложен файл: -1.xls(32.0 Kb)
 
Ответить
СообщениеДобрый день! Помогите, пожалуйста)
Нужна формула (по принципу ВПР наверное, но с дополнительными условиями), которая сможет найти значения из столбца B в столбце А, но нужны не просто совпадения, а чтобы выполнялся ряд условий:
1) совпадают первые 8 символов
2) числа из столбца B заканчиваются на 001 (эти числа в столбце Б будут длиннее, чем в столбце А, поэтому 001 будет за рамками первых 8 символов)

То есть, мне нужно найти те номера, которые были короткие в первом столбце и стали длинными во втором и заканчиваются на 001, вот как-то так) Я полистал похожие темы на форуме, но, к сожалению, не могу пока придумать, как решить свою задачу(

Автор - Mazila
Дата добавления - 10.07.2021 в 13:55
jakim Дата: Суббота, 10.07.2021, 14:22 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1015
Репутация: 277 ±
Замечаний: 0% ±

Excel 2010
У Вас действительно 97 оффис.
 
Ответить
СообщениеУ Вас действительно 97 оффис.

Автор - jakim
Дата добавления - 10.07.2021 в 14:22
Mazila Дата: Суббота, 10.07.2021, 15:00 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Не-не, виноват, тупанул, я наверн не так понял правила)
Написано, что: Старайтесь прилагать файлы в версии Excel 2003-го офиса(xls), так как эти файлы могут открыть пользователи с любой версией Excel, в отличие от файлов версий Excel 2007/2010/2013 (xlsх).
Вот я и не придумал ничего лучше, чем сохранить файлик в формате книги эксель 97-2003.
Вот тут обычный формат прикрепил)
К сообщению приложен файл: -1.xlsx(9.6 Kb)
 
Ответить
СообщениеНе-не, виноват, тупанул, я наверн не так понял правила)
Написано, что: Старайтесь прилагать файлы в версии Excel 2003-го офиса(xls), так как эти файлы могут открыть пользователи с любой версией Excel, в отличие от файлов версий Excel 2007/2010/2013 (xlsх).
Вот я и не придумал ничего лучше, чем сохранить файлик в формате книги эксель 97-2003.
Вот тут обычный формат прикрепил)

Автор - Mazila
Дата добавления - 10.07.2021 в 15:00
Pelena Дата: Суббота, 10.07.2021, 16:05 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 17791
Репутация: 3957 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Можно так
Код
=ЕСЛИ(ПРАВСИМВ(B2;3)="001";ВПР(--ЛЕВСИМВ(B2;8);$A$2:$A$14;1;0);"")

или с исключением ошибок #Н/Д
Код
=ЕСЛИ(ПРАВСИМВ(B2;3)="001";ЕСЛИОШИБКА(ВПР(--ЛЕВСИМВ(B2;8);$A$2:$A$14;1;0);"");"")
К сообщению приложен файл: 2067248.xlsx(10.1 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Можно так
Код
=ЕСЛИ(ПРАВСИМВ(B2;3)="001";ВПР(--ЛЕВСИМВ(B2;8);$A$2:$A$14;1;0);"")

или с исключением ошибок #Н/Д
Код
=ЕСЛИ(ПРАВСИМВ(B2;3)="001";ЕСЛИОШИБКА(ВПР(--ЛЕВСИМВ(B2;8);$A$2:$A$14;1;0);"");"")

Автор - Pelena
Дата добавления - 10.07.2021 в 16:05
Mazila Дата: Суббота, 10.07.2021, 16:35 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Большое спасибо!)
Вот эти формулы с левыми/правыми символами вообще не знаю, буду изучать, очень полезны в работе будут)


Сообщение отредактировал Serge_007 - Понедельник, 12.07.2021, 09:02
 
Ответить
СообщениеБольшое спасибо!)
Вот эти формулы с левыми/правыми символами вообще не знаю, буду изучать, очень полезны в работе будут)

Автор - Mazila
Дата добавления - 10.07.2021 в 16:35
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула для поиска совпадений по двум условиям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!