Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/попадание в диапозон времени и даты. - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » попадание в диапозон времени и даты. (Формулы/Formulas)
попадание в диапозон времени и даты.
Valet Дата: Четверг, 22.07.2021, 01:44 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Добрый день. Помогите пожалуйста подобрать формулу. Нужно чтобы по ед оборудования выводил номер водителя если он попадает в диапозон времени и даты.
Пробовал через Если - не вышло. Может коряво делал)
К сообщению приложен файл: New_Microsoft_E.xlsx(25.0 Kb)
 
Ответить
СообщениеДобрый день. Помогите пожалуйста подобрать формулу. Нужно чтобы по ед оборудования выводил номер водителя если он попадает в диапозон времени и даты.
Пробовал через Если - не вышло. Может коряво делал)

Автор - Valet
Дата добавления - 22.07.2021 в 01:44
Светлый Дата: Четверг, 22.07.2021, 06:31 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 1676
Репутация: 447 ±
Замечаний: 0% ±

Excel 2013, 2016
Добрый день!
Формула массива вводится одновременным нажатием Ctrl+Shift+Enter:
Код
=ЕСЛИОШИБКА(ИНДЕКС(лист2!$B:$B;НАИМЕНЬШИЙ(ЕСЛИ(($B2+$C2>=лист2!$C$2:$C$325+лист2!$D$2:$D$325)*($B2+$C2<=лист2!$E$2:$E$325+лист2!$F$2:$F$325);СТРОКА(лист2!$F$2:$F$325));СТОЛБЕЦ(A2)));"")
Протянуть формулу вниз и вправо.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеДобрый день!
Формула массива вводится одновременным нажатием Ctrl+Shift+Enter:
Код
=ЕСЛИОШИБКА(ИНДЕКС(лист2!$B:$B;НАИМЕНЬШИЙ(ЕСЛИ(($B2+$C2>=лист2!$C$2:$C$325+лист2!$D$2:$D$325)*($B2+$C2<=лист2!$E$2:$E$325+лист2!$F$2:$F$325);СТРОКА(лист2!$F$2:$F$325));СТОЛБЕЦ(A2)));"")
Протянуть формулу вниз и вправо.

Автор - Светлый
Дата добавления - 22.07.2021 в 06:31
jakim Дата: Четверг, 22.07.2021, 11:45 | Сообщение № 3
Группа: Друзья
Ранг: Старожил
Сообщений: 1035
Репутация: 278 ±
Замечаний: 0% ±

Excel 2010
Формула

Код
=IFERROR(INDEX(лист2!$B$2:$B$1000;AGGREGATE(15;6;ROW($1:$1000)/(($B2+$C2)>=(лист2!$C$2:$C$1000+лист2!$D$2:$D$1000))/(($B2+$C2)<=(лист2!$E$2:$E$1000+лист2!$F$2:$F$1000))/($A2=лист2!$A$2:$A$1000);COLUMNS($D:D)));"")
К сообщению приложен файл: 2847013.xlsx(27.0 Kb)


Сообщение отредактировал jakim - Четверг, 22.07.2021, 11:47
 
Ответить
Сообщение
Формула

Код
=IFERROR(INDEX(лист2!$B$2:$B$1000;AGGREGATE(15;6;ROW($1:$1000)/(($B2+$C2)>=(лист2!$C$2:$C$1000+лист2!$D$2:$D$1000))/(($B2+$C2)<=(лист2!$E$2:$E$1000+лист2!$F$2:$F$1000))/($A2=лист2!$A$2:$A$1000);COLUMNS($D:D)));"")

Автор - jakim
Дата добавления - 22.07.2021 в 11:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » попадание в диапозон времени и даты. (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!