Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ВПР не привязывает описание - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР не привязывает описание (Формулы/Formulas)
ВПР не привязывает описание
Димарик Дата: Понедельник, 02.08.2021, 14:54 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 12
Репутация: 0 ±
Замечаний: 20% ±

Добрый день. Подскажите пожалуйста, почему не срабатывает формула! Скорее всего даже дело не в формуле а в диапазоне, как лучше сделать, чтобы все работало? Имеется такая формула:
[vba]
Код
=ЕСЛИОШИБКА(ВПР($A5;Прайс.xlsm!Таблица10[#Данные];2;0);"")
[/vba]
Она выводит данные описания товара, с другой книги, в определенную строку бланка заказа!
в другой строке, есть аналогичная формула, только разумеется ссылается на туже книгу, только другой лист, но и сравнивает другую ячейку. Так вот, вторая формула работает, все нормально (в выпадающем списке выбираем нужную номенклатуру и автоматически подставляется описание этой номенклатуры, а вот в первой формуле нет! Не могу понять почему. Формула ссылается на Диспетчер имен (умная таблица)!


Сообщение отредактировал Serge_007 - Понедельник, 02.08.2021, 15:02
 
Ответить
СообщениеДобрый день. Подскажите пожалуйста, почему не срабатывает формула! Скорее всего даже дело не в формуле а в диапазоне, как лучше сделать, чтобы все работало? Имеется такая формула:
[vba]
Код
=ЕСЛИОШИБКА(ВПР($A5;Прайс.xlsm!Таблица10[#Данные];2;0);"")
[/vba]
Она выводит данные описания товара, с другой книги, в определенную строку бланка заказа!
в другой строке, есть аналогичная формула, только разумеется ссылается на туже книгу, только другой лист, но и сравнивает другую ячейку. Так вот, вторая формула работает, все нормально (в выпадающем списке выбираем нужную номенклатуру и автоматически подставляется описание этой номенклатуры, а вот в первой формуле нет! Не могу понять почему. Формула ссылается на Диспетчер имен (умная таблица)!

Автор - Димарик
Дата добавления - 02.08.2021 в 14:54
китин Дата: Понедельник, 02.08.2021, 15:00 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6531
Репутация: 997 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Димарик, - Прочитайте Правила форума
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 500 кб согласно п.3 Правил форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
СообщениеДимарик, - Прочитайте Правила форума
- Приложите файл с исходными данными и желаемым результатом (можно вручную) в формате Excel размером до 500 кб согласно п.3 Правил форума
- Оформите формулу тегами (в режиме правки поста выделите формулу и нажмите кнопку fx, пояснялка здесь)

Автор - китин
Дата добавления - 02.08.2021 в 15:00
bmv98rus Дата: Понедельник, 02.08.2021, 15:52 | Сообщение № 3
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3651
Репутация: 647 ±
Замечаний: 0% ±

Excel 2013/2016
и не бегайте по форумам делая один и тот же список ошибок


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщениеи не бегайте по форумам делая один и тот же список ошибок

Автор - bmv98rus
Дата добавления - 02.08.2021 в 15:52
Pelena Дата: Понедельник, 02.08.2021, 15:57 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 17873
Репутация: 4019 ±
Замечаний: ±

Excel 2016 & Mac Excel
Предположу, что Таблица10[#Данные] - это обращение к одному столбцу таблицы, а представленная функция ВПР требует по крайней мере два столбца


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеПредположу, что Таблица10[#Данные] - это обращение к одному столбцу таблицы, а представленная функция ВПР требует по крайней мере два столбца

Автор - Pelena
Дата добавления - 02.08.2021 в 15:57
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР не привязывает описание (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!