Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сравнение 2ух масивов и выведение недостающего - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение 2ух масивов и выведение недостающего (Формулы/Formulas)
Сравнение 2ух масивов и выведение недостающего
negodyaj14 Дата: Суббота, 07.08.2021, 18:17 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Всем привет! Есть столбец А в нем значения, и столбец Б где есть только часть значений из 1 столбца и в другом порядке. Нужно дозаполнить его тем чего не хватает.
Такая некая кастомная сортировка, где начало задаю я, а дальше так как в исходнике было.
К сообщению приложен файл: 6231890.xlsx(8.3 Kb)
 
Ответить
СообщениеВсем привет! Есть столбец А в нем значения, и столбец Б где есть только часть значений из 1 столбца и в другом порядке. Нужно дозаполнить его тем чего не хватает.
Такая некая кастомная сортировка, где начало задаю я, а дальше так как в исходнике было.

Автор - negodyaj14
Дата добавления - 07.08.2021 в 18:17
Pelena Дата: Суббота, 07.08.2021, 19:09 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17889
Репутация: 3982 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Код
=ИНДЕКС($A$1:$A$7; АГРЕГАТ(15;6;СТРОКА($A$1:$A$7)/(СЧЁТЕСЛИ($B$1:B2;$A$1:$A$7)=0);1))
К сообщению приложен файл: 3662430.xlsx(9.8 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ИНДЕКС($A$1:$A$7; АГРЕГАТ(15;6;СТРОКА($A$1:$A$7)/(СЧЁТЕСЛИ($B$1:B2;$A$1:$A$7)=0);1))

Автор - Pelena
Дата добавления - 07.08.2021 в 19:09
negodyaj Дата: Воскресенье, 08.08.2021, 13:39 | Сообщение № 3
Группа: Пользователи
Ранг: Участник
Сообщений: 93
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Дублирую все это в гугл таблицы еще и там функции АГРЕГАТ не существует, есть решения -аналог?
 
Ответить
СообщениеДублирую все это в гугл таблицы еще и там функции АГРЕГАТ не существует, есть решения -аналог?

Автор - negodyaj
Дата добавления - 08.08.2021 в 13:39
Pelena Дата: Воскресенье, 08.08.2021, 15:14 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 17889
Репутация: 3982 ±
Замечаний: ±

Excel 2016 & Mac Excel
Формула массива
Код
=ИНДЕКС($A$1:$A$7; МИН(ЕСЛИ(СЧЁТЕСЛИ($B$1:B2;$A$1:$A$7)=0;СТРОКА($A$1:$A$7))))

Дублирую все это в гугл таблицы
на форуме есть отдельный раздел для гугл таблиц


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеФормула массива
Код
=ИНДЕКС($A$1:$A$7; МИН(ЕСЛИ(СЧЁТЕСЛИ($B$1:B2;$A$1:$A$7)=0;СТРОКА($A$1:$A$7))))

Дублирую все это в гугл таблицы
на форуме есть отдельный раздел для гугл таблиц

Автор - Pelena
Дата добавления - 08.08.2021 в 15:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сравнение 2ух масивов и выведение недостающего (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!