Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск артикула в таблице и сравнение его значений - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск артикула в таблице и сравнение его значений (Формулы/Formulas)
Поиск артикула в таблице и сравнение его значений
andreyyqqq Дата: Пятница, 20.08.2021, 10:14 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 20% ±

Добрый день. Есть таблица Excel со столбцами A - артикул, B - значение, C - другие артикулы, D - другие значения
Мне нужно брать значение А1( и т.д.), узнать, есть ли оно в столбце C. Если есть, то нужно узнать разность их значений (D - B). Если их разность не равна 0, то нужно в любой другой столбец выводить артикул и разность. Столбец C и D связаны (То есть у артикула всегда будет его значение)
Подскажите пожалуйста, как можно такое реализовать. У меня получилось определять, есть ли артикул из столбца А, в столбце С (с помощью ПОИСКПОЗ). А как там уже значения вычитать, я не знаю
Буду огромно благодарен каждому за участие!
 
Ответить
СообщениеДобрый день. Есть таблица Excel со столбцами A - артикул, B - значение, C - другие артикулы, D - другие значения
Мне нужно брать значение А1( и т.д.), узнать, есть ли оно в столбце C. Если есть, то нужно узнать разность их значений (D - B). Если их разность не равна 0, то нужно в любой другой столбец выводить артикул и разность. Столбец C и D связаны (То есть у артикула всегда будет его значение)
Подскажите пожалуйста, как можно такое реализовать. У меня получилось определять, есть ли артикул из столбца А, в столбце С (с помощью ПОИСКПОЗ). А как там уже значения вычитать, я не знаю
Буду огромно благодарен каждому за участие!

Автор - andreyyqqq
Дата добавления - 20.08.2021 в 10:14
Nic70y Дата: Пятница, 20.08.2021, 10:40 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7017
Репутация: 1618 ±
Замечаний: 0% ±

Excel 2010
Код
=ВПР()-ВПР()
подробнее с Вашим файлом


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
Код
=ВПР()-ВПР()
подробнее с Вашим файлом

Автор - Nic70y
Дата добавления - 20.08.2021 в 10:40
andreyyqqq Дата: Пятница, 20.08.2021, 10:43 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 20% ±

Nic70y, прикрепил пример как выглядит таблица
К сообщению приложен файл: 0780942.png(7.1 Kb)


Сообщение отредактировал andreyyqqq - Пятница, 20.08.2021, 10:44
 
Ответить
СообщениеNic70y, прикрепил пример как выглядит таблица

Автор - andreyyqqq
Дата добавления - 20.08.2021 в 10:43
Serge_007 Дата: Пятница, 20.08.2021, 10:45 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14465
Репутация: 2384 ±
Замечаний: ±

Excel 2010
andreyyqqq, здравствуйте

Прочитайте правила форума


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщениеandreyyqqq, здравствуйте

Прочитайте правила форума

Автор - Serge_007
Дата добавления - 20.08.2021 в 10:45
Nic70y Дата: Пятница, 20.08.2021, 10:45 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 7017
Репутация: 1618 ±
Замечаний: 0% ±

Excel 2010
andreyyqqq, это и так понятно,
нужен файл-эксель, на картинке не удобно писать формулы


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщениеandreyyqqq, это и так понятно,
нужен файл-эксель, на картинке не удобно писать формулы

Автор - Nic70y
Дата добавления - 20.08.2021 в 10:45
andreyyqqq Дата: Пятница, 20.08.2021, 10:47 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 20% ±

Nic70y,
К сообщению приложен файл: my_book.xlsx(30.9 Kb)
 
Ответить
СообщениеNic70y,

Автор - andreyyqqq
Дата добавления - 20.08.2021 в 10:47
Serge_007 Дата: Пятница, 20.08.2021, 10:56 | Сообщение № 7
Группа: Админы
Ранг: Местный житель
Сообщений: 14465
Репутация: 2384 ±
Замечаний: ±

Excel 2010
См. вложение
К сообщению приложен файл: 20210820_andrey.xls(198.0 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеСм. вложение

Автор - Serge_007
Дата добавления - 20.08.2021 в 10:56
Nic70y Дата: Пятница, 20.08.2021, 10:56 | Сообщение № 8
Группа: Друзья
Ранг: Экселист
Сообщений: 7017
Репутация: 1618 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ(ЕСЛИОШИБКА(ПОДСТАВИТЬ(B1;СИМВОЛ(160);)-ПОДСТАВИТЬ(ВПР(A1;C:D;2;);СИМВОЛ(160););)<>0;A1;"")
Код
=ЕСЛИ(E1="";"";ПОДСТАВИТЬ(B1;СИМВОЛ(160);)-ПОДСТАВИТЬ(ВПР(A1;C:D;2;);СИМВОЛ(160);))
К сообщению приложен файл: 24.xlsx(46.2 Kb)


ЮMoney(Яндекс Деньги) 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕСЛИОШИБКА(ПОДСТАВИТЬ(B1;СИМВОЛ(160);)-ПОДСТАВИТЬ(ВПР(A1;C:D;2;);СИМВОЛ(160););)<>0;A1;"")
Код
=ЕСЛИ(E1="";"";ПОДСТАВИТЬ(B1;СИМВОЛ(160);)-ПОДСТАВИТЬ(ВПР(A1;C:D;2;);СИМВОЛ(160);))

Автор - Nic70y
Дата добавления - 20.08.2021 в 10:56
andreyyqqq Дата: Пятница, 20.08.2021, 11:05 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 20% ±

Serge_007, Nic70y, Благодарю за помощь
 
Ответить
СообщениеSerge_007, Nic70y, Благодарю за помощь

Автор - andreyyqqq
Дата добавления - 20.08.2021 в 11:05
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск артикула в таблице и сравнение его значений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!