Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Подсчет количества различных значений внутри серии - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества различных значений внутри серии (Формулы/Formulas)
Подсчет количества различных значений внутри серии
socula24 Дата: Среда, 08.09.2021, 15:28 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Имеется таблица с продуктами. У каждого продукта указана серия и плавка. Необходимо посчитать какое количество плавок (различных значений) входит в каждую серию и вывести в отдельном столбце для каждого продукта.

Всю голову сломала, в Excel новичок. Пробовала sumproduct(1/countif), но так считает, если прямо выделить диапазон серии, а для каждой серии диапазон будет разный.
К сообщению приложен файл: Example.xlsx(14.4 Kb)
 
Ответить
СообщениеИмеется таблица с продуктами. У каждого продукта указана серия и плавка. Необходимо посчитать какое количество плавок (различных значений) входит в каждую серию и вывести в отдельном столбце для каждого продукта.

Всю голову сломала, в Excel новичок. Пробовала sumproduct(1/countif), но так считает, если прямо выделить диапазон серии, а для каждой серии диапазон будет разный.

Автор - socula24
Дата добавления - 08.09.2021 в 15:28
MCH Дата: Среда, 08.09.2021, 15:52 | Сообщение № 2
Группа: Админы
Ранг: Старожил
Сообщений: 1969
Репутация: 737 ±
Замечаний: ±

так нужно?
К сообщению приложен файл: Example-2.xlsx(18.3 Kb)
 
Ответить
Сообщениетак нужно?

Автор - MCH
Дата добавления - 08.09.2021 в 15:52
socula24 Дата: Среда, 08.09.2021, 15:56 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

MCH, да, спасибо большое!!!
 
Ответить
СообщениеMCH, да, спасибо большое!!!

Автор - socula24
Дата добавления - 08.09.2021 в 15:56
YouGreed Дата: Среда, 08.09.2021, 16:03 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 583
Репутация: 121 ±
Замечаний: 0% ±

Excel 2010
socula24, Попробуем так

Код
=ЕСЛИ(C1=C2;"";СЧЁТЕСЛИМН($B$2:$B$256;$B2;$C$2:$C$256;$C2))
 
Ответить
Сообщениеsocula24, Попробуем так

Код
=ЕСЛИ(C1=C2;"";СЧЁТЕСЛИМН($B$2:$B$256;$B2;$C$2:$C$256;$C2))

Автор - YouGreed
Дата добавления - 08.09.2021 в 16:03
Pelena Дата: Среда, 08.09.2021, 18:22 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 17873
Репутация: 4019 ±
Замечаний: ±

Excel 2016 & Mac Excel
Ещё вариант сводной с задействованной моделью данных
К сообщению приложен файл: 1362391.xlsx(104.5 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕщё вариант сводной с задействованной моделью данных

Автор - Pelena
Дата добавления - 08.09.2021 в 18:22
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Подсчет количества различных значений внутри серии (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!