Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск и вывод значений в массиве данных - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск и вывод значений в массиве данных (Формулы/Formulas)
Поиск и вывод значений в массиве данных
sarapev Дата: Вторник, 14.09.2021, 13:20 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Добрый день.
Имеется список слов (категория товара), каждое по очереди нужно найти о найти в массиве данных (одна колонка в 5 тыс строк). Массив данных представляет собой описание товара, которое содержит категорию товара . В колонке рядом выводится найденное значение.
Заранее спасибо за помощь
К сообщению приложен файл: 1231659.xlsx(10.2 Kb)


Сообщение отредактировал sarapev - Вторник, 14.09.2021, 13:47
 
Ответить
СообщениеДобрый день.
Имеется список слов (категория товара), каждое по очереди нужно найти о найти в массиве данных (одна колонка в 5 тыс строк). Массив данных представляет собой описание товара, которое содержит категорию товара . В колонке рядом выводится найденное значение.
Заранее спасибо за помощь

Автор - sarapev
Дата добавления - 14.09.2021 в 13:20
Pelena Дата: Вторник, 14.09.2021, 13:28 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 17961
Репутация: 4001 ±
Замечаний: ±

Excel 2016 & Mac Excel
И Вам здравствуйте.
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$12;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(ПОИСК($A$2:$A$12;A16));0));"-")

Если именно слова целиком, а не вхождение, то
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$12;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(ПОИСК(" "&$A$2:$A$12&" ";" "&A16&" "));0));"-")
К сообщению приложен файл: 8746119.xlsx(11.7 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеИ Вам здравствуйте.
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$12;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(ПОИСК($A$2:$A$12;A16));0));"-")

Если именно слова целиком, а не вхождение, то
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$12;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(ПОИСК(" "&$A$2:$A$12&" ";" "&A16&" "));0));"-")

Автор - Pelena
Дата добавления - 14.09.2021 в 13:28
sarapev Дата: Вторник, 14.09.2021, 14:09 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Pelena, спасибо ! но что-то у меня пошло не так ((
Видно ручки кривоваты или знаний не хватает :'(
К сообщению приложен файл: 4043862.xlsx(9.4 Kb)
 
Ответить
СообщениеPelena, спасибо ! но что-то у меня пошло не так ((
Видно ручки кривоваты или знаний не хватает :'(

Автор - sarapev
Дата добавления - 14.09.2021 в 14:09
Serge_007 Дата: Вторник, 14.09.2021, 14:24 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14580
Репутация: 2409 ±
Замечаний: ±

Excel 2010
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$9;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(ПОИСК($B$2:$B$9;B11));0));"-")
К сообщению приложен файл: 20210914_sarape.xls(58.5 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B$9;ПОИСКПОЗ(ИСТИНА;ЕЧИСЛО(ПОИСК($B$2:$B$9;B11));0));"-")

Автор - Serge_007
Дата добавления - 14.09.2021 в 14:24
sarapev Дата: Вторник, 14.09.2021, 15:34 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 3
Репутация: 0 ±
Замечаний: 0% ±

Serge_007, Спасибо огромное - заработало !
 
Ответить
СообщениеSerge_007, Спасибо огромное - заработало !

Автор - sarapev
Дата добавления - 14.09.2021 в 15:34
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск и вывод значений в массиве данных (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!