Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/динамическая выборка диапазона данных по датам - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » динамическая выборка диапазона данных по датам (Формулы/Formulas)
динамическая выборка диапазона данных по датам
Мастер_ИП Дата: Вторник, 14.09.2021, 16:37 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Доброго времени суток;)

Столкнулся с проблемой по выборке данных по датам, конкретнее месяцам.
В формуле, которую, я с трудом нашел в инэте, все месяца находятся кроме сентября!
Например ячейка D24
Вопрос где я накосячил?

[p.s.]Понимаю что описал проблему , так себе , просто нужны наводящие вопросы.
[p.p.s.] HELP!
К сообщению приложен файл: __.xlsm(69.9 Kb)
 
Ответить
СообщениеДоброго времени суток;)

Столкнулся с проблемой по выборке данных по датам, конкретнее месяцам.
В формуле, которую, я с трудом нашел в инэте, все месяца находятся кроме сентября!
Например ячейка D24
Вопрос где я накосячил?

[p.s.]Понимаю что описал проблему , так себе , просто нужны наводящие вопросы.
[p.p.s.] HELP!

Автор - Мастер_ИП
Дата добавления - 14.09.2021 в 16:37
Serge_007 Дата: Вторник, 14.09.2021, 17:00 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 14580
Репутация: 2409 ±
Замечаний: ±

Excel 2010
Здравствуйте

Цитата Мастер_ИП, 14.09.2021 в 16:37, в сообщении № 1 ()
Например ячейка D24
Код
=СУММПРОИЗВ((МЕСЯЦ(Доходы!A$3:A$5)=МЕСЯЦ(B24))*Доходы!B$3:B$5)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Цитата Мастер_ИП, 14.09.2021 в 16:37, в сообщении № 1 ()
Например ячейка D24
Код
=СУММПРОИЗВ((МЕСЯЦ(Доходы!A$3:A$5)=МЕСЯЦ(B24))*Доходы!B$3:B$5)

Автор - Serge_007
Дата добавления - 14.09.2021 в 17:00
YouGreed Дата: Вторник, 14.09.2021, 17:07 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 584
Репутация: 121 ±
Замечаний: 0% ±

Excel 2010
Мастер_ИП, Если уж хочется, по старой формуле. То, у Вас в сентябре 31 день, а в календаре 30 дней... Вот он и противится такой несправедливости.
 
Ответить
СообщениеМастер_ИП, Если уж хочется, по старой формуле. То, у Вас в сентябре 31 день, а в календаре 30 дней... Вот он и противится такой несправедливости.

Автор - YouGreed
Дата добавления - 14.09.2021 в 17:07
Мастер_ИП Дата: Вторник, 14.09.2021, 21:02 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Serge_007, Спасибо за ответ! Это именно то что мне нужно!

YouGreed, Спасибо за пояснение ошибки, а то я уже всю голову сломал пытаясь понять в чем причина.

Проблема решена! hands hands hands hands
 
Ответить
СообщениеSerge_007, Спасибо за ответ! Это именно то что мне нужно!

YouGreed, Спасибо за пояснение ошибки, а то я уже всю голову сломал пытаясь понять в чем причина.

Проблема решена! hands hands hands hands

Автор - Мастер_ИП
Дата добавления - 14.09.2021 в 21:02
Мир MS Excel » Вопросы и решения » Вопросы по Excel » динамическая выборка диапазона данных по датам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!