Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск чисел в диапазоне - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск чисел в диапазоне (Формулы/Formulas)
Поиск чисел в диапазоне
Thierry[HenRy-14] Дата: Четверг, 16.09.2021, 19:30 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Доброго время дня!

Подскажите с помощью какой формулы можно найти все значения в диапазоне

>=1 ,но =<15
>=16 ,но =<30
>=31 ,но =<45
>=46 ,но =<60
>=61 ,но =<75
>=76 ,но =<90
 
Ответить
СообщениеДоброго время дня!

Подскажите с помощью какой формулы можно найти все значения в диапазоне

>=1 ,но =<15
>=16 ,но =<30
>=31 ,но =<45
>=46 ,но =<60
>=61 ,но =<75
>=76 ,но =<90

Автор - Thierry[HenRy-14]
Дата добавления - 16.09.2021 в 19:30
Thierry[HenRy-14] Дата: Четверг, 16.09.2021, 19:38 | Сообщение № 2
Группа: Пользователи
Ранг: Новичок
Сообщений: 25
Репутация: 0 ±
Замечаний: 0% ±

Код
=СЧЁТЕСЛИ(AAN4:AAN53;"=16")+СЧЁТЕСЛИ(AAN4:AAN53;"=17")+СЧЁТЕСЛИ(AAN4:AAN53;"=18")+СЧЁТЕСЛИ(AAN4:AAN53;"=19")+СЧЁТЕСЛИ(AAN4:AAN53;"=20")+СЧЁТЕСЛИ(AAN4:AAN53;"=21")+СЧЁТЕСЛИ(AAN4:AAN53;"=22")+СЧЁТЕСЛИ(AAN4:AAN53;"=23")+СЧЁТЕСЛИ(AAN4:AAN53;"=24")+СЧЁТЕСЛИ(AAN4:AAN53;"=25")+СЧЁТЕСЛИ(AAN4:AAN53;"=26")+СЧЁТЕСЛИ(AAN4:AAN53;"=27")+СЧЁТЕСЛИ(AAN4:AAN53;"=28")+СЧЁТЕСЛИ(AAN4:AAN53;"=29")+СЧЁТЕСЛИ(AAN4:AAN53;"=30")
Цитата


очень долгая формула)) есть вариант проще?
 
Ответить
Сообщение
Код
=СЧЁТЕСЛИ(AAN4:AAN53;"=16")+СЧЁТЕСЛИ(AAN4:AAN53;"=17")+СЧЁТЕСЛИ(AAN4:AAN53;"=18")+СЧЁТЕСЛИ(AAN4:AAN53;"=19")+СЧЁТЕСЛИ(AAN4:AAN53;"=20")+СЧЁТЕСЛИ(AAN4:AAN53;"=21")+СЧЁТЕСЛИ(AAN4:AAN53;"=22")+СЧЁТЕСЛИ(AAN4:AAN53;"=23")+СЧЁТЕСЛИ(AAN4:AAN53;"=24")+СЧЁТЕСЛИ(AAN4:AAN53;"=25")+СЧЁТЕСЛИ(AAN4:AAN53;"=26")+СЧЁТЕСЛИ(AAN4:AAN53;"=27")+СЧЁТЕСЛИ(AAN4:AAN53;"=28")+СЧЁТЕСЛИ(AAN4:AAN53;"=29")+СЧЁТЕСЛИ(AAN4:AAN53;"=30")
Цитата


очень долгая формула)) есть вариант проще?

Автор - Thierry[HenRy-14]
Дата добавления - 16.09.2021 в 19:38
прохожий2019 Дата: Четверг, 16.09.2021, 20:13 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 676
Репутация: 171 ±
Замечаний: 0% ±

365 Beta Channel
Код
=СЧЁТЕСЛИМН(A4:A58;">=16";A4:A58;"<=30")
 
Ответить
Сообщение
Код
=СЧЁТЕСЛИМН(A4:A58;">=16";A4:A58;"<=30")

Автор - прохожий2019
Дата добавления - 16.09.2021 в 20:13
bmv98rus Дата: Четверг, 16.09.2021, 20:36 | Сообщение № 4
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3667
Репутация: 650 ±
Замечаний: 0% ±

Excel 2013/2016
Цитата Thierry|HenRy-14|, 16.09.2021 в 19:30, в сообщении № 1 ()
все значения в диапазоне

>=1 ,но =<15
>=16 ,но =<30
>=31 ,но =<45
>=46 ,но =<60
>=61 ,но =<75
>=76 ,но =<90
ну если это диапазон, то тогда можно не искать их там нет, так как взаимоисключающие диапазоны.
Далее подсчет значений и поиск - ну не совсем тоже, ну а в цело м да №3


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
Сообщение
Цитата Thierry|HenRy-14|, 16.09.2021 в 19:30, в сообщении № 1 ()
все значения в диапазоне

>=1 ,но =<15
>=16 ,но =<30
>=31 ,но =<45
>=46 ,но =<60
>=61 ,но =<75
>=76 ,но =<90
ну если это диапазон, то тогда можно не искать их там нет, так как взаимоисключающие диапазоны.
Далее подсчет значений и поиск - ну не совсем тоже, ну а в цело м да №3

Автор - bmv98rus
Дата добавления - 16.09.2021 в 20:36
NikitaDvorets Дата: Пятница, 17.09.2021, 09:43 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 245
Репутация: 41 ±
Замечаний: 0% ±

Excel 2019
Цитата
ну если это диапазон, то тогда можно не искать их там нет, так как взаимоисключающие диапазоны
hands
Цитата
Подскажите с помощью какой формулы можно найти все значения в диапазоне


Возможно, более точной формулировкой задачи было бы:
С помощью какой формулы можно найти - каким диапазонам принадлежат все заданные значения?
Но тогда - где в условии задачи эти заданные значения?
 
Ответить
Сообщение
Цитата
ну если это диапазон, то тогда можно не искать их там нет, так как взаимоисключающие диапазоны
hands
Цитата
Подскажите с помощью какой формулы можно найти все значения в диапазоне


Возможно, более точной формулировкой задачи было бы:
С помощью какой формулы можно найти - каким диапазонам принадлежат все заданные значения?
Но тогда - где в условии задачи эти заданные значения?

Автор - NikitaDvorets
Дата добавления - 17.09.2021 в 09:43
jakim Дата: Пятница, 17.09.2021, 14:14 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 1041
Репутация: 278 ±
Замечаний: 0% ±

Excel 2010
Формула

Код
=IFERROR(AGGREGATE(15;6;$A$1:$A$200/($A$1:$A$200>D$1)/($A$1:$A$200<=E$1);ROWS($2:2));"")
К сообщению приложен файл: Book1.xlsx(14.9 Kb)
 
Ответить
Сообщение
Формула

Код
=IFERROR(AGGREGATE(15;6;$A$1:$A$200/($A$1:$A$200>D$1)/($A$1:$A$200<=E$1);ROWS($2:2));"")

Автор - jakim
Дата добавления - 17.09.2021 в 14:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск чисел в диапазоне (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!