Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сосчитать число повторений A1 на нескольких листах - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сосчитать число повторений A1 на нескольких листах (Формулы/Formulas)
Сосчитать число повторений A1 на нескольких листах
yaweg87 Дата: Воскресенье, 19.09.2021, 11:46 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

Добрый день.
Помогите упростить формулу:
Код
=ЕСЛИ(Лист1!$A$1=A2;1;0)+ЕСЛИ(Лист2!$A$1=A2;1;0)+ЕСЛИ(Лист3!$A$1=A2;1;0)+ЕСЛИ(Лист4!$A$1=A2;1;0)+ЕСЛИ(Лист5!$A$1=A2;1;0)

На листах "Лист1"..."Лист5" в ячейке "А1" записано какое-либо число или пусто.
На листе "Сумма" в "A2", "A3"... заносим любое значение, а в "B2", "B3"... необходимо сосчитать число повторений этого значения с "А1" Лист1...Лист5.
Так, чтобы при сортировке по "A" или "B" формула не слетала.

В прикрепленном файлике всё правильно считается, но хотелось бы покороче и красивее.
Спасибо.
К сообщению приложен файл: 6108270.xlsx(12.6 Kb)
 
Ответить
СообщениеДобрый день.
Помогите упростить формулу:
Код
=ЕСЛИ(Лист1!$A$1=A2;1;0)+ЕСЛИ(Лист2!$A$1=A2;1;0)+ЕСЛИ(Лист3!$A$1=A2;1;0)+ЕСЛИ(Лист4!$A$1=A2;1;0)+ЕСЛИ(Лист5!$A$1=A2;1;0)

На листах "Лист1"..."Лист5" в ячейке "А1" записано какое-либо число или пусто.
На листе "Сумма" в "A2", "A3"... заносим любое значение, а в "B2", "B3"... необходимо сосчитать число повторений этого значения с "А1" Лист1...Лист5.
Так, чтобы при сортировке по "A" или "B" формула не слетала.

В прикрепленном файлике всё правильно считается, но хотелось бы покороче и красивее.
Спасибо.

Автор - yaweg87
Дата добавления - 19.09.2021 в 11:46
Egyptian Дата: Воскресенье, 19.09.2021, 12:18 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 183
Репутация: 58 ±
Замечаний: 0% ±

Excel 2013/2016
С доп. столбцом в котором прописываются все нужные листы и именованным диапазоном.
Формула массива. (Ввводить через CTRL+SHIFT+ENTER)
Код
=SUM(IFERROR(COUNTIF(INDIRECT("'"&диап&"'!A:A");A2);))
К сообщению приложен файл: 9074456.xlsx(12.9 Kb)


Сообщение отредактировал Egyptian - Воскресенье, 19.09.2021, 12:19
 
Ответить
СообщениеС доп. столбцом в котором прописываются все нужные листы и именованным диапазоном.
Формула массива. (Ввводить через CTRL+SHIFT+ENTER)
Код
=SUM(IFERROR(COUNTIF(INDIRECT("'"&диап&"'!A:A");A2);))

Автор - Egyptian
Дата добавления - 19.09.2021 в 12:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сосчитать число повторений A1 на нескольких листах (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!