Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Отображение данных из вертикальной таблицы в горизонтальную - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отображение данных из вертикальной таблицы в горизонтальную (Формулы/Formulas)
Отображение данных из вертикальной таблицы в горизонтальную
karasevslav Дата: Воскресенье, 19.09.2021, 23:27 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Добрый вечер!
Столкнулся с необходимостью отображения данных из вертикальной таблицу в горизонтальную, так как более наглядно.
В вертикальной имеются даты дни недели и соответвующие показатели компании по определённым критериям на данную дату.
Возможно ли настроить формулу, чтобы на одном листе продолжить заполнять актуальные данные и они автоматически подгружались в горизонтальную таблицу?

Прикрепляю файл с примером отображения. Справа как выглядит таблица, которая заполняется, слева, куда необходимо переносить данные.

Заранее спасибо.
К сообщению приложен файл: 9989728.xlsx(11.3 Kb)
 
Ответить
СообщениеДобрый вечер!
Столкнулся с необходимостью отображения данных из вертикальной таблицу в горизонтальную, так как более наглядно.
В вертикальной имеются даты дни недели и соответвующие показатели компании по определённым критериям на данную дату.
Возможно ли настроить формулу, чтобы на одном листе продолжить заполнять актуальные данные и они автоматически подгружались в горизонтальную таблицу?

Прикрепляю файл с примером отображения. Справа как выглядит таблица, которая заполняется, слева, куда необходимо переносить данные.

Заранее спасибо.

Автор - karasevslav
Дата добавления - 19.09.2021 в 23:27
Nic70y Дата: Понедельник, 20.09.2021, 08:36 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7162
Репутация: 1652 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИОШИБКА(ИНДЕКС($M:$O;ПОИСКПОЗ($B4;ИНДЕКС($L:$L;ПОИСКПОЗ(C$2;$J:$J;)):ИНДЕКС($L:$L;ЕСЛИОШИБКА(ПОИСКПОЗ(D$2;$J:$J;)-1;ПОИСКПОЗ("我";$L:$L)));)+ПОИСКПОЗ(C$2;$J:$J;)-1;4-СТРОКА(A1)/7);"")
К сообщению приложен файл: 0009551.xlsx(13.5 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ИНДЕКС($M:$O;ПОИСКПОЗ($B4;ИНДЕКС($L:$L;ПОИСКПОЗ(C$2;$J:$J;)):ИНДЕКС($L:$L;ЕСЛИОШИБКА(ПОИСКПОЗ(D$2;$J:$J;)-1;ПОИСКПОЗ("我";$L:$L)));)+ПОИСКПОЗ(C$2;$J:$J;)-1;4-СТРОКА(A1)/7);"")

Автор - Nic70y
Дата добавления - 20.09.2021 в 08:36
karasevslav Дата: Среда, 22.09.2021, 15:58 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Спасибо большое за помощь, я её немного видоизменил и самому такую формулу что-то не получается написать.
Добавил колонок в которых искать значения
 
Ответить
СообщениеСпасибо большое за помощь, я её немного видоизменил и самому такую формулу что-то не получается написать.
Добавил колонок в которых искать значения

Автор - karasevslav
Дата добавления - 22.09.2021 в 15:58
Nic70y Дата: Среда, 22.09.2021, 16:00 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 7162
Репутация: 1652 ±
Замечаний: 0% ±

Excel 2010
ну так покажите файл с
Добавил колонок в которых искать значения


ЮMoney 41001841029809
 
Ответить
Сообщениену так покажите файл с
Добавил колонок в которых искать значения

Автор - Nic70y
Дата добавления - 22.09.2021 в 16:00
karasevslav Дата: Среда, 22.09.2021, 19:50 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, Прикладываю нынешний файл.
Все данные по годам вводим на лист "данные" затем отдельно на каждый лист хотим выводить по каждому направлению деятельности.
Отдельно лист для групп, интенсивов и так далее.
И соответсенно в данных есть 2020 год 2021 год из которого необходимо подгружать данные.
И вопрос внутри, возможно ли сделать так, чтобы можно было растянуть формулой интервал дат, а не писать везде руками.
К сообщению приложен файл: 7421780.xlsx(85.2 Kb)
 
Ответить
СообщениеNic70y, Прикладываю нынешний файл.
Все данные по годам вводим на лист "данные" затем отдельно на каждый лист хотим выводить по каждому направлению деятельности.
Отдельно лист для групп, интенсивов и так далее.
И соответсенно в данных есть 2020 год 2021 год из которого необходимо подгружать данные.
И вопрос внутри, возможно ли сделать так, чтобы можно было растянуть формулой интервал дат, а не писать везде руками.

Автор - karasevslav
Дата добавления - 22.09.2021 в 19:50
Nic70y Дата: Четверг, 23.09.2021, 09:03 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 7162
Репутация: 1652 ±
Замечаний: 0% ±

Excel 2010
для упрощения формулы на лист Данные добавил строки
К сообщению приложен файл: 6714792.xlsx(89.9 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениедля упрощения формулы на лист Данные добавил строки

Автор - Nic70y
Дата добавления - 23.09.2021 в 09:03
karasevslav Дата: Четверг, 23.09.2021, 20:47 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Спасибо большое, все работает. Сам бы я такую формулу не написал :)
 
Ответить
СообщениеСпасибо большое, все работает. Сам бы я такую формулу не написал :)

Автор - karasevslav
Дата добавления - 23.09.2021 в 20:47
Nic70y Дата: Пятница, 24.09.2021, 08:03 | Сообщение № 8
Группа: Друзья
Ранг: Экселист
Сообщений: 7162
Репутация: 1652 ±
Замечаний: 0% ±

Excel 2010
все работает
на самом деле не все, не заметил "косяк" первой* недели - добавить строки не достаточно, нужно и ее имя перенести
К сообщению приложен файл: 3583845.xlsx(90.1 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
все работает
на самом деле не все, не заметил "косяк" первой* недели - добавить строки не достаточно, нужно и ее имя перенести

Автор - Nic70y
Дата добавления - 24.09.2021 в 08:03
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отображение данных из вертикальной таблицы в горизонтальную (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!