Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Отображение услуги в цифрах каждый первый понедельник месяца - Страница 3 - Мир MS Excel

Старая форма входа
  • Страница 3 из 3
  • «
  • 1
  • 2
  • 3
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отображение услуги в цифрах каждый первый понедельник месяца (Формулы/Formulas)
Отображение услуги в цифрах каждый первый понедельник месяца
Смольный Дата: Пятница, 05.11.2021, 04:21 | Сообщение № 41
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 20% ±

bigorq, без ноля никак не сделать? Проверил Вашу формулу сейчас, все что нужно она делает правильно, единственное, как бы без ноля обойтись.


Сообщение отредактировал Смольный - Пятница, 05.11.2021, 04:35
 
Ответить
Сообщениеbigorq, без ноля никак не сделать? Проверил Вашу формулу сейчас, все что нужно она делает правильно, единственное, как бы без ноля обойтись.

Автор - Смольный
Дата добавления - 05.11.2021 в 04:21
bigorq Дата: Пятница, 05.11.2021, 09:24 | Сообщение № 42
Группа: Пользователи
Ранг: Новичок
Сообщений: 31
Репутация: 12 ±
Замечаний: 0% ±

Пробуйте
Код
=ЕСЛИ(И(ЕОШ(ПОИСК(СЧЁТЕСЛИ($E$3:E$3;E$3)&" "&E$3;$A5));(ЕОШ(ПОИСК(", "&E$3;", "&$A5))));"";ЕСЛИ(ВПР(9E+307;$D$4:$D4;1)*(ВПР(9E+307;$D$4:E4;СТОЛБЕЦ()-3)<>"");$C5*$AL5&"";$C5*$AL5))

Дни недели без цифр, должны стоять через пробел после разделительной запятой. Например пн, Вт, 2 ср
Пишу с телефона, работу формулы не проверял
 
Ответить
СообщениеПробуйте
Код
=ЕСЛИ(И(ЕОШ(ПОИСК(СЧЁТЕСЛИ($E$3:E$3;E$3)&" "&E$3;$A5));(ЕОШ(ПОИСК(", "&E$3;", "&$A5))));"";ЕСЛИ(ВПР(9E+307;$D$4:$D4;1)*(ВПР(9E+307;$D$4:E4;СТОЛБЕЦ()-3)<>"");$C5*$AL5&"";$C5*$AL5))

Дни недели без цифр, должны стоять через пробел после разделительной запятой. Например пн, Вт, 2 ср
Пишу с телефона, работу формулы не проверял

Автор - bigorq
Дата добавления - 05.11.2021 в 09:24
Смольный Дата: Пятница, 05.11.2021, 09:36 | Сообщение № 43
Группа: Пользователи
Ранг: Участник
Сообщений: 64
Репутация: 0 ±
Замечаний: 20% ±

bigorq, проверил, работает как надо. Спасибо Вам.
 
Ответить
Сообщениеbigorq, проверил, работает как надо. Спасибо Вам.

Автор - Смольный
Дата добавления - 05.11.2021 в 09:36
Светлый Дата: Понедельник, 15.11.2021, 12:32 | Сообщение № 44
Группа: Друзья
Ранг: Старожил
Сообщений: 1738
Репутация: 473 ±
Замечаний: 0% ±

Excel 2013, 2016
Перед днём недели можно до четырёх цифр вставлять. Если цифр нет, то все дни недели.
Формула в E8:
Код
=ЕСЛИ(ЕОШ(ПОИСК(E$3;$A8))+((СЧЁТ(-ПСТР($A8;ПОИСК(E$3;$A8)-{2;3;4;5};1))>0)*(СЧЁТ(1/(--ПСТР($A8;ПОИСК(E$3;$A8)-{2;3;4;5};1)=СЧЁТЕСЛИ($E$3:E$3;E$3)))=0));"";ЕСЛИ(ВПР(9E+307;$D$4:$D7;1)*(ВПР(9E+307;$D$4:E7;СТОЛБЕЦ()-3)<>"");$C8*$AL8&"";$C8*$AL8))
и копировать.


Программировать проще, чем писать стихи.
 
Ответить
СообщениеПеред днём недели можно до четырёх цифр вставлять. Если цифр нет, то все дни недели.
Формула в E8:
Код
=ЕСЛИ(ЕОШ(ПОИСК(E$3;$A8))+((СЧЁТ(-ПСТР($A8;ПОИСК(E$3;$A8)-{2;3;4;5};1))>0)*(СЧЁТ(1/(--ПСТР($A8;ПОИСК(E$3;$A8)-{2;3;4;5};1)=СЧЁТЕСЛИ($E$3:E$3;E$3)))=0));"";ЕСЛИ(ВПР(9E+307;$D$4:$D7;1)*(ВПР(9E+307;$D$4:E7;СТОЛБЕЦ()-3)<>"");$C8*$AL8&"";$C8*$AL8))
и копировать.

Автор - Светлый
Дата добавления - 15.11.2021 в 12:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Отображение услуги в цифрах каждый первый понедельник месяца (Формулы/Formulas)
  • Страница 3 из 3
  • «
  • 1
  • 2
  • 3
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!