Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Сцепить данные из нескольких ячеек строки, по условию - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сцепить данные из нескольких ячеек строки, по условию (Формулы/Formulas)
Сцепить данные из нескольких ячеек строки, по условию
plex4657 Дата: Понедельник, 11.10.2021, 14:51 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Добрый день!
Имеется две таблицы, в первую нужно внести данные со второй по условию.
В ячейке А2 есть значение, нужно найти это значение во второй таблице и в ячейку В2 внести все данные по строке со второй таблицы.
К сообщению приложен файл: 7599244.xlsx(11.2 Kb)


Сообщение отредактировал plex4657 - Понедельник, 11.10.2021, 14:56
 
Ответить
СообщениеДобрый день!
Имеется две таблицы, в первую нужно внести данные со второй по условию.
В ячейке А2 есть значение, нужно найти это значение во второй таблице и в ячейку В2 внести все данные по строке со второй таблицы.

Автор - plex4657
Дата добавления - 11.10.2021 в 14:51
Egyptian Дата: Понедельник, 11.10.2021, 15:22 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 183
Репутация: 58 ±
Замечаний: 0% ±

Excel 2013/2016
Вариант.
Код
=IFERROR(LOOKUP(2;1/($H$2:$H$17=A2);$F$2:$F$17&", "&$E$2:$E$17&", "&$G$2:$G$17&", "&$H$2:$H$17&", "&$I$2:$I$17&"x"&$J$2:$J$17&"x"&$K$2:$K$17);"")

Формула не рассчитана на повторяющиеся номера, если таковые есть.
Если будут, то другой вариант:
Код
=IFERROR(INDEX($F$2:$F$17&", "&$E$2:$E$17&", "&$G$2:$G$17&", "&$H$2:$H$17&", "&$I$2:$I$17&"x"&$J$2:$J$17&"x"&$K$2:$K$17;AGGREGATE(15;6;ROW($A$1:$A$100)/($H$2:$H$17=A2);COUNTIF($A$2:A2;A2)));"")
К сообщению приложен файл: 5133206.xlsx(11.7 Kb)


Сообщение отредактировал Egyptian - Понедельник, 11.10.2021, 16:03
 
Ответить
СообщениеВариант.
Код
=IFERROR(LOOKUP(2;1/($H$2:$H$17=A2);$F$2:$F$17&", "&$E$2:$E$17&", "&$G$2:$G$17&", "&$H$2:$H$17&", "&$I$2:$I$17&"x"&$J$2:$J$17&"x"&$K$2:$K$17);"")

Формула не рассчитана на повторяющиеся номера, если таковые есть.
Если будут, то другой вариант:
Код
=IFERROR(INDEX($F$2:$F$17&", "&$E$2:$E$17&", "&$G$2:$G$17&", "&$H$2:$H$17&", "&$I$2:$I$17&"x"&$J$2:$J$17&"x"&$K$2:$K$17;AGGREGATE(15;6;ROW($A$1:$A$100)/($H$2:$H$17=A2);COUNTIF($A$2:A2;A2)));"")

Автор - Egyptian
Дата добавления - 11.10.2021 в 15:22
plex4657 Дата: Понедельник, 11.10.2021, 17:47 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Egyptian, спасибо, подходит такой вариант, повторяющихся номеров не должно быть но бывает всякое.
 
Ответить
СообщениеEgyptian, спасибо, подходит такой вариант, повторяющихся номеров не должно быть но бывает всякое.

Автор - plex4657
Дата добавления - 11.10.2021 в 17:47
Serge_007 Дата: Понедельник, 11.10.2021, 17:58 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 14555
Репутация: 2403 ±
Замечаний: ±

Excel 2010
Вариант с допстолбцом (см. вложение):
Код
=ИНДЕКС(D$2:D$17;ПОИСКПОЗ(A2;H$2:H$17;))
К сообщению приложен файл: 20211011_plex46.xls(59.0 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеВариант с допстолбцом (см. вложение):
Код
=ИНДЕКС(D$2:D$17;ПОИСКПОЗ(A2;H$2:H$17;))

Автор - Serge_007
Дата добавления - 11.10.2021 в 17:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Сцепить данные из нескольких ячеек строки, по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!