Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Счет при сложных условиях - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Счет при сложных условиях (Формулы/Formulas)
Счет при сложных условиях
adwordsak Дата: Пятница, 15.10.2021, 08:46 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 20% ±

Всем привет. Буду благодарна, если кто-то подскажет по сложному условию:
Как посчитать количество клиентов которые покупали у двух выбранных поставщиков и больше 1 нового поставщика из не выбранных?
Файл для примера прикрепляю. По условию мне подходит только Вася -он покупал у двух основных и любого не основного
Заранее спасибо.
К сообщению приложен файл: __.xlsx(8.8 Kb)
 
Ответить
СообщениеВсем привет. Буду благодарна, если кто-то подскажет по сложному условию:
Как посчитать количество клиентов которые покупали у двух выбранных поставщиков и больше 1 нового поставщика из не выбранных?
Файл для примера прикрепляю. По условию мне подходит только Вася -он покупал у двух основных и любого не основного
Заранее спасибо.

Автор - adwordsak
Дата добавления - 15.10.2021 в 08:46
Pelena Дата: Пятница, 15.10.2021, 10:54 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18556
Репутация: 4203 ±
Замечаний: ±

Excel 2016 & Mac Excel
Почему Вова не подходит?


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеПочему Вова не подходит?

Автор - Pelena
Дата добавления - 15.10.2021 в 10:54
NikitaDvorets Дата: Пятница, 15.10.2021, 11:48 | Сообщение № 3
Группа: Проверенные
Ранг: Обитатель
Сообщений: 365
Репутация: 65 ±
Замечаний: 0% ±

Excel 2019
adwordsak, добрый день.
Цитата
мне подходит только Вася
- под вопросом...
Цитата
Почему Вова не подходит?

Вова также подходит, поскольку является клиентом двух основных и 3-х "вспомогательных" поставщиков.
Возможно, эта задача должна реализовываться сразу на реальных данных через UDF/макрос, поскольку потребует расчета дополнительных массивов.
 
Ответить
Сообщениеadwordsak, добрый день.
Цитата
мне подходит только Вася
- под вопросом...
Цитата
Почему Вова не подходит?

Вова также подходит, поскольку является клиентом двух основных и 3-х "вспомогательных" поставщиков.
Возможно, эта задача должна реализовываться сразу на реальных данных через UDF/макрос, поскольку потребует расчета дополнительных массивов.

Автор - NikitaDvorets
Дата добавления - 15.10.2021 в 11:48
Nic70y Дата: Пятница, 15.10.2021, 12:23 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 7735
Репутация: 1856 ±
Замечаний: 0% ±

Excel 2010
как-то так, формула массива:
Код
=ЕСЛИОШИБКА(ВПР(A2;A$1:D1;4;);(СУММ(--(СЧЁТЕСЛИМН(A$2:A$18;A2;B$2:B$18;H$2:H$3)>0))=ЧСТРОК(H$2:H$3))*СУММ(ЕСЛИОШИБКА((ПОИСКПОЗ(B$2:B$18;ЕСЛИ(ЕНД(ПОИСКПОЗ(B$2:B$18;H$2:H$3;));ЕСЛИ(A$2:A$18=A2;B$2:B$18));)=СТРОКА(B$2:B$18)-1)*(A$2:A$18=A2);)))
наверное
К сообщению приложен файл: 42.xlsx(9.7 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениекак-то так, формула массива:
Код
=ЕСЛИОШИБКА(ВПР(A2;A$1:D1;4;);(СУММ(--(СЧЁТЕСЛИМН(A$2:A$18;A2;B$2:B$18;H$2:H$3)>0))=ЧСТРОК(H$2:H$3))*СУММ(ЕСЛИОШИБКА((ПОИСКПОЗ(B$2:B$18;ЕСЛИ(ЕНД(ПОИСКПОЗ(B$2:B$18;H$2:H$3;));ЕСЛИ(A$2:A$18=A2;B$2:B$18));)=СТРОКА(B$2:B$18)-1)*(A$2:A$18=A2);)))
наверное

Автор - Nic70y
Дата добавления - 15.10.2021 в 12:23
adwordsak Дата: Пятница, 15.10.2021, 13:17 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 20% ±

Огонь!!! Очень круто. Спасибо!!!

Да, Вова видимо тоже подходит, просо во время создания таблицы была ориентировка на Васю) Но эксель все расставил по местам.


Сообщение отредактировал Serge_007 - Пятница, 15.10.2021, 13:33
 
Ответить
СообщениеОгонь!!! Очень круто. Спасибо!!!

Да, Вова видимо тоже подходит, просо во время создания таблицы была ориентировка на Васю) Но эксель все расставил по местам.

Автор - adwordsak
Дата добавления - 15.10.2021 в 13:17
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Счет при сложных условиях (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!