Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вычисление повторяющихся, гиперссылки с автофильтром - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычисление повторяющихся, гиперссылки с автофильтром (Формулы/Formulas)
Вычисление повторяющихся, гиперссылки с автофильтром
litikovse Дата: Пятница, 22.10.2021, 15:11 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 36
Репутация: 0 ±
Замечаний: 0% ±

Добрый день! Прошу помощи. В приложенном файле два листа, первый лист данных (столбец А по сути не нужен). В столбце В список значений, которые могут повторяться. Напротив каждого значения стоит либо Выполнено либо пустая ячейка либо какая то другая информация, которая приравнивается к пустой ячейке. В листе 2 столбец "А" уникальные значения из столбца "В" листа 1. В столбец "В" листа 2 нужна формула которая вставляла "выполнено", "частично" или "не выполнено", пример подписал. Посложнее, нужны гиперссылки в столбце "С" листа 2, к примеру нажать на ссылку напроти "красный" и оно переносило на лист 1 с уже отфильтрованным красным. Таблица очень большая поэтому такой мини вариант.
К сообщению приложен файл: 0171981.xlsx(10.3 Kb)
 
Ответить
СообщениеДобрый день! Прошу помощи. В приложенном файле два листа, первый лист данных (столбец А по сути не нужен). В столбце В список значений, которые могут повторяться. Напротив каждого значения стоит либо Выполнено либо пустая ячейка либо какая то другая информация, которая приравнивается к пустой ячейке. В листе 2 столбец "А" уникальные значения из столбца "В" листа 1. В столбец "В" листа 2 нужна формула которая вставляла "выполнено", "частично" или "не выполнено", пример подписал. Посложнее, нужны гиперссылки в столбце "С" листа 2, к примеру нажать на ссылку напроти "красный" и оно переносило на лист 1 с уже отфильтрованным красным. Таблица очень большая поэтому такой мини вариант.

Автор - litikovse
Дата добавления - 22.10.2021 в 15:11
Pelena Дата: Пятница, 22.10.2021, 17:18 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18117
Репутация: 4059 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Как вариант
Код
=ЕСЛИ(СЧЁТЕСЛИМН(Лист1!$B$2:$B$10;A2;Лист1!$C$2:$C$10;"ВЫПОЛНЕНО")=СЧЁТЕСЛИ(Лист1!$B$2:$B$10;A2);"ВЫПОЛНЕНО";ЕСЛИ(СЧЁТЕСЛИМН(Лист1!$B$2:$B$10;A2;Лист1!$C$2:$C$10;"ВЫПОЛНЕНО")=0;"НЕ ВЫПОЛНЕНО";"ЧАСТИЧНО"))


По второму вопросу: макросом можно, но это уже в другой теме и в разделе VBA
К сообщению приложен файл: 8901648.xlsx(11.0 Kb)


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Как вариант
Код
=ЕСЛИ(СЧЁТЕСЛИМН(Лист1!$B$2:$B$10;A2;Лист1!$C$2:$C$10;"ВЫПОЛНЕНО")=СЧЁТЕСЛИ(Лист1!$B$2:$B$10;A2);"ВЫПОЛНЕНО";ЕСЛИ(СЧЁТЕСЛИМН(Лист1!$B$2:$B$10;A2;Лист1!$C$2:$C$10;"ВЫПОЛНЕНО")=0;"НЕ ВЫПОЛНЕНО";"ЧАСТИЧНО"))


По второму вопросу: макросом можно, но это уже в другой теме и в разделе VBA

Автор - Pelena
Дата добавления - 22.10.2021 в 17:18
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычисление повторяющихся, гиперссылки с автофильтром (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!