Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос остатка на конец месяца на начало - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос остатка на конец месяца на начало (Формулы/Formulas)
Перенос остатка на конец месяца на начало
Shakal07 Дата: Понедельник, 08.11.2021, 16:10 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2k3;2k7;2k10;2k13;2k19
Здравствуйте
Есть документ в котором есть листы с номерами месяцев
Необходимо переносить остатки на конец одного месяца на начало другого
но это надо делать по четырем искомым значениям
Удалось сделать по одному значению, но иногда при открытии вылазят циклические ссылки
может быть формулу не очень правильно сделал, но как знал

Задача перенести остаток на конец месяца, на начало следующего
Искомые значения данные которые содержатся в столбцах "КЕКР" (Столбец C), "Дата" (Столбец D), "№ документа" (Столбец E), Наименование организации (Столбец F)
В январе остатки на начало вносятся вручную
Также есть проблема стем когда поставщика не было прошлый месяц для него отображается ошибка #Н/Д, такое недопустимо

Формулы должны для столбцов H, I выделены желтым и красным соответственно
И должны быть во всех месяцах кроме января

С уважением,
К сообщению приложен файл: 0338270.xlsx(138.4 Kb)


Сообщение отредактировал Shakal07 - Понедельник, 08.11.2021, 16:11
 
Ответить
СообщениеЗдравствуйте
Есть документ в котором есть листы с номерами месяцев
Необходимо переносить остатки на конец одного месяца на начало другого
но это надо делать по четырем искомым значениям
Удалось сделать по одному значению, но иногда при открытии вылазят циклические ссылки
может быть формулу не очень правильно сделал, но как знал

Задача перенести остаток на конец месяца, на начало следующего
Искомые значения данные которые содержатся в столбцах "КЕКР" (Столбец C), "Дата" (Столбец D), "№ документа" (Столбец E), Наименование организации (Столбец F)
В январе остатки на начало вносятся вручную
Также есть проблема стем когда поставщика не было прошлый месяц для него отображается ошибка #Н/Д, такое недопустимо

Формулы должны для столбцов H, I выделены желтым и красным соответственно
И должны быть во всех месяцах кроме января

С уважением,

Автор - Shakal07
Дата добавления - 08.11.2021 в 16:10
Nic70y Дата: Вторник, 09.11.2021, 08:57 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7162
Репутация: 1652 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИОШИБКА(ВПР($F17;ДВССЫЛ("'"&ПРАВБ(0&ПРАВБ(ЯЧЕЙКА("filename";AP11);2)-1;2)&"'!F:AO");34+СТОЛБЕЦ(A1););)


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Вторник, 09.11.2021, 08:58
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ВПР($F17;ДВССЫЛ("'"&ПРАВБ(0&ПРАВБ(ЯЧЕЙКА("filename";AP11);2)-1;2)&"'!F:AO");34+СТОЛБЕЦ(A1););)

Автор - Nic70y
Дата добавления - 09.11.2021 в 08:57
Shakal07 Дата: Вторник, 09.11.2021, 14:01 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 27
Репутация: 0 ±
Замечаний: 0% ±

Excel 2k3;2k7;2k10;2k13;2k19
Nic70y,

Спасибо за ответ.

Уточните пожалуйста, это универсальная формула и для столбца H, I

Та как у меня для столбца I формула выводит остаток как для столбца Н, а это не правильно
Для столбца Н остаток должен браться из столбца AN,
а для столбца I остаток должен браться из столбца AO

Спасибо
 
Ответить
СообщениеNic70y,

Спасибо за ответ.

Уточните пожалуйста, это универсальная формула и для столбца H, I

Та как у меня для столбца I формула выводит остаток как для столбца Н, а это не правильно
Для столбца Н остаток должен браться из столбца AN,
а для столбца I остаток должен браться из столбца AO

Спасибо

Автор - Shakal07
Дата добавления - 09.11.2021 в 14:01
Nic70y Дата: Вторник, 09.11.2021, 15:29 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 7162
Репутация: 1652 ±
Замечаний: 0% ±

Excel 2010
для столбца H, I
да
К сообщению приложен файл: 4530338.xlsx(148.3 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
для столбца H, I
да

Автор - Nic70y
Дата добавления - 09.11.2021 в 15:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос остатка на конец месяца на начало (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!