Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск вхождений в текстовую строку из диапазона текст зн - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск вхождений в текстовую строку из диапазона текст зн (Формулы/Formulas)
Поиск вхождений в текстовую строку из диапазона текст зн
ladchel16151 Дата: Среда, 17.11.2021, 09:38 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Добрый день!
Друзья, подскажите пожалуйста формулу определяющую входит ли любое текстовое значение из диапазона ячеек в текстовую строку в определённой ячейке. Например есть ячейка с текстом: столичный метрополитен.и есть диапазон ячеек: стол, метро, стул. Формула должна определить есть ли хотя-бы одно вхождение из диапазона.
 
Ответить
СообщениеДобрый день!
Друзья, подскажите пожалуйста формулу определяющую входит ли любое текстовое значение из диапазона ячеек в текстовую строку в определённой ячейке. Например есть ячейка с текстом: столичный метрополитен.и есть диапазон ячеек: стол, метро, стул. Формула должна определить есть ли хотя-бы одно вхождение из диапазона.

Автор - ladchel16151
Дата добавления - 17.11.2021 в 09:38
Pelena Дата: Среда, 17.11.2021, 10:29 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18117
Репутация: 4059 ±
Замечаний: ±

Excel 2016 & Mac Excel
ЕЧИСЛО(ПОИСК(...))
Подробнее при наличии файла с примером


"Черт возьми, Холмс! Но как??!!"
ЯД 41001765434816
 
Ответить
СообщениеЕЧИСЛО(ПОИСК(...))
Подробнее при наличии файла с примером

Автор - Pelena
Дата добавления - 17.11.2021 в 10:29
Serge_007 Дата: Среда, 17.11.2021, 10:37 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 14697
Репутация: 2432 ±
Замечаний: ±

Excel 2010
Формула должна определить есть ли хотя-бы одно вхождение из диапазона
ЕЧИСЛО(ПОИСК(...))
Для разнообразия:
Код
=МИН(ЕОШ(НАЙТИ(D1:D3;A1))-1)<0
К сообщению приложен файл: 20211117_ladche.xls(55.5 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Формула должна определить есть ли хотя-бы одно вхождение из диапазона
ЕЧИСЛО(ПОИСК(...))
Для разнообразия:
Код
=МИН(ЕОШ(НАЙТИ(D1:D3;A1))-1)<0

Автор - Serge_007
Дата добавления - 17.11.2021 в 10:37
ladchel16151 Дата: Среда, 17.11.2021, 10:55 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 10
Репутация: 0 ±
Замечаний: 0% ±

Спасибо огромное! Как все просто оказывается!
 
Ответить
СообщениеСпасибо огромное! Как все просто оказывается!

Автор - ladchel16151
Дата добавления - 17.11.2021 в 10:55
китин Дата: Среда, 17.11.2021, 11:13 | Сообщение № 5
Группа: Модераторы
Ранг: Экселист
Сообщений: 6611
Репутация: 1004 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
усложнять дык усложнять %) :'(
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ($C1;ПСТР($A$1;СТРОКА(ДВССЫЛ("1:"&ДЛСТР($A$1)));ДЛСТР($C1));0));"Есть такое слово на "&ПОИСКПОЗ($C1;ПСТР($A$1;СТРОКА(ДВССЫЛ("1:"&ДЛСТР($A$1)));ДЛСТР($C1));0)&" позиции";"Нет такого слова")
К сообщению приложен файл: ladchel16151.xlsx(8.8 Kb)


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениеусложнять дык усложнять %) :'(
Формула массива. Вводится одновременным нажатием Ctrl+Shift+Enter
Код
=ЕСЛИ(ЕЧИСЛО(ПОИСКПОЗ($C1;ПСТР($A$1;СТРОКА(ДВССЫЛ("1:"&ДЛСТР($A$1)));ДЛСТР($C1));0));"Есть такое слово на "&ПОИСКПОЗ($C1;ПСТР($A$1;СТРОКА(ДВССЫЛ("1:"&ДЛСТР($A$1)));ДЛСТР($C1));0)&" позиции";"Нет такого слова")

Автор - китин
Дата добавления - 17.11.2021 в 11:13
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск вхождений в текстовую строку из диапазона текст зн (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!