Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Множественный поиск с использованием формул массива - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Множественный поиск с использованием формул массива (Формулы/Formulas)
Множественный поиск с использованием формул массива
shevilmay Дата: Пятница, 19.11.2021, 12:20 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 6
Репутация: 0 ±
Замечаний: 0% ±

День добрый!

Необходимо для столбца «Месяц ввода в эксплуатацию» из таблицы Source_Amortization вставить значения c привязкой к Версиям и ЦФО. (Версия и ЦФО - выпадающие списки). Все вроде работает с формулой:

Код
=ИНДЕКС(Source_Amortization!$G$2:$G$145;АГРЕГАТ(15;6;(СТРОКА($F$2:$F$145)-СТРОКА($F$2)+1)/((Source_Amortization!$B$2:$B$145=$C$4)/(Source_Amortization!$C$2:$C$145=$C$5)/(Source_Amortization!$D$2:$D$145=$C10)/(Source_Amortization!$E$2:$E$145=$D10)/(Source_Amortization!$F$2:$F$145=$E10));1))


Однако, формулу необходимо переделать, чтобы использовались формула массива и комбинация функций ИНДЕКС и ПОИСКПОЗ. Подскажите пожалуйста, как это можно реализовать?
К сообщению приложен файл: 4836156.xlsm(36.4 Kb)
 
Ответить
СообщениеДень добрый!

Необходимо для столбца «Месяц ввода в эксплуатацию» из таблицы Source_Amortization вставить значения c привязкой к Версиям и ЦФО. (Версия и ЦФО - выпадающие списки). Все вроде работает с формулой:

Код
=ИНДЕКС(Source_Amortization!$G$2:$G$145;АГРЕГАТ(15;6;(СТРОКА($F$2:$F$145)-СТРОКА($F$2)+1)/((Source_Amortization!$B$2:$B$145=$C$4)/(Source_Amortization!$C$2:$C$145=$C$5)/(Source_Amortization!$D$2:$D$145=$C10)/(Source_Amortization!$E$2:$E$145=$D10)/(Source_Amortization!$F$2:$F$145=$E10));1))


Однако, формулу необходимо переделать, чтобы использовались формула массива и комбинация функций ИНДЕКС и ПОИСКПОЗ. Подскажите пожалуйста, как это можно реализовать?

Автор - shevilmay
Дата добавления - 19.11.2021 в 12:20
bmv98rus Дата: Пятница, 19.11.2021, 13:02 | Сообщение № 2
Группа: Друзья
Ранг: Участник клуба
Сообщений: 3688
Репутация: 651 ±
Замечаний: 0% ±

Excel 2013/2016
Где еще кроме как тут?


Замечательный Временно просто медведь , процентов на 20.
 
Ответить
СообщениеГде еще кроме как тут?

Автор - bmv98rus
Дата добавления - 19.11.2021 в 13:02
bigor Дата: Пятница, 19.11.2021, 13:07 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 545
Репутация: 107 ±
Замечаний: 0% ±

нет
Добрый

[offtop]Такой старый офис, что нет агрегат() :([/offtop]
Массивная, просто перевод без вникания, что где делается
Код
=INDEX(Source_Amortization.$G$2:$G$145;SMALL(IF((Source_Amortization.$B$2:$B$145=$C$4)*(Source_Amortization.$C$2:$C$145=$C$5)*(Source_Amortization.$D$2:$D$145=$C10)*(Source_Amortization.$E$2:$E$145=$D10)*(Source_Amortization.$F$2:$F$145=$E10);ROW($F$2:$F$145)-1;"");1))



ps не соответствует ТЗ по наличию ПОИСКПОЗ()
К сообщению приложен файл: 4836156_1.xlsm(27.2 Kb)


Сообщение отредактировал bigor - Пятница, 19.11.2021, 13:09
 
Ответить
СообщениеДобрый

[offtop]Такой старый офис, что нет агрегат() :([/offtop]
Массивная, просто перевод без вникания, что где делается
Код
=INDEX(Source_Amortization.$G$2:$G$145;SMALL(IF((Source_Amortization.$B$2:$B$145=$C$4)*(Source_Amortization.$C$2:$C$145=$C$5)*(Source_Amortization.$D$2:$D$145=$C10)*(Source_Amortization.$E$2:$E$145=$D10)*(Source_Amortization.$F$2:$F$145=$E10);ROW($F$2:$F$145)-1;"");1))



ps не соответствует ТЗ по наличию ПОИСКПОЗ()

Автор - bigor
Дата добавления - 19.11.2021 в 13:07
Egyptian Дата: Пятница, 19.11.2021, 13:45 | Сообщение № 4
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 202
Репутация: 68 ±
Замечаний: 0% ±

Excel 2013/2016
Ну вот вам исключительно с ИНДЕКС и ПОИСКПОЗ, хотя в другой теме Светлый выложил отличное решение, не понимаю, чем не устраивает.
Код
=INDEX(Source_Amortization!$G$2:$G$145;MATCH(1;(Source_Amortization!$B$2:$B$145=$C$4)*(Source_Amortization!$C$2:$C$145=$C$5)*(Source_Amortization!$D$2:$D$145=$C10)*(Source_Amortization!$E$2:$E$145=$D10)*(Source_Amortization!$F$2:$F$145=$E10);))
К сообщению приложен файл: 4682311.xlsm(31.4 Kb)


Сообщение отредактировал Egyptian - Пятница, 19.11.2021, 14:21
 
Ответить
СообщениеНу вот вам исключительно с ИНДЕКС и ПОИСКПОЗ, хотя в другой теме Светлый выложил отличное решение, не понимаю, чем не устраивает.
Код
=INDEX(Source_Amortization!$G$2:$G$145;MATCH(1;(Source_Amortization!$B$2:$B$145=$C$4)*(Source_Amortization!$C$2:$C$145=$C$5)*(Source_Amortization!$D$2:$D$145=$C10)*(Source_Amortization!$E$2:$E$145=$D10)*(Source_Amortization!$F$2:$F$145=$E10);))

Автор - Egyptian
Дата добавления - 19.11.2021 в 13:45
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Множественный поиск с использованием формул массива (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!