Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/начать с пустой ячейки, затем 8 повторений - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » начать с пустой ячейки, затем 8 повторений (Формулы/Formulas)
начать с пустой ячейки, затем 8 повторений
runa09 Дата: Вторник, 23.11.2021, 15:18 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Доброго дня Мастерам мира Excel )

подскажите пожалуйста, как решить задачу?

Есть один столбец с данными
1
2
3
4
итд

нужен второй столбец с таким результатом:
пусто
1
1
1
1
1
1
1
1
пусто
2
2
2
2
2
2
2
2
2
пусто
итд

т.е. начать с пустой ячейки, затем 8 повторений, потом пустая ячейка и снова 8 повторений и т.д

Спасибо!
 
Ответить
СообщениеДоброго дня Мастерам мира Excel )

подскажите пожалуйста, как решить задачу?

Есть один столбец с данными
1
2
3
4
итд

нужен второй столбец с таким результатом:
пусто
1
1
1
1
1
1
1
1
пусто
2
2
2
2
2
2
2
2
2
пусто
итд

т.е. начать с пустой ячейки, затем 8 повторений, потом пустая ячейка и снова 8 повторений и т.д

Спасибо!

Автор - runa09
Дата добавления - 23.11.2021 в 15:18
китин Дата: Вторник, 23.11.2021, 15:38 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6621
Репутация: 1005 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
Код
=ЕСЛИ(ОСТАТ(((СТРОКА(A1)-1)/9)+1;1)=0;"";ИНДЕКС($G$1:$G$11;((СТРОКА(A1)-1)/9)+1))

исходный столбец с данными находится в G1:G11


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщение
Код
=ЕСЛИ(ОСТАТ(((СТРОКА(A1)-1)/9)+1;1)=0;"";ИНДЕКС($G$1:$G$11;((СТРОКА(A1)-1)/9)+1))

исходный столбец с данными находится в G1:G11

Автор - китин
Дата добавления - 23.11.2021 в 15:38
Serge_007 Дата: Вторник, 23.11.2021, 15:38 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 14711
Репутация: 2434 ±
Замечаний: ±

Excel 2010
Здравствуйте

Как вариант:
Код
=ИНДЕКС(A$1:A$4;(ОТБР(СТРОКА()/9)<>СТРОКА()/9)*(1+ЦЕЛОЕ(СТРОКА()/9)))
К сообщению приложен файл: 2021123_runa09.xls(69.0 Kb)


Яндекс-деньги:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Как вариант:
Код
=ИНДЕКС(A$1:A$4;(ОТБР(СТРОКА()/9)<>СТРОКА()/9)*(1+ЦЕЛОЕ(СТРОКА()/9)))

Автор - Serge_007
Дата добавления - 23.11.2021 в 15:38
прохожий2019 Дата: Вторник, 23.11.2021, 16:41 | Сообщение № 4
Группа: Проверенные
Ранг: Ветеран
Сообщений: 723
Репутация: 180 ±
Замечаний: 0% ±

365 Beta Channel
Код
=MAKEARRAY(СЧЁТ(A1:A4)*9;1;LAMBDA(r;c;ЕСЛИ(ОСТАТ(r;9)-1;ИНДЕКС(A1:A4;ОКРВВЕРХ(r/9;1));"")))

[admin]Продублировала формулу в других тегах для более корректного отображения некоторых функций[/admin]
[vba]
Код
=MAKEARRAY(СЧЁТ(A1:A4)*9;1;LAMBDA(r;c;ЕСЛИ(ОСТАТ(r;9)-1;ИНДЕКС(A1:A4;ОКРВВЕРХ(r/9;1));"")))
[/vba]


Сообщение отредактировал Pelena - Четверг, 25.11.2021, 13:32
 
Ответить
Сообщение
Код
=MAKEARRAY(СЧЁТ(A1:A4)*9;1;LAMBDA(r;c;ЕСЛИ(ОСТАТ(r;9)-1;ИНДЕКС(A1:A4;ОКРВВЕРХ(r/9;1));"")))

[admin]Продублировала формулу в других тегах для более корректного отображения некоторых функций[/admin]
[vba]
Код
=MAKEARRAY(СЧЁТ(A1:A4)*9;1;LAMBDA(r;c;ЕСЛИ(ОСТАТ(r;9)-1;ИНДЕКС(A1:A4;ОКРВВЕРХ(r/9;1));"")))
[/vba]

Автор - прохожий2019
Дата добавления - 23.11.2021 в 16:41
runa09 Дата: Вторник, 23.11.2021, 19:25 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 8
Репутация: 0 ±
Замечаний: 0% ±

Супер! спасибо )
 
Ответить
СообщениеСупер! спасибо )

Автор - runa09
Дата добавления - 23.11.2021 в 19:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » начать с пустой ячейки, затем 8 повторений (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!