Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Кратное распределение при изменении ячейки - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Кратное распределение при изменении ячейки (Формулы/Formulas)
Кратное распределение при изменении ячейки
amromanenko Дата: Вторник, 23.11.2021, 18:46 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Доброго вечера

Помогите пожалуйста решить следующую задачу (на основе примера):

Есть некие значения в столбце В, высчитанные различными способами из других таблиц. В столбец С я ввожу новое значение, которое считаю более "правильным", чем высчитанное, в результате в столбец D выводится это значение, а остальные должны кратно пересчитаться чтобы в итоге сумма в столбцах B и D была одинаковая. Изменяться могут несколько значений, при этом нужно соблюсти следующее правило: на значение, которое проставлено в столбце С и перенесено в столбец D, "перераспределение" не действует. Нашел более-менее похожую тему, но там значения необходимо править внутри диапазона, а мне бы этого не хотелось и при исправлении нового значения перераспределение затрагивает весь диапазон, в том числе исправленный ранее.

Есть хоть малейшая возможность получить требуемый результат? Пересчитывать все исходные данные в ручную придется до конца света.
К сообщению приложен файл: 9789444.xlsx(8.6 Kb)


Сообщение отредактировал amromanenko - Вторник, 23.11.2021, 19:29
 
Ответить
СообщениеДоброго вечера

Помогите пожалуйста решить следующую задачу (на основе примера):

Есть некие значения в столбце В, высчитанные различными способами из других таблиц. В столбец С я ввожу новое значение, которое считаю более "правильным", чем высчитанное, в результате в столбец D выводится это значение, а остальные должны кратно пересчитаться чтобы в итоге сумма в столбцах B и D была одинаковая. Изменяться могут несколько значений, при этом нужно соблюсти следующее правило: на значение, которое проставлено в столбце С и перенесено в столбец D, "перераспределение" не действует. Нашел более-менее похожую тему, но там значения необходимо править внутри диапазона, а мне бы этого не хотелось и при исправлении нового значения перераспределение затрагивает весь диапазон, в том числе исправленный ранее.

Есть хоть малейшая возможность получить требуемый результат? Пересчитывать все исходные данные в ручную придется до конца света.

Автор - amromanenko
Дата добавления - 23.11.2021 в 18:46
Nic70y Дата: Среда, 24.11.2021, 09:10 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7158
Репутация: 1652 ±
Замечаний: 0% ±

Excel 2010
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(9E+307;C$1:C3));СУММ(B$3:B$18000)-СУММ(D4:D$18000);ЕСЛИ(C3;C3;ОКРУГЛ(B3*(СУММ(B$3:B$18000)-СУММ(C$3:C$18000))/СУММЕСЛИ(C$3:C$18000;"";B$3:B$18000);)))
К сообщению приложен файл: 7147598.xlsx(10.2 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
Код
=ЕСЛИ(ЕНД(ПОИСКПОЗ(9E+307;C$1:C3));СУММ(B$3:B$18000)-СУММ(D4:D$18000);ЕСЛИ(C3;C3;ОКРУГЛ(B3*(СУММ(B$3:B$18000)-СУММ(C$3:C$18000))/СУММЕСЛИ(C$3:C$18000;"";B$3:B$18000);)))

Автор - Nic70y
Дата добавления - 24.11.2021 в 09:10
amromanenko Дата: Среда, 24.11.2021, 18:48 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Воу, спасибо! До такой дикой формулы я бы не в жизнь не дошел :-)
 
Ответить
СообщениеВоу, спасибо! До такой дикой формулы я бы не в жизнь не дошел :-)

Автор - amromanenko
Дата добавления - 24.11.2021 в 18:48
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Кратное распределение при изменении ячейки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2021 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!