Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Повторяющиеся значения в столбце - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Повторяющиеся значения в столбце (Формулы/Formulas)
Повторяющиеся значения в столбце
rrrwww Дата: Пятница, 26.11.2021, 10:48 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

2013
Добрый день!
Дана таблица с данными. Чуть ниже рейтинг парков с наихудшими показателями по убыванию "ТОП5" (от самого худшего, столбец C -> ищет по cтолбецу L). Все прописал чтоб находило данные, в столбец B прописал чтоб находило парки согласно данным столбца С, теперь вопрос! Если в столбце C одинаковые показатели 81 и 81 (выделил красным) то и парки он пишет одинаковые, но нюанс парки разные, а показатели одинаковые. Как прописать условие в
Код
=ИНДЕКС($B$5:$L$29;ПОИСКПОЗ($C34;$L$5:$L$29;0);1)

чтоб если показатели одинаковые искало и разные парки %)
Уже все перепробовал :facepalm:
Спасибо.
К сообщению приложен файл: 3679933.xlsx(16.9 Kb)
 
Ответить
СообщениеДобрый день!
Дана таблица с данными. Чуть ниже рейтинг парков с наихудшими показателями по убыванию "ТОП5" (от самого худшего, столбец C -> ищет по cтолбецу L). Все прописал чтоб находило данные, в столбец B прописал чтоб находило парки согласно данным столбца С, теперь вопрос! Если в столбце C одинаковые показатели 81 и 81 (выделил красным) то и парки он пишет одинаковые, но нюанс парки разные, а показатели одинаковые. Как прописать условие в
Код
=ИНДЕКС($B$5:$L$29;ПОИСКПОЗ($C34;$L$5:$L$29;0);1)

чтоб если показатели одинаковые искало и разные парки %)
Уже все перепробовал :facepalm:
Спасибо.

Автор - rrrwww
Дата добавления - 26.11.2021 в 10:48
Nic70y Дата: Пятница, 26.11.2021, 10:55 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7731
Репутация: 1856 ±
Замечаний: 0% ±

Excel 2010
Код
=ИНДЕКС(B$5:B$29;ЕСЛИ(C34=C33;ПОИСКПОЗ(C34;ИНДЕКС(L$5:L$29;ПОИСКПОЗ(C33;L$5:L$29;)+1):L$29;)+ПОИСКПОЗ(C33;L$5:L$29;);ПОИСКПОЗ(C34;L$5:L$29;)))
неправильно, шас переделаю


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Пятница, 26.11.2021, 11:01
 
Ответить
Сообщение
Код
=ИНДЕКС(B$5:B$29;ЕСЛИ(C34=C33;ПОИСКПОЗ(C34;ИНДЕКС(L$5:L$29;ПОИСКПОЗ(C33;L$5:L$29;)+1):L$29;)+ПОИСКПОЗ(C33;L$5:L$29;);ПОИСКПОЗ(C34;L$5:L$29;)))
неправильно, шас переделаю

Автор - Nic70y
Дата добавления - 26.11.2021 в 10:55
rrrwww Дата: Пятница, 26.11.2021, 11:02 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

2013
Спасибо большое! respect
Хотя у меня работает) если есть более оптимизированный вариант pray
Спасибо еще раз)


Сообщение отредактировал rrrwww - Пятница, 26.11.2021, 11:04
 
Ответить
СообщениеСпасибо большое! respect
Хотя у меня работает) если есть более оптимизированный вариант pray
Спасибо еще раз)

Автор - rrrwww
Дата добавления - 26.11.2021 в 11:02
Serge_007 Дата: Пятница, 26.11.2021, 11:03 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 15415
Репутация: 2537 ±
Замечаний: ±

Excel 2016
rrrwww, здравствуйте

Формула массива:
Код
=ИНДЕКС(B$5:B$29;НАИМЕНЬШИЙ(ЕСЛИ(L$5:L$29=C34;СТРОКА($1:$25));СЧЁТЕСЛИ(C$34:C34;C34)))
К сообщению приложен файл: 2021126_rrrwww.xls(81.0 Kb)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщениеrrrwww, здравствуйте

Формула массива:
Код
=ИНДЕКС(B$5:B$29;НАИМЕНЬШИЙ(ЕСЛИ(L$5:L$29=C34;СТРОКА($1:$25));СЧЁТЕСЛИ(C$34:C34;C34)))

Автор - Serge_007
Дата добавления - 26.11.2021 в 11:03
Nic70y Дата: Пятница, 26.11.2021, 11:11 | Сообщение № 5
Группа: Друзья
Ранг: Экселист
Сообщений: 7731
Репутация: 1856 ±
Замечаний: 0% ±

Excel 2010
Хотя у меня работает
для 2-х да,
но если больше нет.
теперь правильно
Код
=ИНДЕКС(B$5:B$29;ЕСЛИ(C34=C33;ПОИСКПОЗ(C34;ИНДЕКС(L$5:L$29;ПОИСКПОЗ(B33;B$5:B$29;)+1):L27;)+ПОИСКПОЗ(B33;B$5:B$29;);ПОИСКПОЗ(C34;L$5:L$29;)))
К сообщению приложен файл: 15.xlsx(17.5 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщение
Хотя у меня работает
для 2-х да,
но если больше нет.
теперь правильно
Код
=ИНДЕКС(B$5:B$29;ЕСЛИ(C34=C33;ПОИСКПОЗ(C34;ИНДЕКС(L$5:L$29;ПОИСКПОЗ(B33;B$5:B$29;)+1):L27;)+ПОИСКПОЗ(B33;B$5:B$29;);ПОИСКПОЗ(C34;L$5:L$29;)))

Автор - Nic70y
Дата добавления - 26.11.2021 в 11:11
rrrwww Дата: Пятница, 26.11.2021, 13:32 | Сообщение № 6
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

2013
Спасибо ВСЕМ за оперативное решение проблемы! booze
 
Ответить
СообщениеСпасибо ВСЕМ за оперативное решение проблемы! booze

Автор - rrrwww
Дата добавления - 26.11.2021 в 13:32
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Повторяющиеся значения в столбце (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!