Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Формула копирования ячейки при совпадении из другой - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула копирования ячейки при совпадении из другой (Формулы/Formulas)
Формула копирования ячейки при совпадении из другой
hoffmanzor Дата: Суббота, 27.11.2021, 09:50 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Добрый день! Нужно исходя из столбца B, при совпадении, подставить значения в пустые ячейки столбца С.


И применить формулу ко всем остальным пустым ячейка в таблице столбца С.
Всю голову сломал, и перерыл соответствующие темы.
К сообщению приложен файл: 4146996.xlsx(90.3 Kb)


Сообщение отредактировал hoffmanzor - Суббота, 27.11.2021, 10:00
 
Ответить
СообщениеДобрый день! Нужно исходя из столбца B, при совпадении, подставить значения в пустые ячейки столбца С.


И применить формулу ко всем остальным пустым ячейка в таблице столбца С.
Всю голову сломал, и перерыл соответствующие темы.

Автор - hoffmanzor
Дата добавления - 27.11.2021 в 09:50
and_evg Дата: Суббота, 27.11.2021, 10:26 | Сообщение № 2
Группа: Проверенные
Ранг: Обитатель
Сообщений: 409
Репутация: 71 ±
Замечаний: 0% ±

Excel 2007
Добрый день.
отфильтровать по пустым ячейкам и в них:
Код
=ЕСЛИ(B103=B104;C103)
К сообщению приложен файл: 0518720.xlsx(96.3 Kb)
 
Ответить
СообщениеДобрый день.
отфильтровать по пустым ячейкам и в них:
Код
=ЕСЛИ(B103=B104;C103)

Автор - and_evg
Дата добавления - 27.11.2021 в 10:26
DrMini Дата: Суббота, 27.11.2021, 10:59 | Сообщение № 3
Группа: Проверенные
Ранг: Ветеран
Сообщений: 835
Репутация: 47 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
Здравствуйте hoffmanzor,
До кучи:
Код
=ЕСЛИ(И(B101=B102);C101;"")
 
Ответить
СообщениеЗдравствуйте hoffmanzor,
До кучи:
Код
=ЕСЛИ(И(B101=B102);C101;"")

Автор - DrMini
Дата добавления - 27.11.2021 в 10:59
Pelena Дата: Суббота, 27.11.2021, 11:19 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 18555
Репутация: 4202 ±
Замечаний: ±

Excel 2016 & Mac Excel
Ещё вариант:
выделить столбец С -- Ctrl+g -- Выделить -- Пустые ячейки -- ОК
не снимая пометки, на клавиатуре нажать = и стрелку вверх -- Ctrl+Enter
затем при необходимости копировать/вставить как значения
видео


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЕщё вариант:
выделить столбец С -- Ctrl+g -- Выделить -- Пустые ячейки -- ОК
не снимая пометки, на клавиатуре нажать = и стрелку вверх -- Ctrl+Enter
затем при необходимости копировать/вставить как значения
видео

Автор - Pelena
Дата добавления - 27.11.2021 в 11:19
hoffmanzor Дата: Суббота, 27.11.2021, 13:33 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Не получается :(
 
Ответить
СообщениеНе получается :(

Автор - hoffmanzor
Дата добавления - 27.11.2021 в 13:33
DrMini Дата: Суббота, 27.11.2021, 14:06 | Сообщение № 6
Группа: Проверенные
Ранг: Ветеран
Сообщений: 835
Репутация: 47 ±
Замечаний: 0% ±

Excel LTSC 2021 RUS
Не получается

Может так понятнее будет?
К сообщению приложен файл: 8868125.gif(452.1 Kb)
 
Ответить
Сообщение
Не получается

Может так понятнее будет?

Автор - DrMini
Дата добавления - 27.11.2021 в 14:06
hoffmanzor Дата: Понедельник, 29.11.2021, 09:22 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

DrMini, Спасибо, получилось. А можно сделать так же, только ссылаясь на столбец? Чтобы искал совпадение по всему столбцу, и копировал значение из соседней ячейки, там где не пустая ячейка


Сообщение отредактировал hoffmanzor - Понедельник, 29.11.2021, 09:23
 
Ответить
СообщениеDrMini, Спасибо, получилось. А можно сделать так же, только ссылаясь на столбец? Чтобы искал совпадение по всему столбцу, и копировал значение из соседней ячейки, там где не пустая ячейка

Автор - hoffmanzor
Дата добавления - 29.11.2021 в 09:22
hoffmanzor Дата: Понедельник, 29.11.2021, 09:51 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±



Чтобы из столбца Е искал повторяющиеся значения из столбца В, и копировал название из соседней ячейки А в ячейку F
К сообщению приложен файл: 9909472.xlsx(51.2 Kb)


Сообщение отредактировал hoffmanzor - Понедельник, 29.11.2021, 09:53
 
Ответить
Сообщение

Чтобы из столбца Е искал повторяющиеся значения из столбца В, и копировал название из соседней ячейки А в ячейку F

Автор - hoffmanzor
Дата добавления - 29.11.2021 в 09:51
китин Дата: Понедельник, 29.11.2021, 10:09 | Сообщение № 9
Группа: Модераторы
Ранг: Экселист
Сообщений: 6895
Репутация: 1056 ±
Замечаний: 0% ±

Excel 2007;2010;2016
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$1959;ПОИСКПОЗ(E2;$B$2:$B$1959;0));"Нет данных")
К сообщению приложен файл: 0161612.xlsx(65.5 Kb)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщение
Код
=ЕСЛИОШИБКА(ИНДЕКС($A$2:$A$1959;ПОИСКПОЗ(E2;$B$2:$B$1959;0));"Нет данных")

Автор - китин
Дата добавления - 29.11.2021 в 10:09
hoffmanzor Дата: Среда, 01.12.2021, 09:07 | Сообщение № 10
Группа: Пользователи
Ранг: Новичок
Сообщений: 14
Репутация: 0 ±
Замечаний: 0% ±

Всем большое спасибо, вы очень помогли)
 
Ответить
СообщениеВсем большое спасибо, вы очень помогли)

Автор - hoffmanzor
Дата добавления - 01.12.2021 в 09:07
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Формула копирования ячейки при совпадении из другой (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!