Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Вычисления дат и времени по условию - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычисления дат и времени по условию (Формулы/Formulas)
Вычисления дат и времени по условию
striffe Дата: Четверг, 02.12.2021, 23:07 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Добрый день, помогите понять ошибку в формулах, ничего похожего не нашел.
что бы была полная картина:
Задача: необходимо автоматически вычислять тайминги доставки и контролировать просрочку утверждения заявки исполнителем.
Столбец А вбивается вручную в формате дата+время по факту отправки заявки от заказчика.
В столбце В необходимо рассчитать тайминг доставки до исполнителя, что бы отсчитывать 24 часа для контроля просрочки.
Формула в столбце В позволяет рассчитать тайминг только если заявка направляется до 17:20 (условие договора), т.е. к текущей дате+время прибавляется 15 мин по условию, и к полученному значению
потом можно прибавить 24 часа,
но если заявка отправлена после 17:20 (условие договора) (строки 5,6,7 столбец А), формула уже не работает, поскольку мне надо как то прописать в значение "ложь"
вывод даты + 1 день и установки фиксированного времени 09:00 в соответствии с условиями договора, чтобы потом именно к 09:00
прибавлять 24 часа.

Далее в столбце G считается просрочка, не пойму почему не выводится слово "нет"
Все тайминги и просрочку необходимо считать исключая из расчета выходные и праздничные дни.
Что не так с этой формулой, где выделено красным:
=ЕСЛИ(ВРЕМЯ(ЧАС(A2);МИНУТЫ(A2);)<ВРЕМЯ(17;20;);A2+ВРЕМЯ(0;15;);A2+1*(ВРЕМЯ(9;0;)))
Спасибо.
К сообщению приложен файл: Test2_1_1.xls(28.0 Kb)
 
Ответить
СообщениеДобрый день, помогите понять ошибку в формулах, ничего похожего не нашел.
что бы была полная картина:
Задача: необходимо автоматически вычислять тайминги доставки и контролировать просрочку утверждения заявки исполнителем.
Столбец А вбивается вручную в формате дата+время по факту отправки заявки от заказчика.
В столбце В необходимо рассчитать тайминг доставки до исполнителя, что бы отсчитывать 24 часа для контроля просрочки.
Формула в столбце В позволяет рассчитать тайминг только если заявка направляется до 17:20 (условие договора), т.е. к текущей дате+время прибавляется 15 мин по условию, и к полученному значению
потом можно прибавить 24 часа,
но если заявка отправлена после 17:20 (условие договора) (строки 5,6,7 столбец А), формула уже не работает, поскольку мне надо как то прописать в значение "ложь"
вывод даты + 1 день и установки фиксированного времени 09:00 в соответствии с условиями договора, чтобы потом именно к 09:00
прибавлять 24 часа.

Далее в столбце G считается просрочка, не пойму почему не выводится слово "нет"
Все тайминги и просрочку необходимо считать исключая из расчета выходные и праздничные дни.
Что не так с этой формулой, где выделено красным:
=ЕСЛИ(ВРЕМЯ(ЧАС(A2);МИНУТЫ(A2);)<ВРЕМЯ(17;20;);A2+ВРЕМЯ(0;15;);A2+1*(ВРЕМЯ(9;0;)))
Спасибо.

Автор - striffe
Дата добавления - 02.12.2021 в 23:07
китин Дата: Пятница, 03.12.2021, 08:23 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6688
Репутация: 1020 ±
Замечаний: 0% ±

Excel 2007;Excel 2010
так?
Код
=ЕСЛИ(ВРЕМЯ(ЧАС(A7);МИНУТЫ(A7);)<ВРЕМЯ(17;20;);A7+ВРЕМЯ(0;15;);(ЦЕЛОЕ(A7)+1) +ВРЕМЯ(9;0;))


Не судите строго:я пытаюсь научиться
ЯД 41001877306852/WM R249698041931; Z239672726538
 
Ответить
Сообщениетак?
Код
=ЕСЛИ(ВРЕМЯ(ЧАС(A7);МИНУТЫ(A7);)<ВРЕМЯ(17;20;);A7+ВРЕМЯ(0;15;);(ЦЕЛОЕ(A7)+1) +ВРЕМЯ(9;0;))

Автор - китин
Дата добавления - 03.12.2021 в 08:23
Pelena Дата: Пятница, 03.12.2021, 08:31 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 18233
Репутация: 4096 ±
Замечаний: ±

Excel 2016 & Mac Excel
И в столбце G формулу лучше записать так
Код
=ЕСЛИ((C2-B2)>1;C2-B2;"нет")


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеИ в столбце G формулу лучше записать так
Код
=ЕСЛИ((C2-B2)>1;C2-B2;"нет")

Автор - Pelena
Дата добавления - 03.12.2021 в 08:31
striffe Дата: Пятница, 03.12.2021, 20:54 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

китин, Pelena, ух ты круто!) спасибо. А сильно изменится формула, если сделать вариант чтоб при расчете в столбце В "Доставка тайминг" учитывались выходные и праздничные, т.е. по дате понимается что это пятница, и заявка, направленная после 17:20 считается доставленной уже в понедельник в 09:00? и так же с праздниками.
 
Ответить
Сообщениекитин, Pelena, ух ты круто!) спасибо. А сильно изменится формула, если сделать вариант чтоб при расчете в столбце В "Доставка тайминг" учитывались выходные и праздничные, т.е. по дате понимается что это пятница, и заявка, направленная после 17:20 считается доставленной уже в понедельник в 09:00? и так же с праздниками.

Автор - striffe
Дата добавления - 03.12.2021 в 20:54
striffe Дата: Суббота, 04.12.2021, 00:14 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 7
Репутация: 0 ±
Замечаний: 0% ±

Кажется я справился с праздниками и выходными)

Код
=ЕСЛИ(ВРЕМЯ(ЧАС(A6);МИНУТЫ(A6);)<ВРЕМЯ(17;20;);A6+ВРЕМЯ(0;15;);(РАБДЕНЬ(A6;1;N43:N45) +ВРЕМЯ(9;0;))


но возникает еще одна проблема в случае праздников или выходных. Потом при проверке по таймингам разницы между датами столбцов D, B, получается, к примеру что фактически исполнитель вернул утвержденную заявку в пятницу в 17:45, а по условиям договора (>17:20) она считается доставленной заказчику уже после выходных/праздников в 9:00, но так как разница высчитывается именно по столбцам D, B, выходит ложная просрочка. Но это скорее всего условия договора кривые. Значит нужно еще встраивать какое то условие в формулу
Код
=ЕСЛИ((D5-B5)>1;D5-B5;"нет")
, которое исключит этот ложный показатель просрочки. Еще почему то в ячейке D5 формула неверно прибавляет рабочий день, по производственному календарю 5 марта это рабочий день, в формуле учтены 6,7,8 марта как выходные, однако дата перескакивает на 9 марта ;)
 
Ответить
СообщениеКажется я справился с праздниками и выходными)

Код
=ЕСЛИ(ВРЕМЯ(ЧАС(A6);МИНУТЫ(A6);)<ВРЕМЯ(17;20;);A6+ВРЕМЯ(0;15;);(РАБДЕНЬ(A6;1;N43:N45) +ВРЕМЯ(9;0;))


но возникает еще одна проблема в случае праздников или выходных. Потом при проверке по таймингам разницы между датами столбцов D, B, получается, к примеру что фактически исполнитель вернул утвержденную заявку в пятницу в 17:45, а по условиям договора (>17:20) она считается доставленной заказчику уже после выходных/праздников в 9:00, но так как разница высчитывается именно по столбцам D, B, выходит ложная просрочка. Но это скорее всего условия договора кривые. Значит нужно еще встраивать какое то условие в формулу
Код
=ЕСЛИ((D5-B5)>1;D5-B5;"нет")
, которое исключит этот ложный показатель просрочки. Еще почему то в ячейке D5 формула неверно прибавляет рабочий день, по производственному календарю 5 марта это рабочий день, в формуле учтены 6,7,8 марта как выходные, однако дата перескакивает на 9 марта ;)

Автор - striffe
Дата добавления - 04.12.2021 в 00:14
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Вычисления дат и времени по условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования Jobsora jooble
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!