Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Перенос значений со смещением по столбцам/строкам - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос значений со смещением по столбцам/строкам (Формулы/Formulas)
Перенос значений со смещением по столбцам/строкам
gendz1986 Дата: Среда, 08.12.2021, 12:03 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Добрый день, товарищи экселеведы!
Прошу помочь с переносом значений из правой таблицы в левую. При этом смещение по столбцу, к примеру ФИО, идет с ходом 3, а по строкам (Даты) с ходом 2.
Нужно чтобы переносились ФИО и значения правой таблицы.
Заранее благодарен. Сам не могу осилить(
К сообщению приложен файл: 21.xls(146.0 Kb)
 
Ответить
СообщениеДобрый день, товарищи экселеведы!
Прошу помочь с переносом значений из правой таблицы в левую. При этом смещение по столбцу, к примеру ФИО, идет с ходом 3, а по строкам (Даты) с ходом 2.
Нужно чтобы переносились ФИО и значения правой таблицы.
Заранее благодарен. Сам не могу осилить(

Автор - gendz1986
Дата добавления - 08.12.2021 в 12:03
Serge_007 Дата: Среда, 08.12.2021, 13:20 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 15415
Репутация: 2537 ±
Замечаний: ±

Excel 2016
Здравствуйте

Для имен:
Код
=ИНДЕКС(BV$14:BV$44;СТРОКА()/3-3)


Для времени принцип переноса не понял


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

Для имен:
Код
=ИНДЕКС(BV$14:BV$44;СТРОКА()/3-3)


Для времени принцип переноса не понял

Автор - Serge_007
Дата добавления - 08.12.2021 в 13:20
gendz1986 Дата: Среда, 08.12.2021, 13:32 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Для времени: значение из BW14 должно переноситься в F12 и далее по строке.
 
Ответить
СообщениеДля времени: значение из BW14 должно переноситься в F12 и далее по строке.

Автор - gendz1986
Дата добавления - 08.12.2021 в 13:32
Serge_007 Дата: Среда, 08.12.2021, 13:48 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 15415
Репутация: 2537 ±
Замечаний: ±

Excel 2016
значение из BW14 должно переноситься в F12
Это первое значение
Второе в примере из BX14 в X12, а третье из BZ14 в AB12
Тут нет закономерности...


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
значение из BW14 должно переноситься в F12
Это первое значение
Второе в примере из BX14 в X12, а третье из BZ14 в AB12
Тут нет закономерности...

Автор - Serge_007
Дата добавления - 08.12.2021 в 13:48
gendz1986 Дата: Среда, 08.12.2021, 14:15 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

BX14 должен в H12, BY14 в J12 и так далее. Чтобы можно было протягивать до 31го числа.
 
Ответить
СообщениеBX14 должен в H12, BY14 в J12 и так далее. Чтобы можно было протягивать до 31го числа.

Автор - gendz1986
Дата добавления - 08.12.2021 в 14:15
Serge_007 Дата: Среда, 08.12.2021, 14:21 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 15415
Репутация: 2537 ±
Замечаний: ±

Excel 2016
BX14 должен в H12, BY14 в J12
В примере не так...

BX14 должен в H12, BY14 в J12 и так далее
Код
=ИНДЕКС($BW14:$DA14;;СТОЛБЕЦ()/2-2)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
BX14 должен в H12, BY14 в J12
В примере не так...

BX14 должен в H12, BY14 в J12 и так далее
Код
=ИНДЕКС($BW14:$DA14;;СТОЛБЕЦ()/2-2)

Автор - Serge_007
Дата добавления - 08.12.2021 в 14:21
gendz1986 Дата: Среда, 08.12.2021, 14:38 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

По строке протягивается без ошибок. А когда пытаюсь скопировать вниз, к примеру по столбцу с первым числом месяца, то появляется сдвиг. Только вручную диапазон смещать?
 
Ответить
СообщениеПо строке протягивается без ошибок. А когда пытаюсь скопировать вниз, к примеру по столбцу с первым числом месяца, то появляется сдвиг. Только вручную диапазон смещать?

Автор - gendz1986
Дата добавления - 08.12.2021 в 14:38
Serge_007 Дата: Среда, 08.12.2021, 14:58 | Сообщение № 8
Группа: Админы
Ранг: Местный житель
Сообщений: 15415
Репутация: 2537 ±
Замечаний: ±

Excel 2016
Код
=ИНДЕКС($BW$14:$DA$44;СТРОКА()/3-3;СТОЛБЕЦ()/2-2)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Код
=ИНДЕКС($BW$14:$DA$44;СТРОКА()/3-3;СТОЛБЕЦ()/2-2)

Автор - Serge_007
Дата добавления - 08.12.2021 в 14:58
gendz1986 Дата: Среда, 08.12.2021, 15:15 | Сообщение № 9
Группа: Пользователи
Ранг: Прохожий
Сообщений: 5
Репутация: 0 ±
Замечаний: 0% ±

Спасибо за помощь! И за оперативность!
 
Ответить
СообщениеСпасибо за помощь! И за оперативность!

Автор - gendz1986
Дата добавления - 08.12.2021 в 15:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Перенос значений со смещением по столбцам/строкам (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!