Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск менеджера по максимальной дате заказа - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск менеджера по максимальной дате заказа (Формулы/Formulas)
Поиск менеджера по максимальной дате заказа
nsyrovatskaya Дата: Среда, 08.12.2021, 22:19 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

Помогите, пожалуйста, решить следующую задачку: есть список заказчиков с датами заказов и список менеджеров.
Необходимо каждому заказчику присвоить менеджера, который выполнил последний заказ.
Вроде понимаю, что существует изящное решение, но даже в неизящно решить не могу...
К сообщению приложен файл: 2474425.xlsx(40.7 Kb)
 
Ответить
СообщениеПомогите, пожалуйста, решить следующую задачку: есть список заказчиков с датами заказов и список менеджеров.
Необходимо каждому заказчику присвоить менеджера, который выполнил последний заказ.
Вроде понимаю, что существует изящное решение, но даже в неизящно решить не могу...

Автор - nsyrovatskaya
Дата добавления - 08.12.2021 в 22:19
amfor Дата: Четверг, 09.12.2021, 07:34 | Сообщение № 2
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 247
Репутация: 74 ±
Замечаний: 0% ±

Excel 2016
И вам добрый день.
Если даты не повторяются(для 2016) можно так:
в H2 и протянуть вниз
Код
=ВПР(МАКСЕСЛИ($C$2:$C$18;$A$2:$A$18;$G2);$C$2:$D$18;2;0)

Если даты могут повторяться, чуть сложнее
Код
=ВПР(ИНДЕКС($B$2:$C$18;ПОИСКПОЗ(МАКСЕСЛИ($C$2:$C$18;$A$2:$A$18;$G2);$C$2:$C$18;0);1);$B$2:$D$18;3;0)
К сообщению приложен файл: 0520900.xlsx(42.3 Kb)


Семь бед - один RESET.
 
Ответить
СообщениеИ вам добрый день.
Если даты не повторяются(для 2016) можно так:
в H2 и протянуть вниз
Код
=ВПР(МАКСЕСЛИ($C$2:$C$18;$A$2:$A$18;$G2);$C$2:$D$18;2;0)

Если даты могут повторяться, чуть сложнее
Код
=ВПР(ИНДЕКС($B$2:$C$18;ПОИСКПОЗ(МАКСЕСЛИ($C$2:$C$18;$A$2:$A$18;$G2);$C$2:$C$18;0);1);$B$2:$D$18;3;0)

Автор - amfor
Дата добавления - 09.12.2021 в 07:34
nsyrovatskaya Дата: Четверг, 09.12.2021, 09:58 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 9
Репутация: 0 ±
Замечаний: 0% ±

amfor, про добрый день и забыла вовсе...
спасибо вам большое, я б да такого не додумалась... а даты еще как повторяются.
 
Ответить
Сообщениеamfor, про добрый день и забыла вовсе...
спасибо вам большое, я б да такого не додумалась... а даты еще как повторяются.

Автор - nsyrovatskaya
Дата добавления - 09.12.2021 в 09:58
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск менеджера по максимальной дате заказа (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!