Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Выпадающий список с поиском - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выпадающий список с поиском (Формулы/Formulas)
Выпадающий список с поиском
Смольный Дата: Четверг, 16.12.2021, 13:09 | Сообщение № 1
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 188
Репутация: 0 ±
Замечаний: 0% ±

Доброго дня всем форумчанам. Снова нужна Ваша помощь. Суть вопроса такая, на первом листе номенклатура(ее около 1000 штук будет) на листе заявление в ячейке К9 и К14 нужен выпадающий список с поиском данных столбца В на листе "Номенклатура" Ячейки К9 и К14 должны работать отдельно друг от друга. При выборе данных в ячейке К9, в ячейки Н9 и N9 подтягиваются данные с листа "Номенклатура" В прикрепленном файле привел пример.
К сообщению приложен файл: 9609254.xlsx(11.1 Kb)
 
Ответить
СообщениеДоброго дня всем форумчанам. Снова нужна Ваша помощь. Суть вопроса такая, на первом листе номенклатура(ее около 1000 штук будет) на листе заявление в ячейке К9 и К14 нужен выпадающий список с поиском данных столбца В на листе "Номенклатура" Ячейки К9 и К14 должны работать отдельно друг от друга. При выборе данных в ячейке К9, в ячейки Н9 и N9 подтягиваются данные с листа "Номенклатура" В прикрепленном файле привел пример.

Автор - Смольный
Дата добавления - 16.12.2021 в 13:09
Nic70y Дата: Четверг, 16.12.2021, 13:55 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7731
Репутация: 1856 ±
Замечаний: 0% ±

Excel 2010
список
Код
=ДВССЫЛ("Номенклатура!B2:B"&ПОИСКПОЗ(9E+307;Номенклатура!$B:$B))
тянучка
Код
=ИНДЕКС(Номенклатура!A:A;ПОИСКПОЗ($K9;Номенклатура!$B:$B;))
К сообщению приложен файл: 18.xlsx(11.3 Kb)


ЮMoney 41001841029809
 
Ответить
Сообщениесписок
Код
=ДВССЫЛ("Номенклатура!B2:B"&ПОИСКПОЗ(9E+307;Номенклатура!$B:$B))
тянучка
Код
=ИНДЕКС(Номенклатура!A:A;ПОИСКПОЗ($K9;Номенклатура!$B:$B;))

Автор - Nic70y
Дата добавления - 16.12.2021 в 13:55
Смольный Дата: Четверг, 16.12.2021, 14:10 | Сообщение № 3
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 188
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, Супер, можно сделать чтоб только нужный номер оставался, который в К14 введен?
К сообщению приложен файл: 4390547.png(28.6 Kb)
 
Ответить
СообщениеNic70y, Супер, можно сделать чтоб только нужный номер оставался, который в К14 введен?

Автор - Смольный
Дата добавления - 16.12.2021 в 14:10
Nic70y Дата: Четверг, 16.12.2021, 14:17 | Сообщение № 4
Группа: Друзья
Ранг: Экселист
Сообщений: 7731
Репутация: 1856 ±
Замечаний: 0% ±

Excel 2010
Смольный, не понял ваш вопрос.


ЮMoney 41001841029809
 
Ответить
СообщениеСмольный, не понял ваш вопрос.

Автор - Nic70y
Дата добавления - 16.12.2021 в 14:17
Смольный Дата: Четверг, 16.12.2021, 14:28 | Сообщение № 5
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 188
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, Если я ввожу в ячейке К14 не полностью номер, а цифру пять, то в поиске все равно все номера.
 
Ответить
СообщениеNic70y, Если я ввожу в ячейке К14 не полностью номер, а цифру пять, то в поиске все равно все номера.

Автор - Смольный
Дата добавления - 16.12.2021 в 14:28
Nic70y Дата: Четверг, 16.12.2021, 14:38 | Сообщение № 6
Группа: Друзья
Ранг: Экселист
Сообщений: 7731
Репутация: 1856 ±
Замечаний: 0% ±

Excel 2010
теперь понял 9наверное), это макросом нужно
http://www.excelworld.ru/board/vba/tricks/find_in_database/9-1-0-27
вам так надо?


ЮMoney 41001841029809
 
Ответить
Сообщениетеперь понял 9наверное), это макросом нужно
http://www.excelworld.ru/board/vba/tricks/find_in_database/9-1-0-27
вам так надо?

Автор - Nic70y
Дата добавления - 16.12.2021 в 14:38
Смольный Дата: Четверг, 16.12.2021, 15:29 | Сообщение № 7
Группа: Проверенные
Ранг: Форумчанин
Сообщений: 188
Репутация: 0 ±
Замечаний: 0% ±

Nic70y, если честно, не совсем понятно как там реализовано, файл пример посмотрел, если правильно понял то там поиск именно в столбце самой номенклатуры.


Сообщение отредактировал Смольный - Четверг, 16.12.2021, 15:29
 
Ответить
СообщениеNic70y, если честно, не совсем понятно как там реализовано, файл пример посмотрел, если правильно понял то там поиск именно в столбце самой номенклатуры.

Автор - Смольный
Дата добавления - 16.12.2021 в 15:29
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Выпадающий список с поиском (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!