Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Автозаполнение определенных строк из выпадающего списка - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автозаполнение определенных строк из выпадающего списка (Формулы/Formulas)
Автозаполнение определенных строк из выпадающего списка
festdm Дата: Четверг, 16.12.2021, 23:10 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Добрый вечер! Прошу помощи!
Например, есть выпадающий список из 12 элементов (a,b,c........)
Как сделать так, чтобы при выборе значения из него, например "с" в 16 определенных ячейках отображались по порядку значения из списка: c,d,e.....a,b..то есть доходя до последнего значения, начиналось с первого..
Объяснил, как смог..может кто поймет и поможет...)
Прилагаю файл, оранжевым залил куда должны отправляться значения, первым идет выпадающий список с фамилиями, там я должен выбираться с кого начинать.
К сообщению приложен файл: tp.xlsx(10.5 Kb)
 
Ответить
СообщениеДобрый вечер! Прошу помощи!
Например, есть выпадающий список из 12 элементов (a,b,c........)
Как сделать так, чтобы при выборе значения из него, например "с" в 16 определенных ячейках отображались по порядку значения из списка: c,d,e.....a,b..то есть доходя до последнего значения, начиналось с первого..
Объяснил, как смог..может кто поймет и поможет...)
Прилагаю файл, оранжевым залил куда должны отправляться значения, первым идет выпадающий список с фамилиями, там я должен выбираться с кого начинать.

Автор - festdm
Дата добавления - 16.12.2021 в 23:10
Pelena Дата: Четверг, 16.12.2021, 23:42 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18555
Репутация: 4202 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Код
=ИНДЕКС(Лист3!$B$2:$B$13;ОСТАТ(ПОИСКПОЗ(C$5;Лист3!$B$2:$B$13;0)+B7-2;СЧЁТЗ(Лист3!$B$2:$B$13))+1)
К сообщению приложен файл: 1249413.xlsx(12.7 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Код
=ИНДЕКС(Лист3!$B$2:$B$13;ОСТАТ(ПОИСКПОЗ(C$5;Лист3!$B$2:$B$13;0)+B7-2;СЧЁТЗ(Лист3!$B$2:$B$13))+1)

Автор - Pelena
Дата добавления - 16.12.2021 в 23:42
festdm Дата: Пятница, 17.12.2021, 13:40 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Pelena, Вообще супер, еще одна маленькая делать.
Если в столбце B и F будет не нумерация, а время?
 
Ответить
СообщениеPelena, Вообще супер, еще одна маленькая делать.
Если в столбце B и F будет не нумерация, а время?

Автор - festdm
Дата добавления - 17.12.2021 в 13:40
Pelena Дата: Пятница, 17.12.2021, 13:43 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 18555
Репутация: 4202 ±
Замечаний: ±

Excel 2016 & Mac Excel
Пример?


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеПример?

Автор - Pelena
Дата добавления - 17.12.2021 в 13:43
festdm Дата: Пятница, 17.12.2021, 13:49 | Сообщение № 5
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Вот пример
Я как бы понимаю, что нумерацию можно вынести за пределы и скрыть чтобы все работало
Но может можно как то по другому?
К сообщению приложен файл: 6707973.xlsx(12.1 Kb)
 
Ответить
СообщениеВот пример
Я как бы понимаю, что нумерацию можно вынести за пределы и скрыть чтобы все работало
Но может можно как то по другому?

Автор - festdm
Дата добавления - 17.12.2021 в 13:49
Pelena Дата: Пятница, 17.12.2021, 14:06 | Сообщение № 6
Группа: Админы
Ранг: Местный житель
Сообщений: 18555
Репутация: 4202 ±
Замечаний: ±

Excel 2016 & Mac Excel
Так проверьте
К сообщению приложен файл: 1685269.xlsx(12.0 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеТак проверьте

Автор - Pelena
Дата добавления - 17.12.2021 в 14:06
festdm Дата: Пятница, 17.12.2021, 14:15 | Сообщение № 7
Группа: Пользователи
Ранг: Прохожий
Сообщений: 4
Репутация: 0 ±
Замечаний: 0% ±

Супер! Огромное спасибо!!!!
 
Ответить
СообщениеСупер! Огромное спасибо!!!!

Автор - festdm
Дата добавления - 17.12.2021 в 14:15
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Автозаполнение определенных строк из выпадающего списка (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!