Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Расчет по выбранному условию - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет по выбранному условию (Формулы/Formulas)
Расчет по выбранному условию
ElenaHo Дата: Среда, 22.12.2021, 13:15 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте!
Есть табличка с данными (Лист1) и форма ТЗ. Нужно чтобы при выборе из выпадающего списка позиций и вводе значений в ячейку N24 или O24, т. е. вводят какое-то одно значение или в одну или в другую ячейку.
В столбце "Цена за единицу" автоматически подтягивалась цена из Листа1. Понимаю, что скорее всего через ВПР и ЕСЛИ, но не работает формула. Помогите, пожалуйста, советом.
В прикрепленном файле есть формула через которую пыталась оформить данное решение, но не получается. :(
К сообщению приложен файл: 4704237.xlsx(68.1 Kb)
 
Ответить
СообщениеЗдравствуйте!
Есть табличка с данными (Лист1) и форма ТЗ. Нужно чтобы при выборе из выпадающего списка позиций и вводе значений в ячейку N24 или O24, т. е. вводят какое-то одно значение или в одну или в другую ячейку.
В столбце "Цена за единицу" автоматически подтягивалась цена из Листа1. Понимаю, что скорее всего через ВПР и ЕСЛИ, но не работает формула. Помогите, пожалуйста, советом.
В прикрепленном файле есть формула через которую пыталась оформить данное решение, но не получается. :(

Автор - ElenaHo
Дата добавления - 22.12.2021 в 13:15
Nic70y Дата: Среда, 22.12.2021, 13:36 | Сообщение № 2
Группа: Друзья
Ранг: Экселист
Сообщений: 7731
Репутация: 1856 ±
Замечаний: 0% ±

Excel 2010
как-то так
Код
=ИНДЕКС(Лист1!B$2:C$40;ПОИСКПОЗ(B24;Лист1!A$2:A$40;);1+(O24>0))
наверное
или так
Код
=ВПР(B24;Лист1!A$2:C$40;2+(O24>0);)


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Среда, 22.12.2021, 13:37
 
Ответить
Сообщениекак-то так
Код
=ИНДЕКС(Лист1!B$2:C$40;ПОИСКПОЗ(B24;Лист1!A$2:A$40;);1+(O24>0))
наверное
или так
Код
=ВПР(B24;Лист1!A$2:C$40;2+(O24>0);)

Автор - Nic70y
Дата добавления - 22.12.2021 в 13:36
Serge_007 Дата: Среда, 22.12.2021, 13:39 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 15415
Репутация: 2537 ±
Замечаний: ±

Excel 2016
Здравствуйте

В P25:
Код
=ВПР(B25;Лист1!A$1:C$40;СУММПРОИЗВ((N25:O25<>"")*{2;3});0)
К сообщению приложен файл: 20211222_ElenaH.xls(165.5 Kb)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
СообщениеЗдравствуйте

В P25:
Код
=ВПР(B25;Лист1!A$1:C$40;СУММПРОИЗВ((N25:O25<>"")*{2;3});0)

Автор - Serge_007
Дата добавления - 22.12.2021 в 13:39
ElenaHo Дата: Среда, 22.12.2021, 14:54 | Сообщение № 4
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Спасибо большое. Вот о таком варианте даже и не вспомнила :D
 
Ответить
СообщениеСпасибо большое. Вот о таком варианте даже и не вспомнила :D

Автор - ElenaHo
Дата добавления - 22.12.2021 в 14:54
ElenaHo Дата: Понедельник, 27.12.2021, 09:28 | Сообщение № 5
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте!
Подскажите, пожалуйста, еще такой вопрос. В первый раз с таким сталкиваюсь. Делаю выпадающий список в таблице. Сохраняю ее при закрытии, а когда открываю он пропадает. Что это может быть? Уже данные упорядочила как таблицу, ничего не помогает. (Таблица та же поэтому в продолжении этой же темы пишу).
И еще не могу сообразить какую формулу написать в колонке "Цена итого рублей", чтобы она перемножала колонку N42*Q42 или O42*Q42 смотря в какую из колонок внесено значение. Пробовала через если и умножение, но не работает
К сообщению приложен файл: ___.xls(130.0 Kb)
 
Ответить
СообщениеЗдравствуйте!
Подскажите, пожалуйста, еще такой вопрос. В первый раз с таким сталкиваюсь. Делаю выпадающий список в таблице. Сохраняю ее при закрытии, а когда открываю он пропадает. Что это может быть? Уже данные упорядочила как таблицу, ничего не помогает. (Таблица та же поэтому в продолжении этой же темы пишу).
И еще не могу сообразить какую формулу написать в колонке "Цена итого рублей", чтобы она перемножала колонку N42*Q42 или O42*Q42 смотря в какую из колонок внесено значение. Пробовала через если и умножение, но не работает

Автор - ElenaHo
Дата добавления - 27.12.2021 в 09:28
китин Дата: Понедельник, 27.12.2021, 10:12 | Сообщение № 6
Группа: Модераторы
Ранг: Экселист
Сообщений: 6895
Репутация: 1056 ±
Замечаний: 0% ±

Excel 2007;2010;2016
Ну у вас похоже Ексель 2003, а он не поддерживает диапазоны с других листов. надо делать именованный диапазон( см. в файле диспетчер имен) а по формуле как то так
Код
=ЕСЛИ($N45="";$O45*$P45;$N45*$P45)
К сообщению приложен файл: 125.xls(131.0 Kb)


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
СообщениеНу у вас похоже Ексель 2003, а он не поддерживает диапазоны с других листов. надо делать именованный диапазон( см. в файле диспетчер имен) а по формуле как то так
Код
=ЕСЛИ($N45="";$O45*$P45;$N45*$P45)

Автор - китин
Дата добавления - 27.12.2021 в 10:12
ElenaHo Дата: Понедельник, 27.12.2021, 10:18 | Сообщение № 7
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Спасибо! hands
 
Ответить
СообщениеСпасибо! hands

Автор - ElenaHo
Дата добавления - 27.12.2021 в 10:18
ElenaHo Дата: Пятница, 14.01.2022, 11:21 | Сообщение № 8
Группа: Пользователи
Ранг: Новичок
Сообщений: 13
Репутация: 0 ±
Замечаний: 0% ±

Здравствуйте!
В процессе доработки формы во вложении, возникла еще одна потребность:
Теперь вставила формулу, которая при указывании длины и ширины перемножает их и считает М2. Возникла потребность следующего плана:
какую формулу добавить чтобы в ячейке Q42 (Цена за единицу) цена устанавливалась при следующих условиях: Если м2 <50м, то формула подставляла бы цену за единицу из ячейки B41, а если >50м, то из ячейки С41 Листа "Стоимость за материал". Но только по тем позициям, которые выделены зеленым цветом. А по остальным позициям из столбца С листа "Стоимость за материал" брала цены.
Весь мозг себе уже сломала))) Помогите, пожалуйста :(
К сообщению приложен файл: 8818084.xls(135.0 Kb)
 
Ответить
СообщениеЗдравствуйте!
В процессе доработки формы во вложении, возникла еще одна потребность:
Теперь вставила формулу, которая при указывании длины и ширины перемножает их и считает М2. Возникла потребность следующего плана:
какую формулу добавить чтобы в ячейке Q42 (Цена за единицу) цена устанавливалась при следующих условиях: Если м2 <50м, то формула подставляла бы цену за единицу из ячейки B41, а если >50м, то из ячейки С41 Листа "Стоимость за материал". Но только по тем позициям, которые выделены зеленым цветом. А по остальным позициям из столбца С листа "Стоимость за материал" брала цены.
Весь мозг себе уже сломала))) Помогите, пожалуйста :(

Автор - ElenaHo
Дата добавления - 14.01.2022 в 11:21
китин Дата: Пятница, 14.01.2022, 11:50 | Сообщение № 9
Группа: Модераторы
Ранг: Экселист
Сообщений: 6895
Репутация: 1056 ±
Замечаний: 0% ±

Excel 2007;2010;2016
ElenaHo, этот вопрос не имеет отношения к вашему предыдущему вопросу. Создайте новую тему


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
СообщениеElenaHo, этот вопрос не имеет отношения к вашему предыдущему вопросу. Создайте новую тему

Автор - китин
Дата добавления - 14.01.2022 в 11:50
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Расчет по выбранному условию (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!