Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/ВПР и часть значения из ячейки - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР и часть значения из ячейки (Формулы/Formulas)
ВПР и часть значения из ячейки
forteinvestozerovav Дата: Среда, 22.12.2021, 13:52 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Добрый день!

Прошу Вас помочь. файл эксель во вложении.
Вводные:
На листе рабочая таблица(умная) собираются данные из массива, а так же из других листов.
Столбец B - номер заявки, который притягивается из массива данных
Столбец С - из столбца В - изымаются все знаки до "/" и включая его, формула прописана
Столбец D - из столбца B - изымаются все цифры после "/", их всегда 4
Столбец E - через ВПР из листа "ВПР", должны подтягиваться значения (ссылаясь на столбец D)

Итог: ВПР не работает. Изменять формат ячеек пробовал. Прошу подсказать или скинуть ссылку на аналогичную тему. Заранее благодарю
К сообщению приложен файл: Forum.xlsx(13.7 Kb)
 
Ответить
СообщениеДобрый день!

Прошу Вас помочь. файл эксель во вложении.
Вводные:
На листе рабочая таблица(умная) собираются данные из массива, а так же из других листов.
Столбец B - номер заявки, который притягивается из массива данных
Столбец С - из столбца В - изымаются все знаки до "/" и включая его, формула прописана
Столбец D - из столбца B - изымаются все цифры после "/", их всегда 4
Столбец E - через ВПР из листа "ВПР", должны подтягиваться значения (ссылаясь на столбец D)

Итог: ВПР не работает. Изменять формат ячеек пробовал. Прошу подсказать или скинуть ссылку на аналогичную тему. Заранее благодарю

Автор - forteinvestozerovav
Дата добавления - 22.12.2021 в 13:52
китин Дата: Среда, 22.12.2021, 14:18 | Сообщение № 2
Группа: Модераторы
Ранг: Экселист
Сообщений: 6895
Репутация: 1056 ±
Замечаний: 0% ±

Excel 2007;2010;2016
у вас в столбце D листа Рабочая таблица данные текст. поэтому и #Н/Д . навскидку
Код
=--ЕСЛИ(ЕОШИБКА(ПСТР(B3;НАЙТИ("/";B3)+1;ДЛСТР(B3)));" ";ПСТР(B3;НАЙТИ("/";B3)+1;ДЛСТР(B3)))

в ячейку D3


Не судите очень строго:я пытаюсь научиться
ЯД 41001877306852
 
Ответить
Сообщениеу вас в столбце D листа Рабочая таблица данные текст. поэтому и #Н/Д . навскидку
Код
=--ЕСЛИ(ЕОШИБКА(ПСТР(B3;НАЙТИ("/";B3)+1;ДЛСТР(B3)));" ";ПСТР(B3;НАЙТИ("/";B3)+1;ДЛСТР(B3)))

в ячейку D3

Автор - китин
Дата добавления - 22.12.2021 в 14:18
Serge_007 Дата: Среда, 22.12.2021, 14:21 | Сообщение № 3
Группа: Админы
Ранг: Местный житель
Сообщений: 15415
Репутация: 2537 ±
Замечаний: ±

Excel 2016
Цитата forteinvestozerovav, 22.12.2021 в 13:52, в сообщении № 1 ()
ВПР не работает...Прошу подсказать
Код
=ВПР(--D3;ВПР!B:D;2;)


ЮMoney:41001419691823 | WMR:126292472390
 
Ответить
Сообщение
Цитата forteinvestozerovav, 22.12.2021 в 13:52, в сообщении № 1 ()
ВПР не работает...Прошу подсказать
Код
=ВПР(--D3;ВПР!B:D;2;)

Автор - Serge_007
Дата добавления - 22.12.2021 в 14:21
forteinvestozerovav Дата: Среда, 22.12.2021, 14:25 | Сообщение № 4
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Код
=--ЕСЛИ(ЕОШИБКА(ПСТР(B3;НАЙТИ("/";B3)+1;ДЛСТР(B3)));" ";ПСТР(B3;НАЙТИ("/";B3)+1;ДЛСТР(B3)))


Спасибо, помогло.


Сообщение отредактировал Serge_007 - Среда, 22.12.2021, 14:30
 
Ответить
Сообщение
Код
=--ЕСЛИ(ЕОШИБКА(ПСТР(B3;НАЙТИ("/";B3)+1;ДЛСТР(B3)));" ";ПСТР(B3;НАЙТИ("/";B3)+1;ДЛСТР(B3)))


Спасибо, помогло.

Автор - forteinvestozerovav
Дата добавления - 22.12.2021 в 14:25
Мир MS Excel » Вопросы и решения » Вопросы по Excel » ВПР и часть значения из ячейки (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!