Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск даты, ближайшей к заданной - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск даты, ближайшей к заданной (Формулы/Formulas)
Поиск даты, ближайшей к заданной
pirotehnik Дата: Воскресенье, 09.01.2022, 19:42 | Сообщение № 1
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
Коллеги, добрый вечер!
Прошу помочь в решении следующей задачи.
Из столбца D надо перенести дату, ближайшую к дате в столбце А.
Итоговый вариант решения задачи отражен в столбце B.
Заранее всем спасибо за помощь!
К сообщению приложен файл: 7829263.xlsx(10.5 Kb)


Сообщение отредактировал pirotehnik - Воскресенье, 09.01.2022, 19:46
 
Ответить
СообщениеКоллеги, добрый вечер!
Прошу помочь в решении следующей задачи.
Из столбца D надо перенести дату, ближайшую к дате в столбце А.
Итоговый вариант решения задачи отражен в столбце B.
Заранее всем спасибо за помощь!

Автор - pirotehnik
Дата добавления - 09.01.2022 в 19:42
gling Дата: Воскресенье, 09.01.2022, 20:26 | Сообщение № 2
Группа: Друзья
Ранг: Старожил
Сообщений: 2372
Репутация: 617 ±
Замечаний: 0% ±

2010
Здравствуйте.
Попробуйте формулу массива
Код
=ИНДЕКС($D$2:$D$9;ПОИСКПОЗ(МИН(ABS(A2-$D$2:$D$9));ABS(A2-$D$2:$D$9);))
К сообщению приложен файл: 3623289.xls(57.0 Kb)


ЯД-41001506838083
 
Ответить
СообщениеЗдравствуйте.
Попробуйте формулу массива
Код
=ИНДЕКС($D$2:$D$9;ПОИСКПОЗ(МИН(ABS(A2-$D$2:$D$9));ABS(A2-$D$2:$D$9);))

Автор - gling
Дата добавления - 09.01.2022 в 20:26
pirotehnik Дата: Воскресенье, 09.01.2022, 20:41 | Сообщение № 3
Группа: Пользователи
Ранг: Новичок
Сообщений: 11
Репутация: 0 ±
Замечаний: 0% ±

Excel 2013
К сожалению, некорректно переносятся даты (данные в столбцах В и С разные).
К сообщению приложен файл: _7829263-2.xlsx(10.5 Kb)


Сообщение отредактировал pirotehnik - Воскресенье, 09.01.2022, 20:44
 
Ответить
СообщениеК сожалению, некорректно переносятся даты (данные в столбцах В и С разные).

Автор - pirotehnik
Дата добавления - 09.01.2022 в 20:41
gling Дата: Воскресенье, 09.01.2022, 20:55 | Сообщение № 4
Группа: Друзья
Ранг: Старожил
Сообщений: 2372
Репутация: 617 ±
Замечаний: 0% ±

2010
Да чтото я упустил, не обратил внимание на формулу в столбце С. Тогда так
Код
=ЕСЛИ(ИНДЕКС($D$2:$D$9;ПОИСКПОЗ(МИН(ABS(A2-$D$2:$D$9));ABS(A2-$D$2:$D$9);))<A2;ИНДЕКС($D$2:$D$9;ПОИСКПОЗ(МИН(ABS(A2-$D$2:$D$9));ABS(A2-$D$2:$D$9);)+1);ИНДЕКС($D$2:$D$9;ПОИСКПОЗ(МИН(ABS(A2-$D$2:$D$9));ABS(A2-$D$2:$D$9);)))


ЯД-41001506838083

Сообщение отредактировал gling - Воскресенье, 09.01.2022, 21:07
 
Ответить
СообщениеДа чтото я упустил, не обратил внимание на формулу в столбце С. Тогда так
Код
=ЕСЛИ(ИНДЕКС($D$2:$D$9;ПОИСКПОЗ(МИН(ABS(A2-$D$2:$D$9));ABS(A2-$D$2:$D$9);))<A2;ИНДЕКС($D$2:$D$9;ПОИСКПОЗ(МИН(ABS(A2-$D$2:$D$9));ABS(A2-$D$2:$D$9);)+1);ИНДЕКС($D$2:$D$9;ПОИСКПОЗ(МИН(ABS(A2-$D$2:$D$9));ABS(A2-$D$2:$D$9);)))

Автор - gling
Дата добавления - 09.01.2022 в 20:55
Pelena Дата: Воскресенье, 09.01.2022, 21:27 | Сообщение № 5
Группа: Админы
Ранг: Местный житель
Сообщений: 18555
Репутация: 4202 ±
Замечаний: ±

Excel 2016 & Mac Excel
Я так поняла, что надо ближайшее большее или равное.
Вариант
Код
=A2+МИН(--ТЕКСТ($D$2:$D$9-A2;"[ч]:мм;99999"))


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЯ так поняла, что надо ближайшее большее или равное.
Вариант
Код
=A2+МИН(--ТЕКСТ($D$2:$D$9-A2;"[ч]:мм;99999"))

Автор - Pelena
Дата добавления - 09.01.2022 в 21:27
gling Дата: Понедельник, 10.01.2022, 03:53 | Сообщение № 6
Группа: Друзья
Ранг: Старожил
Сообщений: 2372
Репутация: 617 ±
Замечаний: 0% ±

2010
Вариант
Красивый вариант!


ЯД-41001506838083
 
Ответить
Сообщение
Вариант
Красивый вариант!

Автор - gling
Дата добавления - 10.01.2022 в 03:53
Nic70y Дата: Понедельник, 10.01.2022, 07:53 | Сообщение № 7
Группа: Друзья
Ранг: Экселист
Сообщений: 7731
Репутация: 1856 ±
Замечаний: 0% ±

Excel 2010
для разнообразия, без массивного ввода
Код
=ИНДЕКС(D$2:D$9;ЧСТРОК(D$2:D$9)-СЧЁТЕСЛИ(D$2:D$9;">="&A2)+1)
или
Код
=ИНДЕКС(D$2:D$9;9-СЧЁТЕСЛИ(D$2:D$9;">="&A2))


апдэйт, так "правильнее"
Код
=НАИМЕНЬШИЙ(D$2:D$9;СЧЁТЕСЛИ(D$2:D$9;"<="&A2)+1)


ЮMoney 41001841029809

Сообщение отредактировал Nic70y - Понедельник, 10.01.2022, 11:51
 
Ответить
Сообщениедля разнообразия, без массивного ввода
Код
=ИНДЕКС(D$2:D$9;ЧСТРОК(D$2:D$9)-СЧЁТЕСЛИ(D$2:D$9;">="&A2)+1)
или
Код
=ИНДЕКС(D$2:D$9;9-СЧЁТЕСЛИ(D$2:D$9;">="&A2))


апдэйт, так "правильнее"
Код
=НАИМЕНЬШИЙ(D$2:D$9;СЧЁТЕСЛИ(D$2:D$9;"<="&A2)+1)

Автор - Nic70y
Дата добавления - 10.01.2022 в 07:53
jakim Дата: Понедельник, 10.01.2022, 12:18 | Сообщение № 8
Группа: Друзья
Ранг: Старожил
Сообщений: 1116
Репутация: 295 ±
Замечаний: 0% ±

Excel 2010
Ещё одна формула
Код

=AGGREGATE(15;6;D$2:D$9/(A2<=D$2:D$9);1)
 
Ответить
Сообщение
Ещё одна формула
Код

=AGGREGATE(15;6;D$2:D$9/(A2<=D$2:D$9);1)

Автор - jakim
Дата добавления - 10.01.2022 в 12:18
MCH Дата: Понедельник, 10.01.2022, 12:43 | Сообщение № 9
Группа: Админы
Ранг: Старожил
Сообщений: 2000
Репутация: 751 ±
Замечаний: ±

формула массива:
Код
=МИН(ЕСЛИ(D$2:D$9>=A2;D$2:D$9))
 
Ответить
Сообщениеформула массива:
Код
=МИН(ЕСЛИ(D$2:D$9>=A2;D$2:D$9))

Автор - MCH
Дата добавления - 10.01.2022 в 12:43
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск даты, ближайшей к заданной (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!