Домашняя страница Undo Do New Save Карта сайта Обратная связь Поиск по форуму
МИР MS EXCEL - Гость.xls

Вход

Регистрация

Напомнить пароль

 

= Мир MS Excel/Поиск части текста в ячейке по заданным условиям - Мир MS Excel

Старая форма входа
  • Страница 1 из 1
  • 1
Модератор форума: китин, _Boroda_  
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск части текста в ячейке по заданным условиям (Формулы/Formulas)
Поиск части текста в ячейке по заданным условиям
Маруся4104 Дата: Вторник, 25.01.2022, 20:03 | Сообщение № 1
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

Добрый вечер всем гуру Excel! Помогите пожалуйста.
Написана формула в ячейке С2, которая ищет нужную часть текста в ячейках стоЛбца В из списка в столбце А.
Присваивает "Серый" если есть совпадение с значениями в диапазоне А2:А7, "Оранжевый" - если совпадение с диапазоном А8:А9.
Но загвоздка в том, что не могу понять как написать третий вариант: если в ячейке столбца В есть совпадение и с значениями в диапазоне А2:А7 и диапазоне А8:А9
он может быть какой угодно, главное отличный от первых двух.
Может написать вспомогательную формулу или как-то в эту можно ввернуть?
Помогите кто чем может))

Р.С. серый и оранжевый это просто пример, в реальной таблице привязки к цветам не будет. Т.е там могут быть просто цифры 1 и 2
К сообщению приложен файл: 8717631.xlsx(14.1 Kb)
 
Ответить
СообщениеДобрый вечер всем гуру Excel! Помогите пожалуйста.
Написана формула в ячейке С2, которая ищет нужную часть текста в ячейках стоЛбца В из списка в столбце А.
Присваивает "Серый" если есть совпадение с значениями в диапазоне А2:А7, "Оранжевый" - если совпадение с диапазоном А8:А9.
Но загвоздка в том, что не могу понять как написать третий вариант: если в ячейке столбца В есть совпадение и с значениями в диапазоне А2:А7 и диапазоне А8:А9
он может быть какой угодно, главное отличный от первых двух.
Может написать вспомогательную формулу или как-то в эту можно ввернуть?
Помогите кто чем может))

Р.С. серый и оранжевый это просто пример, в реальной таблице привязки к цветам не будет. Т.е там могут быть просто цифры 1 и 2

Автор - Маруся4104
Дата добавления - 25.01.2022 в 20:03
Pelena Дата: Вторник, 25.01.2022, 21:16 | Сообщение № 2
Группа: Админы
Ранг: Местный житель
Сообщений: 18550
Репутация: 4199 ±
Замечаний: ±

Excel 2016 & Mac Excel
Здравствуйте.
Вариант
Код
=ЕСЛИ(И(СЧЁТ(ПОИСК($A$1:$A$7;B2));СЧЁТ(ПОИСК($A$8:$A$9;B2)));"Серый и Оранжевый";ЕСЛИ(СЧЁТ(ПОИСК($A$1:$A$7;B2));"Серый";ЕСЛИ(СЧЁТ(ПОИСК($A$8:$A$9;B2));"Оранжевый";"нет совпадений")))
К сообщению приложен файл: 2821919.xlsx(15.1 Kb)


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
СообщениеЗдравствуйте.
Вариант
Код
=ЕСЛИ(И(СЧЁТ(ПОИСК($A$1:$A$7;B2));СЧЁТ(ПОИСК($A$8:$A$9;B2)));"Серый и Оранжевый";ЕСЛИ(СЧЁТ(ПОИСК($A$1:$A$7;B2));"Серый";ЕСЛИ(СЧЁТ(ПОИСК($A$8:$A$9;B2));"Оранжевый";"нет совпадений")))

Автор - Pelena
Дата добавления - 25.01.2022 в 21:16
Маруся4104 Дата: Вторник, 25.01.2022, 22:30 | Сообщение № 3
Группа: Пользователи
Ранг: Прохожий
Сообщений: 2
Репутация: 0 ±
Замечаний: 0% ±

=ЕСЛИ(И(СЧЁТ(ПОИСК($A$1:$A$7;B2));СЧЁТ(ПОИСК($A$8:$A$9;B2)));"Серый и Оранжевый";ЕСЛИ(СЧЁТ(ПОИСК($A$1:$A$7;B2));"Серый";ЕСЛИ(СЧЁТ(ПОИСК($A$8:$A$9;B2));"Оранжевый";"нет совпадений")))

Спасибо. правда формулы массива не мой конек, буду разбираться, как с ними работать, если скопировать в другую книгу. У вас в книге все отлично работает
 
Ответить
Сообщение
=ЕСЛИ(И(СЧЁТ(ПОИСК($A$1:$A$7;B2));СЧЁТ(ПОИСК($A$8:$A$9;B2)));"Серый и Оранжевый";ЕСЛИ(СЧЁТ(ПОИСК($A$1:$A$7;B2));"Серый";ЕСЛИ(СЧЁТ(ПОИСК($A$8:$A$9;B2));"Оранжевый";"нет совпадений")))

Спасибо. правда формулы массива не мой конек, буду разбираться, как с ними работать, если скопировать в другую книгу. У вас в книге все отлично работает

Автор - Маруся4104
Дата добавления - 25.01.2022 в 22:30
Pelena Дата: Вторник, 25.01.2022, 22:38 | Сообщение № 4
Группа: Админы
Ранг: Местный житель
Сообщений: 18550
Репутация: 4199 ±
Замечаний: ±

Excel 2016 & Mac Excel


"Черт возьми, Холмс! Но как??!!"
Ю-money 41001765434816
 
Ответить
Сообщение
Цитата Маруся4104, 25.01.2022 в 22:30, в сообщении № 3 ()
буду разбираться

Как разобраться в работе сложной формулы

Автор - Pelena
Дата добавления - 25.01.2022 в 22:38
Мир MS Excel » Вопросы и решения » Вопросы по Excel » Поиск части текста в ячейке по заданным условиям (Формулы/Formulas)
  • Страница 1 из 1
  • 1
Поиск:

Яндекс.Метрика Яндекс цитирования
© 2010-2022 · Дизайн: MichaelCH · Хостинг от uCoz · При использовании материалов сайта, ссылка на www.excelworld.ru обязательна!